Author Topic: Captcha doesn't like old browsers  (Read 1616 times)

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 167
  • Posts: 2331
    • View Profile
Captcha doesn't like old browsers
« on: October 28, 2018, 10:55:09 pm »
Had a report about someone trying to create an account here using FF 38ESR, probably the one that ships with ArcaOS, and can't get past the captcha due to too old a browser.
I take it the captcha is outsourced to Google. I told him to try changing user agent or contact Martin. Still something that will need fixing.
While on the subject, more sites seem to not work with our old browsers, yet changing the user agent makes them work, sites such as github.

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 36
  • Posts: 890
    • View Profile
Re: Captcha doesn't like old browsers
« Reply #1 on: October 29, 2018, 02:58:48 am »
Hi Dave

Am I right in thinking that there are a few variations of javascript? - and if "Yes" could it be that most websites use MS/Internet Explorers variation and that switching User Agent to Internet Explorer means that Seamonkey/Firefox uses the Internet Explorer javascript variant?

And, of course, there are a lot of websites that check which browser is in use and may not work or work properly if the browser/version is not in their "browser list".


Regards

Pete

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 447
  • -Receive: 91
  • Posts: 2553
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Captcha doesn't like old browsers
« Reply #2 on: October 29, 2018, 03:52:51 am »
Hi

I'm checking on that. It seems that Recaptcha was updated in some way that is incompatible with OS/2's browsers.
I had checked with Firefox 38.8.0 and it is not working.

I will check some other options.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 167
  • Posts: 2331
    • View Profile
Re: Captcha doesn't like old browsers
« Reply #3 on: October 29, 2018, 05:43:48 am »
Thanks Martin. Just tested with 45.9 and it seems to work, at least it showed images before I cancelled.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 167
  • Posts: 2331
    • View Profile
Re: Captcha doesn't like old browsers
« Reply #4 on: October 29, 2018, 05:50:46 am »
HI Pete. Generally the JavaScript compatibility has improved a lot between browsers with, I believe, Safari being the worst. The problem is JavaScript keeps evolving, so slowly old browsers will break. Really pages should test for capabilities rather then having a list but people are lazy or just don't know better.
Then there are sites like Github that seem to stop working for no good reason, except I guess being a Microsoft property now. In the case of Github, I just changed to the next ESR version, FF52, SM 2.49 and it started working though I guess there might be subtle breaks.
Until we get a newer browser, it is worth trying different user agents to see if it works.
Edit
OTOH, just tried FF38.8 as FF52 and still no captcha here so actually needs a newer browser
« Last Edit: October 29, 2018, 05:57:42 am by Dave Yeo »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 447
  • -Receive: 91
  • Posts: 2553
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Captcha doesn't like old browsers
« Reply #5 on: October 30, 2018, 04:04:33 am »
Hi

Yes, it works fine with Firefox 45. I'm checking the site plugin to see if there is something that can be improved, but I'm not sure if I can do more about it.

Regards

Martin Iturbide
OS2World NewsMaster
... just share the dream.

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 67
  • Posts: 553
    • View Profile
Re: Captcha doesn't like old browsers
« Reply #6 on: October 30, 2018, 04:13:34 pm »
I sometimes wonder if our browser had the option of manually changing the browser version that is reported to sites, more sites would allow access.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 167
  • Posts: 2331
    • View Profile
Re: Captcha doesn't like old browsers
« Reply #7 on: October 30, 2018, 04:42:32 pm »
Check out the user agent switcher extension. It fixes some sites, others, our browsers are too old for or too buggy for.