Author Topic: Webcam Support for OS/2 and eCS!!  (Read 90144 times)

Alex Taylor

  • Sr. Member
  • ****
  • Posts: 303
  • Karma: +0/-0
    • View Profile
Re: Webcam Support for OS/2 and eCS!!
« Reply #150 on: August 12, 2014, 04:09:56 am »
[00000280] Obtain Thread error!
Trying now on my W500.  I consistently get this error popup after about 3 seconds, using either uvcview or weblook. The camera light turns on but I get no picture (except the very first time I tried it, when I got a single frozen frame).

This webcam has a strange ??? range of alternate interface settings. Most webcams start with the lowest bandwidth for the lowest setting and end with the highest bandwidth for the highest setting. It seems that this camera has one specific alternate interface setting for each of the reported video stream format frames.

With the 640x480 programs you could try e.g. "uvcview /i8" or "uvcview /i1 /u"
With the 320x240 programs you could try e.g. "uvcview /i9" or "uvcview /i2 /u"


I've just tried all four of the above. There is no change with any of them except for 'uvcview /i9' with the 320x240 program, which briefly produces a still image for a few seconds before producing the same error popup.

BTW, I previously also tried (not with these new parameters) an external USB webcam on this system. It produces the exact same error. I'm not sure how uvcview selects between the two webcams, but it does appear to use the external in this case, as the light on the external camera goes on for a few seconds (instead of the light on the built-in camera, as normal).


  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
    • View Profile
Re: Webcam Support for OS/2 and eCS!!
« Reply #151 on: August 17, 2014, 06:27:43 pm »

I created rxusb.dll in order to be able test my usbcalls.dll and usbresmg.sys device driver.

It appears that your installation does not use my usbresmg.sys driver. You have to recheck your config.sys file again to see what file the device driver statement points to and to verify that it is my usbresmg.sys driver.

After working around this issue and with the latest release of usbresmgr/webview my cam now works in one mode.  Again thanks for the hard work making this possible !