OS/2, eCS & ArcaOS - Technical > Web applications

Firefox high mem

<< < (3/3)

André Heldoorn:
IIRC I always had Mozilla dictionary add-ons/plug-ins for FF/SM, and I'm not sure if I want to know where Hunspell data files have to be saved. Typing, FF and a 1 GHz Pentrium III CPU may be a fatal combination, but I tend to use and prefer SM anyway.

Hunspell may be faster than Mozilla's solutions, but it works with nothing but the DLL installed. It wasn't an intentional and tested choice (speeds, memory usage, ...). It was a matter of installing nothing but Yet Another Required And Unimported DLL, which worked.


--- Quote from: Dave Yeo on January 22, 2019, 11:13:32 pm ---I added LIBPATHSTRICT to my xxturbo's and they can co-exist. The original mozturbo doesn't have this and would need wrapping in a script to set LIBPATHSTRICT and BEGINLIBPATH if you want it to coexist with my builds.
--- End quote ---
Recently I was testing FFTURBO.EXE XOR SMTURBO.EXE, and MOZTURBO.EXE. I'll try to assign LIBPATHSTRICT=T and BEGINLBPATH=xxx to the MOZTURBO.EXE object in the <WP_START> folder first, with the same xxx an own install script assigns to Mozilla object(s) installed by eCS.

If that doesn't work, then I'll write a script. Perhaps even a delay (command "SLEEP.EXE 1 & SMTURBO.EXE") could work, to avoid some race condition or whatever.

FWIW: SYS2070s always happened with SMTURBO.EXE (not used with FFTURBO.EXE), after probably less than 5% of boots, it seems like SMTURBO.EXE was no longer in the tasklist when the SYS2070 popped up, and a reboot was required to browse.

Dave Yeo:
Hunspell is included with the Mozilla source and is compiled into SeaMonkey's xul.dll. The default en-US dictionary is in your SeaMonkey program directory under dictionaries. What you added were more dictionaries.
As for what else uses hunspell, see
--- Code: ---https://hunspell.github.io/
--- End code ---
, a surprising number of programs and even operating systems, including our port of OpenOffice I assume.
The data files for our hunspell port go into @UNIXROOT/usr/share/myspell. Myspell dictionaries are compatible.

What was the sys2070? So far I've only seen it with this build I'm using (unreleased) which is linked against the newest libcx when testing on a new install with an older libcx.
All the latest builds of FF, Sm, and TB set LIBPATHSTRICT in their own so scripts should be unneeded.

André Heldoorn:

--- Quote from: Dave Yeo on January 24, 2019, 12:30:45 am ---What was the sys2070?
--- End quote ---
FTR: solved. No more SYS2070s since using your MOZTURBO.EXE, replacing IBM's legacy MOZTURBO.EXE installed by eCS 1.x.

Navigation

[0] Message Index

[*] Previous page

Go to full version