OS/2, eCS & ArcaOS - Technical > Games

ArcaOS - Retro Gaming Machine

(1/13) > >>

Martin Iturbide:

Since there was some interest at Warpstock and on the forum taking about the potential of ArcaOS (and OS/2) as a "Retro Gaming Machine" that can run DOS and Win 3.1 games, I want to do some tests and configure my Thinkpad L420 for that.

I'm not much into DOS and Win16 these days, so my first question will be ask for tips and suggestion to enable the audio on DOS and Win-OS/2 for my machine. UniAud seems to be running as audio driver, but tips to configure it for DOS and Win16 are welcome.


Dave Yeo:
Lack of sound drivers for DOS and WinOS2 is the problem. Currently, as far as I know, there is no sound support for DOS, and little for WinOS2 on modern hardware.
I believe Arca Noae is planning Sound Blaster level support for DOS and WinOS2, using UniAud or the next sound driver. Hopefully they find time to implement it.
It was nice back in ISA days, with lots of sound card support.

Doug Bissett:
DOS WinOS2 won't even run on my newer machines (especially laptops, like my Lenovo T510, or L530), so the first thing to do, is see if it will run. Try both full screen, and windowed. Sometimes full screen will work, when windowed won't.

If it won't run, you can try DOSBOX (it is at HOBBES), which has worked pretty well, when I tried it (including sound). Of course, DOSBOX is available for other operating systems too. It has the advantage that it can run the latest Win 3.11, which OS/2 never could. You do need to install Win 3.11 in the supplied DOS environment. If you search the web, there is (perhaps 'was'), at least one, ready built win 3.11 package available for it.

Eugene Gorbunoff:
I agree that
OS/2 as Retro Gaming Machine 
could become perfect Area of OS/2 Usage. I see demand on old DOS games among simple Windows users. And they can spend some USD to such computer.

Yes, main barriers: SoundBlaster support in DOS VM, and problems of DOS VM on newer machines

Hi All

To have audio in DOD/Win16 sessions is possible when using uniaud. It requires the installation of another driver called DTA - Data Transport Agent.

The last version I used was 4.0a01. I think it was hosted on Rodericks site at 1 point but no idea where to find it now.

There is some info about it here https://ecsoft2.org/data-transport-agent-dta

I probably have a copy somewhere among my backups if required.




[0] Message Index

[#] Next page

Go to full version