Author Topic: AS400 and IBM Access Client Solution (ACS)  (Read 431 times)

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 7
  • -Receive: 24
  • Posts: 403
    • View Profile
    • Blonde Guy
AS400 and IBM Access Client Solution (ACS)
« on: February 04, 2019, 03:47:49 pm »
I've got a Affirmative Unicomp 1225T 5250 Model M 122-Key PS2 Buckling Spring Keyboard (See attachment for picture)

I had to hook it to the computer using a Belkin USB adapter. It seems to work. Is there anything I need to do to have the system recognize all 122 keys? I have ArcaOS 5.0.3 running, and the last version of Personal Communications.

I'm trying to support Access to an AS400.
Neil still using that old piece of shit? Is that a very old AS400 customer? Or does he have a later >=V7R1 release? If so i strongly suggest to use IBM i Access Client Solution (ACS in short). It's written in Java and works like a charm. I use it daily, as thats my main development job

regards
Silvan

This didn't go anywhere for me until now. The customer just upgraded his very old AS400. Now I should be able to use ACS. I have downloaded a copy of Access Client Solution, but I don't see how to start it using OS/2. Do you use a command file or something? I tried starting from command line:

{0}[k:\programs\iaccess] java -jar acsbundle.jar
java.lang.UnsupportedClassVersionError: com/ibm/iaccess/launch/AcsLaunchPad : Un
supported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
2)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: com.ibm.iaccess.launch.AcsLaunchPad. Program will
 exit.

« Last Edit: February 04, 2019, 05:05:54 pm by Neil Waldhauer »
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 165
    • View Profile
Re: AS400 and IBM Access Client Solution (ACS)
« Reply #1 on: February 04, 2019, 05:42:56 pm »
There is one drawback, you need to use a older version, as the latest is not running with out java :( I use version 1.1.6.2 build 7031 from January 2017. All later builds did crash for me as well.

And I use exactly the same command as you stated.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 7
  • -Receive: 24
  • Posts: 403
    • View Profile
    • Blonde Guy
Re: AS400 and IBM Access Client Solution (ACS)
« Reply #2 on: February 05, 2019, 02:06:00 am »
Thanks for your comment. I went to Google and found IBM i Access Client Solutions (32-bit) Version: 1.1.5.0 Build id: 5492. This seems to start and I am able to connect to the iSeries with a 5250 emulator.

I am looking to enable SSL, but I think something is missing on the host.

Neil
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 165
    • View Profile
Re: AS400 and IBM Access Client Solution (ACS)
« Reply #3 on: February 05, 2019, 08:52:03 am »
Thanks for your comment. I went to Google and found IBM i Access Client Solutions (32-bit) Version: 1.1.5.0 Build id: 5492. This seems to start and I am able to connect to the iSeries with a 5250 emulator.

I am looking to enable SSL, but I think something is missing on the host.

Neil
I can send you my version is you want. Please write me private if needed.

For SSL the host needs to have installed some license programs. If you need consulting for the i5 let me know as well.

regards
Silvan
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php