Author Topic: T420 and Intel 5100 Wifi  (Read 678 times)

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
T420 and Intel 5100 Wifi
« on: March 29, 2019, 07:06:13 pm »
How to get the Intel 5100 Wifi working in the T420.

1.) If you want to replace non-working standard Wifi-Card in the mini PCI slot under the keyboard, only buy a half-size 5100.
2.) If you want to use the half-size slot, you have to patch the BIOS.
     a.) Install the newest BIOS (as of now 1.56)
     b.) Install the corresponding patched BIOS (Google it) EDIT: The patched BIOS needs the check for the Wifi white list removed.
3.) Install the card under keyboard in the half-size slot or in the full-size slot.
4.) If you have a Linux live cd, test the installation. Normally, it should work out of the box.
5.) Download the test package of the Intel test package from here: https://www.os2world.com/wiki/index.php/GenMU.
6.) Rename the driver names  WRAPPER_8086_4232 from NETW5X32.* to NETW4X32.*
7.) Reboot and configure your network.

For me, that installation just works fine without fuss. (Except that the wired network doesn't seem to work anymore, but that doesn't bother me at the moment.
« Last Edit: March 29, 2019, 09:37:34 pm by Jochen Schäfer »

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 8
  • -Receive: 31
  • Posts: 460
    • View Profile
    • Blonde Guy
Re: T420 and Intel 5100 Wifi
« Reply #1 on: March 29, 2019, 09:29:50 pm »
I have a nice web page describing the process for a W500. It's nice to know it would work on a T420.

http://www.blondeguy.com/computer/hobopeep.html

I have no problem switching back and forth for WiFi and wired. I do find that to do that well, it has to start on wired.

 Does the BIOS on the T420 complain about a foreign adapter? There was no such complaint about the W500, but the W500 was available new with a 5100.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: T420 and Intel 5100 Wifi
« Reply #2 on: March 29, 2019, 09:36:36 pm »
It does, when you use the half-size slot and only use the original BIOS: The BIOS loudly complains and doesn't let you start the computer.
That's why I wrote, that you need the patched BIOS.
For the full size slot, you don't need that, but then again you lose the ability to use a SSD there.
« Last Edit: March 29, 2019, 09:39:14 pm by Jochen Schäfer »

Valery Sedletski

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 20
  • Posts: 306
    • View Profile
Re: T420 and Intel 5100 Wifi
« Reply #3 on: April 01, 2019, 10:45:47 am »
Hi all.

I bought T420 too, it was one month ago. Almost all devices are working with eCS 2.2, except wifi (my T420 has Intel PRO/Wireless 6205 a/g/n, 8086:0085 wifi card installed). Also, Intel HDA sound is semi-working (sometimes, I hear a startup sound during the boot, and sometimes I don't. I use uniaud from eCS 2.2 distribution. unimix sometimes says that it successfully set the sound volume, but sometimes it says "Failed")

For a wifi, I found a winxp driver, but I did not tamed it yet to work under GenMac. System just hangs on netbind.exe during the boot. Also, I tried to make it work with the Intel PRO/Wireless 4965 a/g/n driver. So far, driver loads ok, the log output in lantran.log is ok, but the MAC address shown is all zeroes. Also, XWLAN widget says It does not see any wifi card. So, I did not achieved any success with it so far. Gigabit LAN is working ok with e1000e driver, though. (I patched a table in the genm32.os2 driver accordingly, so GenMac now knows about my new card and which winxp driver it should use for it)

So, 5100 is still being sold? Good choice, I think (if so). I also have 4965 card on my older Thinkpad X61 Tablet, so I planned to swap wifi adapters on X61T and T420, but buying 5100 could be a better idea.
« Last Edit: April 01, 2019, 10:48:19 am by Valery Sedletski »

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: T420 and Intel 5100 Wifi
« Reply #4 on: April 01, 2019, 11:02:19 am »
I bought the 5100 used on eBay.
You can try to swap the 4965, but be prepared that the BIOS complains, if you install it in the half-size slot under the keyboard.
AFAIK, the full size slot doesn't get checked, but then again you are blocked from installing eg. an SSD.

Valery Sedletski

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 20
  • Posts: 306
    • View Profile
Re: T420 and Intel 5100 Wifi
« Reply #5 on: April 01, 2019, 01:30:07 pm »
2Jochen Schaefer: Yes, I know. But there are patched BIOS'es which have supported cards whitelist disabled. With my older X61T laptop, I had BIOS already patched with its previous owner. Need to check if a patched BIOS exists for T420, of course. Some info on this should be available at http://www.thinkwiki.org. So, 5100 is whitelisted?

IIRC, the half-sized slot is intended for 3g/4g WWAN cards, or for SSD's. It has PCI-express lines missing, only USB lines present. Full-size slot additionally supports PCI-express cards (like wifi ones).

Did you tried to install a 3G WWAN card into T420? Does T420 have a SIM card slot somewhere? X61T has it under the same cover where DIMM memory modules are installed. But I don't see the SIM slot under similar cover in T420.

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: T420 and Intel 5100 Wifi
« Reply #6 on: April 01, 2019, 04:03:27 pm »
No, the 5100 is not whitelisted on a T420 with a vanilla BIOS, that's why I added the patched BIOS requirement for the half-size slot.
Follow the link in the Thinkwiki. There you will find the correct BIOS with whitelisting turned off (and some other enhancements like RAM speed).

AFAIK, the full size slot is where normally the WWAN card would go. But I never had one, so I can't help you with the SIM location.