Author Topic: Weird behaviour for PDF viewer - during network access only  (Read 1678 times)

Herwig Bauernfeind

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 38
    • View Profile
Re: Weird behaviour for PDF viewer - during network access only
« Reply #15 on: April 26, 2019, 02:19:56 pm »
Just redid the tests using Lucide 1.4.0 (using popple66.dll) and qpdfview (with latest poppler) together with bitwise ndpsmb 2.3 and both setups work normally. Added that comment to the ticket as well.

hannos

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
    • View Profile
Re: Weird behaviour for PDF viewer - during network access only
« Reply #16 on: April 28, 2019, 09:06:29 pm »
Hi all,

same long loading times for PDFs from NAS using Lucide 1.40 or 1.41beta10 (more than 20 sec, no real difference which size the PDF is). Also OO docs are loading very slowly compared with a LAN connection to a WarpServer (just 1 sec loading time for PDF with Lucide!).
Samba client is from ArcaOS 5.03 or 4.10.0 on another computer (both with same results).

The "Details" tab within the properties shows for the NAS/samba connection: NDFS, block size 1024 and for the LAN connection: LAN, block size 4096.

After installing the new versions for libc (now 0.1.1-1) and libcx (now 0.6.5-1) speed is dramatically faster (about 2 sec instead of 21 sec!).

BUT: PMMail crashes with the new libc under some circumstance when accessing a folder (I have to take a deeper look into that, but looking into the log says that it's a problem with memory allocation)

Gregg Young

  • Jr. Member
  • **
  • Thank You
  • -Given: 1
  • -Receive: 6
  • Posts: 53
    • View Profile
Re: Weird behaviour for PDF viewer - during network access only
« Reply #17 on: April 28, 2019, 09:53:17 pm »


BUT: PMMail crashes with the new libc under some circumstance when accessing a folder (I have to take a deeper look into that, but looking into the log says that it's a problem with memory allocation)

I had this happen too. I believe it is caused by a corrupt message file in the folder. I had to remove some files from my inbox using FM/2 to get PMMail to load. I created a new folder and put some of the files in it returning others to the inbox. The inbox works but indexing the new folder traps. I haven't had time to track down the offending file.

Since I am trying to troubleshoot the Lucide issue I should note I am using the new libc also.

hannos

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 3
    • View Profile
Re: Weird behaviour for PDF viewer - during network access only
« Reply #18 on: April 29, 2019, 08:42:18 am »
Hi Gregg,

after downgrading to libc066.dll PMMail works again (this was to expect ... ;-) ).

When libc 0.1.1-1 is used, PMMail trap log shows:
Module:   LIBCN0
 Filename: D:\USR\LIB\LIBCN0.DLL (02/24/2019 20:54:00 1,158,654)
 Address:  005B:1C8B7186 (0001:00087186)
 Cause:    Attempted to read from 44C01C88
           (unallocated memory)
...
 EAX : not a valid address
 EBX : unallocated memory
 ECX : not a valid address
 EDX : read/write memory on this thread's stack
 ESI : read/write memory allocated by LIBCN0
 EDI : read/write memory allocated by PMMERGE

I do not know, if the crashes are basically with PMMail or libc ...
« Last Edit: April 29, 2019, 11:54:57 am by hannos »