OS/2, eCS & ArcaOS - Technical > Networking

Remote file browsing and management OS/2 -> Linux

(1/2) > >>

I recently setup Ubuntu as a File Server and for backup purposes. (Major home system revamp.)

So far, so good. I have two 4Tb drives in with one for storage and one for backups.

I can send and backup to the FS using rSync for the numerous small files and FTP/d for the larger files.

VINO/Desktop Sharing/PM VNC takes care of the remote desktop handling, (soon the FS will have no keyboard/monitor).

Now I just have a problem browsing/retrieving/handling/sending individual files while sitting at my main eCS desktop.

For the rest of my network, (all eCS), I have been using File Manager/2 along with NetDrive with the ftp option.

That works GREAT using Peter Moylen's FTPd, but using Ubuntu with vsFTPd or ProFTP, it is an abysmal failure!


Well, it works fine when you are only browsing the first two or three subdirectories; I have only to wait seconds. But, once I hit the next level, it ties up my desktop and I have to wait 20-30 minutes, for it to stop scanning; obviously, that makes it unusable.

I have many, many, files. It isn't a problem on the OS/2 side, because the setup works so well when connecting to an OS/2 machine.

Has anyone seen this problem before and if so, have you found a solution?

Samba is not really an option because my home LAN uses LAN Services a fair bit. It could be replaced with Samba again, (I tried it once before), but Samba has a problem in dealing the EAs; I had to dump it a couple of years back; I won't try again.


Doug Bissett:

--- Quote ---Samba is not really an option because my home LAN uses LAN Services a fair bit. It could be replaced with Samba again, (I tried it once before), but Samba has a problem in dealing the EAs; I had to dump it a couple of years back; I won't try again.


--- End quote ---

If you haven't tried SAMBA for a couple of years, I would suggest trying it again. It still has problems, but it is working much better now than it was even 6 months ago. FWIW, I have never had trouble with EA support, although I never tried it with Linux at the other end of the wire (I assume that Linux supports EAs, but I never checked that out. It may need to be enabled, somehow). EAs, other than in the desktop stuff, are mostly redundant anyway. Any program that thinks you need them, will recreate them.

Of course, SAMBA, the server, is quite different from the SAMBA client. You can use the client (EVFSGUI, that comes with eCS, but the updates at netlabs improve the reliability a lot), along side of the NETBIOS over TCPIP stuff. The SAMBA server does not get along with NETBIOS over TCPIP, because they both want to use the same ports. From what you say, the client should do what you want. You would need the server, if you want to use Linux to browse the eCS machine, although it might work with NETBIOS over TCPIP (I never tried it).

If I had only one eCS machine on one end and a Linux machine on the other, EAs would be of little import.

However, most of my machines are OS/2 in some variation, (where EAs are important), and you cannot run LAN Services and Samba at the same time; it is one or the other. Switching would simply cause too many problems.

I used Samba for years; I just had to give up on it. EAs, (especially with images), became just too big a problem. The last time I communicated with the authors of the OS/2 port, they were not working on that problem and had no plans to do so.

To do the switch is a lot of screwing around with a lot of machines with little hope of improvement, solving one thing at the cost of another.

It would seem to me that there might be a better way, but a solution is necessary... it is just a matter of what it is going to be.

Maybe trying PureFTP on might work. I mean, if FTPd under OS/2 can do it, surely something is available in Linux... unless whatever is causing my problem is at the core of what makes Linux, Linux.

Really, it is just a matter of me finding the time and dredging up a solution.

I was just hoping that someone else had done the grunt work and thus, could save me the time.

Dave Yeo:
The things with EAs (called xattrs under Linux) and Linux are it has to be enabled in the kernel, which it most likely is for most distributions, I believe it also has to be enabled when mounting a file system or in /etc/fstab and not all file systems support xattrs good enough for use with OS/2, eg ext2, ext3 and ext4 only support 4kbs of xattrs, some other file systems don't support any and only a few such as JFS support them well.
If you decide to use JFS, it's best to format under OS/2 as Linux supports the OS/2 version of JFS but OS/2 will not read Linux formatted JFS.
So they have to be enabled and you need to be using a file system that supports them and quite possibly Samba also needs to have them enabled.

Interesting information Dave, thanks for adding it.

My File Server has been up and running for a few weeks now and I had no choice but, to format the drives with ext4 using gpart in order to recognize the full drive; 4Tb.

But EAs aren't the problem for this setup, rather some means of being able to remotely browse deep layers of sub-directories with HUGE numbers of files. I am simply not willing to utilize Samba to solve this problem, because of the LAN-wide new problems I'd have with EAs on OS/2 machines.


[0] Message Index

[#] Next page

Go to full version