Author Topic: changing USB volume letter  (Read 804 times)

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
changing USB volume letter
« on: June 18, 2019, 02:49:01 pm »
Hi, I've made an USB stick detectable-handlable on OS2 W 4.52 (Virtualbox guest machine) with DFsee following the precious instructions received here.
Now I realized that the choosen drive letter (G) conflicts with the Shared Folder drive wich is G as well.  When plugged in, the USB volume functionality hangs after being automatically shifted to H letter, it remains locked and often make OS2 WPS not responding as well, so a letter change to a still unassigned drive letter appears to be the solution.
Can you suggest a way to just re-assign the USB volume letter avoiding the whole volume creation process in DFsee, that would wipe all data in it ?
Thank you

Neil Waldhauer

  • Sr. Member
  • ****
  • Thank You
  • -Given: 7
  • -Receive: 29
  • Posts: 429
    • View Profile
    • Blonde Guy
Re: changing USB volume letter
« Reply #1 on: June 18, 2019, 03:42:26 pm »
You can assign a drive letter without losing data by using Logical Volume Management (Simple) in the setup folder.

I think you can assign "None" and get the drive mounted with the next available letter.

I'm not sure how the assigned letter works for old Warp 4 systems, but I recall that it seems to ignore LVM and just mount the next available drive letter.
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: changing USB volume letter
« Reply #2 on: June 18, 2019, 03:56:44 pm »
You can assign a drive letter without losing data by using Logical Volume Management (Simple) in the setup folder.

I think you can assign "None" and get the drive mounted with the next available letter.

I'm not sure how the assigned letter works for old Warp 4 systems, but I recall that it seems to ignore LVM and just mount the next available drive letter.

thank you Neil, I'll try.
I believed could also use DFsee as well but eventually needed some hint

Lars

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 41
  • Posts: 395
    • View Profile
Re: changing USB volume letter
« Reply #3 on: June 18, 2019, 05:38:19 pm »
DFSee: "change LVM info" and then set '*' (without the '') as the drive letter. That equivalents to driveletter = None = the next available drive letter.

That is how I set up ALL my USB sticks and drives/partitions in order to avoid a driveletter conflict.

As to my USBMSD.ADD that can also mount "large floppy" formatted USB sticks: it also always sets the drive letter of the "fake" volume that it creates (for the 'large floppy' formatted USB stick) to '*' so that it will never conflict with any already used drive letters.

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: changing USB volume letter
« Reply #4 on: June 20, 2019, 07:33:20 am »
done, thanks both of you.
Tell you the truth, some issue still persists and it is not a Shared Folder conflict matter, since I've kept it turned off while testing the USB functionality.
After opened the USB volume and worked with its contents, even only subfolders opening/closing, then the system shut-down often fails, I've to force the guest machine shut down from the VBox menu. Restarting it, the USB volume cannot be used, I've to do the CHKDSK /F to have it working again. It seems like WPS goes in trouble after having browsed the USB volume, even if everything appears ok during its use.
« Last Edit: June 20, 2019, 07:37:04 am by mauro »

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 33
  • Posts: 968
    • View Profile
Re: changing USB volume letter
« Reply #5 on: June 20, 2019, 11:09:54 am »
Just a thought, you did eject the usb stick before you removed it?  If you didn't that will cause the chkdsk problem you are seeing.

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: changing USB volume letter
« Reply #6 on: June 20, 2019, 07:59:44 pm »
….mmmmh….. have to check this  :o

mauro

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 160
    • View Profile
Re: changing USB volume letter
« Reply #7 on: June 21, 2019, 08:17:05 pm »
Just a thought, you did eject the usb stick before you removed it?  If you didn't that will cause the chkdsk problem you are seeing.

right, that was what needed.
Sorry    :)

Valery Sedletski

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 20
  • Posts: 304
    • View Profile
Re: changing USB volume letter
« Reply #8 on: July 05, 2019, 01:02:10 pm »
Also, you can try a shared folder "drive letter pinning" feature:

Just create a vboxfs.cfg file in your \os2\boot directory, with the following contents:

Quote
exch            e:
os2f             f:
valerius       m:

etc. So, format is "<shared_folder_name>     <drive_letter>:".
So, all specified shared folders will take a specified drive letter. So, you could assign them the way they will not conflict.
« Last Edit: July 05, 2019, 03:24:20 pm by Valery Sedletski »