Author Topic: VirtualBox 5.0.51 for OS/2 error  (Read 474 times)

nyao

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 5
  • Posts: 34
    • View Profile
VirtualBox 5.0.51 for OS/2 error
« on: July 31, 2019, 05:07:37 pm »
Hi.all.
I tried to start Windows XP with Virtualbox, but I can not start because of the following error.
Thank you.

Failed to open a session for the virtual machine Win-XP.

Failed to load R0 module D:\VIRTUALBOX/VMMR0.r0: Unable to local imported symbol 'VBoxDrv.sys.RTMpOs2GetApiExt' for module 'VMMR0.r0' (VERR_SYMBOL_NOT_FOUND).

Failed to load VMMR0.r0 (VERR_SYMBOL_NOT_FOUND).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}


Valery Sedletski

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 20
  • Posts: 307
    • View Profile
Re: VirtualBox 5.0.51 for OS/2 error
« Reply #1 on: July 31, 2019, 06:54:10 pm »
Did you install VBoxDrv.sys? If yes, is it the latest version?

roberto

  • Sr. Member
  • ****
  • Thank You
  • -Given: 16
  • -Receive: 10
  • Posts: 472
    • View Profile
Re: VirtualBox 5.0.51 for OS/2 error
« Reply #2 on: July 31, 2019, 11:10:08 pm »
It would be nice to know if you could run it before and not now.
Or it is a new installation.
Or as the vbox version changed.
Or some other.


nyao

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 5
  • Posts: 34
    • View Profile
Re: VirtualBox 5.0.51 for OS/2 error
« Reply #3 on: August 01, 2019, 01:09:18 pm »
Thank you all.
I forgot to replace VBoxDrv.sys in C: \ OS2 \ BOOT.
After replacing, you will get a photo error but after closing it will succeed.

Failed to open a session for the virtual machine Win-XP.

The virtual machine 'Win-XP' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}


Valery Sedletski

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 20
  • Posts: 307
    • View Profile
Re: VirtualBox 5.0.51 for OS/2 error
« Reply #4 on: August 01, 2019, 11:35:47 pm »
#define VERR_INVALID_CPU_ID                 (-1018)

This means that invalid CPU ID is specified. On IBM kernels, CPU ID's are calculated as local APIC ID's. Unfortunately, this method
is unreliable, because sometimes CPU core's LAPIC ID's are not from 0..NCpuIDs interval. I think, this is your case. In my case,
my CPU has contiguous interval of LAPIC ID's, so you're unlucky. I'd suspect that you're using IBM's kernel? Unfortunately, IBM
kernels lack a reliable method of getting current CPU ID. OS/4 kernels have a specific KEE API for that. Also, OS/4 kernels have
API for CPU rendez-vous. This is required for enabling hardware virtualization (VT-x/AMD-V). IBM kernels also have no such
feature. So, in your case I'd suggest using OS/4 kernel.

PS: your error occurs when VBox switches to a CPU with a spectfic LAPIC ID. VBox assumes that CPU ID's are consecutive,
but in your case it's not (most probably).

PPS: You also can try pinning VBox executable to a 0 CPU, so it will not hit a hole in CPU ID's range.
« Last Edit: August 01, 2019, 11:41:08 pm by Valery Sedletski »