OS/2, eCS & ArcaOS - Technical > Internet

FF/SM parameters

(1/2) > >>

André Heldoorn:
WPProgram object #1, converted to CLI commands: C: & CD \SEAMONKEY & C:\SEAMONKEY\SEAMONKEY.EXE
WPProgram object #2, converted to CLI commands: C: & CD \SEAMONKEY & C:\SEAMONKEY\SEAMONKEY.EXE C:\TOOLS\openurls.html
WPProgram object #3, converted to CLI commands: C: & CD \SEAMONKEY & C:\SEAMONKEY\SEAMONKEY.EXE -search "\"hello world\"

While #1 is running, is it a (fixable) bug or missing feature that #2 opens an expected new tab but #3 doesn't?

I was trying to develop a simple fire & forget front-end to search without having to wait for a started browser first, and of course hardly better than using "-search "[Search for ...]" as a WPProgram parameter prompt, but one of the unexpected results was that a new search killed the browser and next restarted the browser again (WPProgram object #3 replaced) or didn't start at all (#3 updated). So apparently the started EXE is linked to the survival of its starter.

Dave Yeo:
Seems to work as expected here. With my setup, if SeaMonkey is running, it opens a new window, without it running it opens a new tab along with the previous session.

André Heldoorn:
Here it didn't. I'll try to reproduce it with a test...

André Heldoorn:
"Funny". Yesterday a different test app killed and restarted SM (replace existing WPProgram object), or moved the previous session to the foreground (update existing WPProgram object). The last parameter of SysOpenObject() made no difference. Perhaps the cause was running out of memory!?

At least the test code below still doesn't open a new tab here. If I open a local HTML file with another WPProgram object, then it opens a new tab per opened HTML file.

Save TEST.CMD in the directory of SEAMONKEY.EXE, and execute TEST.CMD twice. Do not execute the created object Test 1. Delete this object afterwards.

The attached images may save you the troubles. Executing TEST.CMD (SEAMONKEY.EXE -search "stupid question") twice, while typing this, results in 3 SM sessions. Executing OpenURLs (SEAMONKEY.EXE openurls.html" twice, while typing this, results in 2 new tabs.

So if the parameter of a SEAMONKEY.EXE WPProgram object is a HTML file, it opens a new tab. If the parameter is "-search something", then it doesn't. With the same SM setup.

--- Code: ---/* Test.CMD */

CALL RxFuncAdd 'SysCreateObject','RexxUtil','SysCreateObject'
CALL RxFuncAdd 'SysOpenObject','RexxUtil','SysOpenObject'


   SAY 'Error: SEAMONKEY.EXE not found in' dir

IF Right(dir,1)<>'\' THEN dir=dir||'\'
setup=setup||'-search "\"hello world\";OBJECTID=<Am_I_Wrong>'

IF SysCreateObject('WPProgram','Test 1','<WP_DESKTOP>',setup,'R')>0 THEN DO
   CALL SysOpenObject '<Am_I_Wrong>','DEFAULT','TRUE'

--- End code ---

Of course I've traditionally deleted the source code of the original search app, which killed and restarted SM...

Dave Yeo:
Worked here. Had a few seconds of one core at 100% CPU then a new window opened with the search terms. Whether it is a new window or new tab depends on your settings in Preferences-->Browser-->Internet Search, where I have nothing ticked as I prefer the search results in a new window.
Quite possible you are running out of memory when the new Seamonkey.exe starts, communicates with the one already running and closes after telling the already running one to display the search results (at least that is what I think happens).


[0] Message Index

[#] Next page

Go to full version