OS/2, eCS & ArcaOS - Technical > Internet

TOR and FF

(1/3) > >>

I'm trying to use TOR.
I installed it and it start well (ready) (with help of Vidalia)
I than tried to configure FF as it should using proxy, the given port used by TOR etc...
I tried 9050 - 9051 - 9150 - 9151 (DNS checked, no proxy for etc...
I never could get any web page under FF (38 or 45) using TOR !
How do you do to be able to use FF with TOR ?


Martin Iturbide:

Uhm.. my 2014 discussion notes are not working anymore.

General FYI:
Latest version is - updated 2019-05-11
available on: https://os2ports.smedley.id.au/index.php?page=tor

More comments are welcome.

Valery Sedletski:
2Remy: Unfortunately, it seems, proxies are broken in current versions of FF and SM. So, I won't be able to use Tor or any Http or
Socks proxy in FF / SM. Trying different proxy-related settings didn't help.

Dave Yeo:
How are proxies broken? I just started squid and am using it for a proxy and it seems to work.

Martin Iturbide:

I just tried it on Firefox 45.9.0, ArcaOS 5.0.4 and TOR
I configured the socks as the picture.

It is not working, but it seems to be something more related to DNS, if you call the IP directly you can get some pages, but if some other URL with DNS is called, you will get nothing on your screen.

Any tip is welcome.



[0] Message Index

[#] Next page

Go to full version