Author Topic: Qt 5 Base for OS/2  (Read 1105 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 393
  • -Receive: 79
  • Posts: 2376
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Qt 5 Base for OS/2
« on: August 14, 2019, 06:03:00 pm »
Hi

Qt5 first release is now available for download. It is not yet on the netlabs repository, but on the netlabs experimental repository. (I don't know the rules on when it is going to be on the normal repository).

I had installed as suggested: "yum install qt5-qtbase-examples" and rebooted.

I think it would be great if the community can start testing it out, reporting bugs/issues (I guess here), testing software, and even dreaming what Qt5 open source can be ported to OS/2. But it is also important to help funding this project (webshop or via Patreon page).

Regards

Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 393
  • -Receive: 79
  • Posts: 2376
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Qt 5 Base for OS/2
« Reply #1 on: August 14, 2019, 07:21:20 pm »
Hi

Looking around I found a list of Qt apps available (Qt4 and Qt5) for other platforms. Not all can be ported, but maybe there is something interesting ;)
- manjaro.org

Any other links or ideas are welcome.

Regard
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dmitriy Kuminov

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 16
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #2 on: August 14, 2019, 08:16:58 pm »
Martin, thanks for popping this up! A couple of notes:
- Qt 5 RPMs will be moved to the release repository later today.
- Qt 5 consists of modules and each module has its own repository and issue tracker. Per-module tickets should be reported to the module's issue tracker. Currently we only ported the QtBase module. Its issue tracker is located here: https://github.com/bitwiseworks/qtbase-os2/issues.

And here are the proper release notes btw: https://github.com/bitwiseworks/qtbase-os2/releases/tag/v5.11.0-os2-b1
« Last Edit: August 14, 2019, 08:44:48 pm by Dmitriy Kuminov »
CPO of bww bitwise works GmbH

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 35
  • Posts: 996
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #3 on: August 15, 2019, 05:08:23 pm »
A question, How backward compatible is it?  In other words will it run Qt 4 programs or do we need to keep our Qt 4 install?

I ask because I have about 25 Qt 4 programs that get from daily to weekly use.

Eugene Tucker

  • Jr. Member
  • **
  • Thank You
  • -Given: 25
  • -Receive: 3
  • Posts: 73
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #4 on: August 15, 2019, 06:25:27 pm »
I get this error trying to install the new Q5 libs. ERROR with transaction check vs depsolve:klusrmgr >= 1.2.2 is needed by libc-1:0.1.2-1.oc00.i686Please report this error at http://trac.netlabs.org/rpm/

Dmitriy Kuminov

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 16
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #5 on: August 15, 2019, 07:03:50 pm »
Qt 5 is not very backward compatible with Qt 4 but there are tools from Qt that simplify porting. But Qt 5 and Qt 4 apps can coexist so unless there are Qt 5 versions of your apps (which you should use then) you can still use Qt 4 versions.

Re the package error. Fixed, it will get deployed in 30 min or such.
CPO of bww bitwise works GmbH

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 35
  • Posts: 996
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #6 on: August 15, 2019, 10:19:36 pm »
Thank you Dmitriy, at least I can continue proof reading and editing, hopefully without problems.

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #7 on: August 16, 2019, 08:23:54 am »
I get this error: "Datei /@unixroot/usr/bin/pwd_mkdb.exe aus der Installation von libc-1:0.1.2-1.oc00.i686 kollidiert mit der Datei aus dem Paket klusrmgr-1.2.1-1.oc00.i686", meaning pwd_mkdb.exe is both in libc and klusrmgr.

Dmitriy Kuminov

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 16
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #8 on: August 16, 2019, 12:10:01 pm »
Jochen, how do you install things? `libc-1:0.1.2-1` depends on a newer `klusrmgr-1.2.2-1` which should be automatically dragged in (causing a klusrmgr update before libc) unless you do something special with custom yum/rpm flags.
CPO of bww bitwise works GmbH

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #9 on: August 16, 2019, 02:29:47 pm »
With ANPM. I start the upgrade. Libc stops the installation with the message, that I must reboot and then start update again.
I rebooted and restarted ANPM. Then comes the message.

klusrmgr 1.2.2 was installed (at least according to the RPM DB), but 1.2.1 was still there. I had to clean up the duplicates.
« Last Edit: August 16, 2019, 02:31:39 pm by Jochen Schäfer »

Dmitriy Kuminov

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 16
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #10 on: August 16, 2019, 02:44:32 pm »
Jochen, I see. This looks like an ANPM bug to me. Please report this situation to their bug tracker at https://mantis.arcanoae.com/. (Apparently they should let the whole update process to complete and only then offer a reboot).
CPO of bww bitwise works GmbH

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #11 on: August 16, 2019, 02:57:05 pm »
OK, I will try update via yum, when I'm home again.

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #12 on: August 19, 2019, 12:37:39 pm »
OK, I will try update via yum, when I'm home again.
I think, I have to file this one via Netlabs.
yum update crashed midway. After a reboot, python couldn't import its SSL wrapper.
I had to unpack the RPM on linux and copy them over to my /@unixroot.
After that, yum was working again.

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 168
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #13 on: August 19, 2019, 04:38:00 pm »
OK, I will try update via yum, when I'm home again.
I think, I have to file this one via Netlabs.
yum update crashed midway. After a reboot, python couldn't import its SSL wrapper.
I had to unpack the RPM on linux and copy them over to my /@unixroot.
After that, yum was working again.
can you reproduce the issue? As w/o a reproducable case it's almost impossible to see what the issue could have caused. As to be honest we never got such a report so far. Which doesn't mean anything :)

regards
Silvan
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

Jochen Schäfer

  • Jr. Member
  • **
  • Thank You
  • -Given: 17
  • -Receive: 7
  • Posts: 99
    • View Profile
Re: Qt 5 Base for OS/2
« Reply #14 on: August 19, 2019, 05:19:14 pm »
Yes, I know. My daily work is trying to reproducing claims of misbehaving software.
I will try to reproduce the issue.