Author Topic: OpenOffice 4.1.6 fatal error, any solutions?  (Read 551 times)

Tuure Linden

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 2
  • Posts: 73
    • View Profile
OpenOffice 4.1.6 fatal error, any solutions?
« on: August 26, 2019, 11:01:50 am »
When trying to start OpenOffice, I'll get the following message. Is there any way to fix this?

OpenOffice 4.1.6 - Fatal Error

The application cannot be started.
exception occured raising singleton
"/singletons/com.syn.star.deployment.ExtensionManager": loading component library failed:
file://C:\PROGRAMS\APACHEOPENOFFICE.4/PROGRAM/../program/deploy.dll

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 171
    • View Profile
Re: OpenOffice 4.1.6 fatal error, any solutions?
« Reply #1 on: August 26, 2019, 12:16:35 pm »
When trying to start OpenOffice, I'll get the following message. Is there any way to fix this?

OpenOffice 4.1.6 - Fatal Error

The application cannot be started.
exception occured raising singleton
"/singletons/com.syn.star.deployment.ExtensionManager": loading component library failed:
file://C:\PROGRAMS\APACHEOPENOFFICE.4/PROGRAM/../program/deploy.dll
you miss libxml2. Install it via "yum install libxml2" or you can also use ANPM to do so of course.. ArcaOS doesn't deliver that by default. The readme should have pointed you to it btw.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 61
  • Posts: 515
    • View Profile
Re: OpenOffice 4.1.6 fatal error, any solutions?
« Reply #2 on: August 26, 2019, 08:24:26 pm »
I had the same problem when I first bought and installed it.  Silvan was quick to point out to me what I had missed.  The best source for programs and installation is

https://ecsoft2.org/

The best page for information is

https://ecsoft2.org/openoffice

The missing component was something I thought needed to be included in the ArcaOS install. I was told this would not happen.  Only those components that support the operating system.

Tuure Linden

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 2
  • Posts: 73
    • View Profile
Re: OpenOffice 4.1.6 fatal error, any solutions?
« Reply #3 on: August 27, 2019, 09:09:10 am »
No, libxml2 is already installed. That's not the problem. Of course I've installed dependencies mentioned in the documentation.

OpenOffice works fine with another computer of mine. But with this Lenovo ThinkCentre M73 it doesn't and gives the error message.

Tuure Linden

  • Jr. Member
  • **
  • Thank You
  • -Given: 4
  • -Receive: 2
  • Posts: 73
    • View Profile
Re: OpenOffice 4.1.6 fatal error, any solutions?
« Reply #4 on: August 27, 2019, 09:14:21 am »
According to eCSoft/2 site the missing library was libxslt. I hadn't installed it for some reason. But...

"Rpmdb checksum is invalid: dCDPT(pkg checksums): libxslt.i686 0:1.1.32-1.oc00 -u"

OpenOffice seems to work fine now however.