Author Topic: Firefox 45.9.0 can no longer play Youtube movies ?  (Read 8153 times)

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Firefox 45.9.0 can no longer play Youtube movies ?
« on: September 20, 2019, 08:09:16 am »
I can no longer get Firefox 45.9.0 to play Youtube movies. It used to work in the past but I cannot remember when that would no longer work.
Is this a known problem ? And is there a solution ?

OS4User

  • Sr. Member
  • ****
  • Thank You
  • -Given: 96
  • -Receive: 16
  • Posts: 306
  • Karma: +9/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #1 on: September 20, 2019, 10:06:33 am »
I can no longer get Firefox 45.9.0 to play Youtube movies. It used to work in the past but I cannot remember when that would no longer work.
Is this a known problem ? And is there a solution ?

Hi Lars

I have just checked  - it works here as usually.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #2 on: September 20, 2019, 12:37:32 pm »
Maybe I screwed something up about the configuration ("about:config"). Is there a way to reset the configuration to some "safe default" or do I need to create a new profile ?

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 613
  • Karma: +1/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #3 on: September 20, 2019, 02:39:32 pm »
You could try setting parameters: / safe-mode
Or refresh it
But the one that suits me best is the Seamonkey version 2.42.9 esr

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #4 on: September 20, 2019, 04:30:15 pm »
Maybe I screwed something up about the configuration ("about:config"). Is there a way to reset the configuration to some "safe default" or do I need to create a new profile ?

You can start with --safe-mode or go to about:support which gives a couple of options. The nuclear one is refresh which will reset your profile. There's other possible relevant info on that page.
Make sure you have the FFmpeg libs installed as well.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #5 on: September 20, 2019, 06:04:02 pm »
1) I did have FFMPEG installed
2) I now did a "Refresh Firefox" and that has fixed the problem.

Many thanks for your help !

Lars

Doug Clark

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 22
  • Posts: 227
  • Karma: +2/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #6 on: September 21, 2019, 05:14:46 pm »
I also have issues with 45.9.0 that seem to be related to the profile.

1) After working correctly for a while, the download will stop working. Or rather download to a specific location stops working. Downloading to the download folder continues to work
2) Firefox will just disappear while displaying a page.

Clearing out the profile will fix both problems - for awhile.


Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #7 on: September 21, 2019, 05:55:20 pm »
Firefox has always seemed somewhat fragile when it comes to downloading files, it was quite bad here when on dial-up, better now that most files download quick but I wouldn't try downloading something like an ISO. Rather use wget or the awget frontend.
As for vanishing, the usual questions, trp's, popup log entries, do you have it marked to use high memory, are you using mozturbo to keep the DLLs loaded?

Mike Kölling

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 6
  • Posts: 80
  • Karma: +4/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #8 on: September 22, 2019, 12:18:06 pm »
I am using Firefox for a long time by now. I started using when it was still named Firebird.
Download problems, like described, can take place when the space on the target drive to store the download is not sufficient to the downloaded file size.
By the way, I downloaded all my eCS and AOS ISOs with Firefox without any problems.
Mike

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #9 on: September 22, 2019, 09:22:50 pm »
I think downloading also depends on your network connection. I was on dialup until the other year and learned to use wget, which would often have to resume a download due to dropped packets or such.

Doug Clark

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 22
  • Posts: 227
  • Karma: +2/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #10 on: September 26, 2019, 05:37:11 am »
I am on an 80 mbs download speed connection - comcast cable

It is marked for loading into high memory. I do not use mozturbo. I don't know what trp or popup log is/are.

The issue exists for version 38 as well as version 45 - but happens more often with version 45.

I should be more specific on the download issue.  On the options - General page, if I select Downloads to "save files to" and specify a directory, the download will happen. If I select "Always ask me where to save files", when I try to download a file a dialog box comes up asking for me to chose: "Open With" or "Save file".  If I chose "Save File" and click OK nothing happens. If I chose "Open with" the download will happen.

Clearing out the profile (deleting everything in the mozilla home directory) makes everything work again. Sometimes for just a few hours. Sometimes for a few weeks.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 52
  • Posts: 1316
  • Karma: +13/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #11 on: September 26, 2019, 01:08:05 pm »
I can't help wondering if the CPU has some effect on what is being seen here.  On my Ryzen based machines I have no problems with firefox 38.8.0 as supplied with ArcaOS while firefox 45.9.0 does not appear to like the Ryzen processor and is very finicky on operation (it starts sometimes and generally runs each processor at 100% switching between processors at random).

The only drawback with firefox 38.8.0 is that some websites are using items it knows nothing about supposedly for security reasons.   

Roderick Klein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 26
  • Posts: 422
  • Karma: +6/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #12 on: September 26, 2019, 11:16:08 pm »
Or if everybody can make a donation to support the new web browser this can make live a lot easier in terms of browser support :-)

Over the last 12 months the Dutch OS/2 VOICE foundation has been funding BWW from Austria to port a new version of the QT library to OS/2/ArcaOS. With this we will able to get a new web browser on ArcaOS/OS/2 that will be current again.

However as we always say: free software does not grow on trees!
Open source software still needs a developer to make the software run on OS/2. And that is why we need your donations badly!

Currently its expected in November or December of this year a port of the Falkon browser will be released for OS/2 ArcaOS. For all the latest details please visit the following page:

http://articles.os2voice.org/category/software/24-new-web-browser-for-os-2-is-with-reach.html

Donations you can make it here:
http://www.os2voice.org/membership.html#bww

Thank you,

Roderick Klein
President OS/2 VOICE

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #13 on: September 27, 2019, 04:39:33 am »
I can't help wondering if the CPU has some effect on what is being seen here.  On my Ryzen based machines I have no problems with firefox 38.8.0 as supplied with ArcaOS while firefox 45.9.0 does not appear to like the Ryzen processor and is very finicky on operation (it starts sometimes and generally runs each processor at 100% switching between processors at random).

The only drawback with firefox 38.8.0 is that some websites are using items it knows nothing about supposedly for security reasons.

Doubt very much that it has anything to do with your CPU, but rather your profile. Have you tested a new one? I had this happen, suddenly one core was always pegged, couldn't fix it by playing with my profile and finally fixed it by reverting to a week old backup of my profile. 45ESR is somewhat fragile.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3110
  • Karma: +53/-0
    • View Profile
Re: Firefox 45.9.0 can no longer play Youtube movies ?
« Reply #14 on: September 27, 2019, 05:08:28 am »
I am on an 80 mbs download speed connection - comcast cable

It is marked for loading into high memory. I do not use mozturbo. I don't know what trp or popup log is/are.

POPUPLOG.OS2 will be in the root of your boot volume, trp files are usually in the programs directory and have a bunch of info about the program crash, especially if debug or xqs files are present.
Mozturbo is to work around a kernel bug. When a DLL is marked to load high and unloaded (program closed), the kernel doesn't correctly release the memory, leaving a zombie allocation. Open and close the program enough times and high memory will run out. I also wonder if the system misreports free memory to the program. Anyways this often results in the system crashing eventually. It's not really needed if you shutdown your computer regularly.

Quote
The issue exists for version 38 as well as version 45 - but happens more often with version 45.

I should be more specific on the download issue.  On the options - General page, if I select Downloads to "save files to" and specify a directory, the download will happen. If I select "Always ask me where to save files", when I try to download a file a dialog box comes up asking for me to chose: "Open With" or "Save file".  If I chose "Save File" and click OK nothing happens. If I chose "Open with" the download will happen.

Clearing out the profile (deleting everything in the mozilla home directory) makes everything work again. Sometimes for just a few hours. Sometimes for a few weeks.

'Tis a weird problem. Check that your TMP and TEMP settings point to somewhere with lots of room. You could try clearing the list of downloaded files regularly. Go to about:downloads and choose clear all (or such).