Author Topic: Qt 5 version 5.13.1 OS/2 Beta 1  (Read 4797 times)

TeLLie

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 71
    • View Profile
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #15 on: November 15, 2019, 02:04:29 pm »
Hi all,
I uploaded some new programs.
Please remember that those fprograms are hardly tested and you install them on you're own risk..
Also the Qt5 Os2 plugin don;t work fully for now, as f.e in help you try to run a url it dont work atm..

But if you like those programs please consider to donate to BWW as without them we would have this :)

http://www.bitwiseworks.com/shop/index.php?id_product=56&controller=product&id_lang=1


« Last Edit: November 15, 2019, 02:07:34 pm by TeLLie »

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 433
  • -Receive: 90
  • Posts: 2511
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #16 on: November 17, 2019, 04:23:22 pm »
Hi Tellie

Openshot (video edition tool) uses Qt 5. Can you take a look at it and see if can be easily ported or if it requires more work?
https://github.com/OpenShot

And also VideoCut, which seems smaller.
https://sourceforge.net/projects/vidcutter/

Regards
« Last Edit: November 17, 2019, 04:32:14 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

TeLLie

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 71
    • View Profile
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #17 on: November 17, 2019, 10:16:34 pm »
Hi Martin,
Those are files that need python, so i can not compile those...

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 164
  • Posts: 2302
    • View Profile
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #18 on: November 17, 2019, 11:06:24 pm »
Looks like, amongst other things, OpenShot uses Python 3 (something we're going to need a port of with Python2 coming to end of life) and the Openshot audio library.
VideoCutter is worse, uses libmpv (hardware accelerated MPlayer fork), and OpenGL for video rendering.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 433
  • -Receive: 90
  • Posts: 2511
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #19 on: November 17, 2019, 11:36:28 pm »
Thanks for the info.
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Paul Smedley

  • Sr. Member
  • ****
  • Thank You
  • -Given: 12
  • -Receive: 55
  • Posts: 476
    • View Profile
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #20 on: November 18, 2019, 02:57:16 am »
Hey Dave,

Looks like, amongst other things, OpenShot uses Python 3 (something we're going to need a port of with Python2 coming to end of life) and the Openshot audio library.

I keep meaning to look at Python 3 again. It's made harder now as I think it was 3.2.x was the last that included any of the old OS/2 patches.

Cheers,

Paul.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 433
  • -Receive: 90
  • Posts: 2511
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #21 on: January 29, 2020, 01:26:34 am »
Hi

I'm trying to run CuteChess.exe (from Tellie's ports), but I get this error:
 - SYS1804: The system cannot find the file QT5SVG.
Do you know which Qt5 package has this file? Because it seems to me that I installed all the Qt5 packages.


Regards
« Last Edit: January 29, 2020, 02:32:52 am by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Laurence Pithie

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 3
  • Posts: 38
    • View Profile
Re: Qt 5 version 5.13.1 OS/2 Beta 1
« Reply #22 on: January 29, 2020, 03:29:56 am »
qt5-qtsvg-devel contains Qt5Svg.lib and qt5-qtsvg contains the Qt5Svg.dll and the plugins/qsvg.dll