Author Topic: Tea - Hunspell errors  (Read 1227 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 488
  • -Receive: 96
  • Posts: 2695
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Tea - Hunspell errors
« on: December 12, 2019, 12:41:05 am »
Hi

I'm running the Tea text editor (yum install tea).

When I run it I got the following hunspell errors.
Quote
error: \usr\share\hunspell\en.aff: cannot open
error: \usr\share\hunspell\en.dic: cannot open
error: \usr\share\hunspell\en.aff: cannot open

I have installed the Hunspell dictionary. Hunspell installed the dictionaries on "usr/share/myspell"

Another issue seems to be like that tea is looking for "en.aff" and others, while on /myspell it is "en-US.aff".

Is this problem hardcoded on the tea port? or is there a way to solve this error?

Regards

« Last Edit: December 12, 2019, 12:47:27 am by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 44
  • Posts: 997
    • View Profile
Re: Tea - Hunspell errors
« Reply #1 on: December 12, 2019, 02:10:33 am »
Hi Martin

If I understand you correctly you have usr/share/myspell/en-US.aff installed but Tea is looking for \usr\share\hunspell\en.aff

Sounds like a bit of a mixup...

Maybe this will work:  create \usr\share\hunspell then copy usr/share/myspell/en-US.aff to \usr\share\hunspell\en.aff


Regards

Pete

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 174
  • Posts: 2470
    • View Profile
Re: Tea - Hunspell errors
« Reply #2 on: December 12, 2019, 03:47:02 am »
Sounds like a ticket is needed. Not sure whether Tea should be adjusted or Hunspell should have some symlinks for apps like Tea.

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 178
    • View Profile
Re: Tea - Hunspell errors
« Reply #3 on: December 12, 2019, 07:06:45 am »
Sounds like a ticket is needed. Not sure whether Tea should be adjusted or Hunspell should have some symlinks for apps like Tea.
no no no ticket for that. all works as designed when nothing is set.
you need to set "spell_lang" and "hunspell_dic_path" in the settings. At least thats what the code says.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 17
  • -Receive: 12
  • Posts: 513
    • View Profile
Re: Tea - Hunspell errors
« Reply #4 on: December 12, 2019, 04:21:44 pm »
If i try to install with anpm that give me:
ERROR en el chequeo de la transacción vs resolución de dependencias:poppq51.dll es necesario por tea-50.0.4-1.oc00.i686Por favor, informe este error en http://trac.netlabs.org/rpm/

TeLLie

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 79
    • View Profile
Re: Tea - Hunspell errors
« Reply #5 on: December 12, 2019, 06:38:34 pm »
Hi Roberto,

If you want to use the poppler that is needed for latest tea, you need to install netlabs.repo

Please do with anpm and install the netlabs repo.
If you don't want to do, download then the zip file.

http://rpm.netlabs.org/experimental/00/zip/poppler-0_61_1-1_oc00.zip
Inside is the dll


roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 17
  • -Receive: 12
  • Posts: 513
    • View Profile
Re: Tea - Hunspell errors
« Reply #6 on: December 12, 2019, 07:58:14 pm »
Double thanks Tellie, for your comment and for the ports. Now I understand I had the experimental report * deactivated * when activated, I have seen a lot of pending updates.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 174
  • Posts: 2470
    • View Profile
Re: Tea - Hunspell errors
« Reply #7 on: December 12, 2019, 09:28:01 pm »
Careful with the NSS and NSPR updates, reports of instability and the updated NSS breaks some HTTPS sites on FF38 and friends.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 488
  • -Receive: 96
  • Posts: 2695
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Tea - Hunspell errors
« Reply #8 on: December 12, 2019, 10:00:06 pm »
Hi

I found "tea.conf" on the C:\Home\Tea\

I added:
- spell_lang=en_US
- hunspell_dic_path=hunspell_dic_path=C:/usr/share/myspell

The errors are now gone.
When I close Tea I got this message:
Quote
[C:\]tea
rvln::~rvln()

But now I'm noticing that copy+paste is not working. Is anybody experiencing that ?

Regards
« Last Edit: December 12, 2019, 10:03:44 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 39
  • Posts: 1151
    • View Profile
Re: Tea - Hunspell errors
« Reply #9 on: December 13, 2019, 01:43:34 am »
Hi Martin,

What version of Tea are you using?  Here I have v36.0.2 and everything works without problems.

I assume that later versions follow the setup that the version I have - if so then you need to open the 'Tune' tab and select 'functions'.  There you fill in the information in the spell check section.

TeLLie

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 79
    • View Profile
Re: Tea - Hunspell errors
« Reply #10 on: December 14, 2019, 11:09:35 am »
Hi all,

There will be a new version soon, that would fix some of the errors that been showed here...

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 17
  • -Receive: 12
  • Posts: 513
    • View Profile
Re: Tea - Hunspell errors
« Reply #11 on: December 14, 2019, 04:45:21 pm »
Careful with the NSS and NSPR updates, reports of instability and the updated NSS breaks some HTTPS sites on FF38 and friends.
After updating my system, I see that the Seamonkey closes very frequently.User agent: Mozilla / 5.0 (OS / 2; Warp 4.5;
 rv: 45.0) Gecko / 20100101 Firefox / 45.0 SeaMonkey / 2.42.9esr
Build identifier: 20190601192153

So I decide to change the tcpip, and add in Host name, the ip of my pc with the host name of this computer to host list.
And the number of closures decreases a lot.