Author Topic: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install  (Read 1032 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 432
  • -Receive: 90
  • Posts: 2509
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« on: January 02, 2020, 04:35:45 am »
Hi

I'm trying to install ANPM and with it RPM/YUM on a VM with Warp 4.52  (14.106).
I'm stuck on a loop trying to install RPM/YUM (Pic 1-Loop.png). The only strange thing that I see is that when it asks me to shut down (and I click OK), REXXAPI.DLL give me an error (2-Error.png).

Any ideas?

Regards
« Last Edit: January 02, 2020, 04:42:45 am by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 164
  • Posts: 2302
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #1 on: January 02, 2020, 05:19:31 am »
Duplicate REXXAPI.DLL? Or similar with the older one taking precedence.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 15
  • Posts: 648
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #2 on: January 02, 2020, 04:16:55 pm »
Hi Martin,

It's been a while since I went through this, but I started with 4.52 as well, so here are some suggestions:

1) Take a look at the main AN RPM/YUM Wiki
https://www.arcanoae.com/wiki/anpm/

2) Take a look at the AN RPM/YUM 'Best Practices'
https://www.arcanoae.com/wiki/anpm/rpm-yum-best-practices/

3) Take a look at the AN 'Non-Updated Systems' Wiki
https://www.arcanoae.com/wiki/anpm/non-updated-systems/

4) Take a look at the AN 'How to install ANPM when there is an existing Python installation'
https://www.arcanoae.com/wiki/anpm/install-anpm-existing-python-installation/

This actually was something that I ran into, so we documented the work-around in that Wiki.

Here are the various REXXxxx DLLs I have on my system, all present in the \os2\dll :

Directory of G:\os2\dll

 9-06-00  12:42p    266031           0  REXX.DLL
 9-06-00  12:42p     40995           0  REXXAPI.DLL
 9-06-00  12:42p     79348           0  REXXCRT.DLL
 9-06-00  12:42p      8360           0  REXXINIT.DLL
 9-06-00  12:42p     68119           0  REXXUTIL.DLL

REXXAPI.DLL is only present in that single location.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 432
  • -Receive: 90
  • Posts: 2509
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #3 on: January 02, 2020, 04:25:00 pm »
Hi

I just checked the REXX*.DLLs and I only have one and I'm on the same level.

By the way, I'm installing ANPM 1.0.4.

I also checked the POPUPLOG (Attached pic)

Regards
« Last Edit: January 02, 2020, 04:31:44 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Andreas Schnellbacher

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 26
  • Posts: 464
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #4 on: January 02, 2020, 07:02:16 pm »
Have you checked the prerequisites? Is kLIBC Pathrewriter installed?

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 432
  • -Receive: 90
  • Posts: 2509
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #5 on: January 02, 2020, 09:21:47 pm »
Have you checked the prerequisites? Is kLIBC Pathrewriter installed?

...no... it is not installed  :-[

I installed it, rebooted, and run again ANPM, follow the RPM/YUM first install procedure again and got the same error :(

I also notices that at this instance of the install, the config.sys still do not have the path for usr/lib and any others, while the usr/lib directory had been created and populated with some files like yum.exe and rpm.exe. Also, not home directory on the config.sys yet.

Regards

Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 432
  • -Receive: 90
  • Posts: 2509
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #6 on: January 02, 2020, 09:32:22 pm »
Hi

I got some progress. I set usr/lib on my libpath and rebooted. Turned on ANPM and it complains that is not right and will try to fix my config.sys, he did it. Rebooted again and now it works...

But.. I don't know what is trying to access the D: drive (which is empty, no partition, not mounted) and gives me this errors frequently.  (See attached). But not only on ANPM, on startup.cmd is also tryuing to access D: while is nothing calling d: there.   This VM has a C: drive only and vm CD-ROM mounted on e:

I will be reverting the VM and try to install ANPM again.

Regards
« Last Edit: January 02, 2020, 09:43:53 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 432
  • -Receive: 90
  • Posts: 2509
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #7 on: January 02, 2020, 09:55:26 pm »
uhm.. something is wrong with the VM

Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 432
  • -Receive: 90
  • Posts: 2509
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #8 on: January 02, 2020, 10:12:13 pm »
The installation of klib pathwire triggered the errors from D: drive.

It added this on the config.sys.
  SET LIBC_HOOK_DLLS=C:\OS2\DLL\klibccfg.dll@_kLIBCInitPath!pathrewrite

Any hints?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 15
  • Posts: 648
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #9 on: January 02, 2020, 10:40:44 pm »
Martin,

The installation of klib pathwire triggered the errors from D: drive.

It added this on the config.sys.
  SET LIBC_HOOK_DLLS=C:\OS2\DLL\klibccfg.dll@_kLIBCInitPath!pathrewrite

Do you have 'kLIBC Pathwriters' installed? If so, what are the actual kLIBC path mappings you see?

See what I have currently defined on my machine...not saying this is 100% correct, but that's what present there along with the following environment setups in my CONFIG.SYS (FYI - Y:\ is my ramdisk, G:\ is my OS2 partition):

Code: [Select]
REM [ Temporary and Log directory ]
SET TMPDIR=G:\var\tmp
SET TEMP=Y:\TMP
SET TMP=Y:\TMP
SET FT2_LOGGING_FILEBASE=G:\TMP\LOG
SET LOGFILES=G:\TMP\LOG
...
REM [ Below are the YUM_RPM & ArcaNoae Package Manager variables ]
SET YUM_RPM_ETC=G:\ETC
SET UNIXROOT=G:
SET LIBC_HOOK_DLLS=G:\OS2\DLL\klibccfg.dll@_kLIBCInitPath!pathrewrite

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 432
  • -Receive: 90
  • Posts: 2509
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #10 on: January 02, 2020, 11:22:43 pm »
Hi

The 'kLIBC Pathwriters' that I installed (klibccfg_1_0_2_1.exe) did not added TEMP, TMPDIR, LOGFILES on the config.sys.

I add those manually and the D: drive issues are gone.

Thanks. I will keep testing the ANPM.
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Andreas Schnellbacher

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 26
  • Posts: 464
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #11 on: January 03, 2020, 01:53:54 am »
The 'kLIBC Pathwriters' that I installed (klibccfg_1_0_2_1.exe) did not added TEMP, TMPDIR, LOGFILES on the config.sys.

I add those manually and the D: drive issues are gone.
Strange. I've just checked the installation .wis script. It contains:
Code: [Select]
      REGISTERCLASS="kLIBCConfig|$(1)\klibccfg.dll"
      CREATEOBJECT="REPLACE kLIBCConfig|kLIBC Pathrewriters|<WP_CONFIG>|OBJECTID=<WP_KLIBCPRW>"
      CONFIGSYS="SET LIBC_HOOK_DLLS=$(1)\klibccfg.dll@_kLIBCInitPath!pathrewrite"
      WRITEPROFILE="$(ETC)\klibcfg.ini\REWRITE\/etc|%ETC%"
      WRITEPROFILE="$(ETC)\klibcfg.ini\REWRITE\/var/log|%LOGFILES%"
      WRITEPROFILE="$(ETC)\klibcfg.ini\REWRITE\/tmp|%TMP%"

That looks as if it should have added the CONFIG.SYS entry and created %ETC%\KLIBCFG.INI.

Travis Thoms

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 18
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #12 on: January 19, 2020, 02:31:17 am »
Hi Martin:

Do I understand correctly that you got ANPM to work?  I have the same problem that you reported initially, and have not found a resolution.  If it is working for you, could you walk me through how you did it?

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 51
  • Posts: 1282
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #13 on: January 19, 2020, 05:15:41 am »
Hi Martin:

Do I understand correctly that you got ANPM to work?  I have the same problem that you reported initially, and have not found a resolution.  If it is working for you, could you walk me through how you did it?

Please READ the section on ANPM, under SOFTWARE (page down), at https://www.arcanoae.com/wiki/.

Travis Thoms

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 4
  • Posts: 18
    • View Profile
Re: ANPM on Warp 4.52 - Error and Loop on RPM/YUM install
« Reply #14 on: January 19, 2020, 06:28:09 am »
Hi Doug:
    Thanks for the link.  I have read that page, and the software section.  Maybe I'm missing something, but none of the information seems to help my particular situation.