Author Topic: [fixed] NetDrive can't load module smbcln47??  (Read 742 times)

Mathias

  • Full Member
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 9
  • Posts: 161
  • using ArcaOS
    • View Profile
    • IRC
[fixed] NetDrive can't load module smbcln47??
« on: February 06, 2020, 02:18:48 pm »
Hello together,

worked until yesterday or so.. and now I try to mount a samba share, and it tells me about a network error. :o
Okay.. so I went and tried net use on the prompt... which also says something about error 50.

In the end I went and had a look at netdrive.. which works. I can attach and detach.
But: ndctl says:
Code: [Select]
NetDrive for OS/2(R) Control Program version 3.1.5.865 Apr 06 2017

NDFSDIR environment variable found: C:\Programs\NDFS
NetDrive working directory is C:\Programs\NDFS
File system driver name is NDFS32.
NetDrive configuration file 'C:\Programs\NDFS\ndctl.cfg' has been processed.

Exclusive Samba Use

[   local] internal plugin has been initialized.
NDF0033: The system can't load the module: SMBCLN47
NDF0029: [  ndpsmb] plugin has not been loaded.
NDF0007: The system error is SYS0002
Initialization completed. The control program is running.
NDF0016: Can't connect to file system driver.
NDF0015: NetDrive Control Program is already running.

The last two lines appear to be normal. On a second ArcaOS machine I did the same things, compared the output .. and it worked out there.

So.. I have two questions now:
1) what is SMBCLN47?
2) How to get that thing working again?

Config.sys wise...
- C:\PROGRAMS\NDFS is in LIBPATH
- C:\PROGRAMS\NDFS is in PATH
- IFS=C:\Programs\NDFS\NDFS32.IFS is set in config.sys and DOES exist on the file system (no error at OS boot, Net Drive message displays properly)
- SET NDFSDIR=C:\Programs\NDFS is set

Didn't change a thing, that I am aware of. Well.. I installed an update today via ArcaNoae Packet Manager: poppler (which should imo only have to do with PDF stuff)

Any ideas? @_@
« Last Edit: February 07, 2020, 11:22:43 am by Mathias »

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 43
  • Posts: 1174
    • View Profile
Re: NetDrive can't load module smbcln47??
« Reply #1 on: February 06, 2020, 03:02:31 pm »
Did you check that ndfs32.ifs is still in the 'programs\NDFS\ directory?  If not it should be and you need to find it and put it back there.

As an aside, I am very careful with using rpm/yum because it can mess up things. I learned that way back when I was using SUSE Linux and it was the reason I moved over to Linux mint and its 'deb' packages.

BTW,
SYS0002: The system cannot find the file specified.

EXPLANATION: The file named in the command does not exist in the
current directory or search path specified or the file name was
entered incorrectly.

ACTION: Retry the command using the correct file name.

Mathias

  • Full Member
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 9
  • Posts: 161
  • using ArcaOS
    • View Profile
    • IRC
Re: NetDrive can't load module smbcln47??
« Reply #2 on: February 06, 2020, 03:25:05 pm »
Yes, indeed. The ndfs32.ifs is still in that path.

Also it loads fine when the machine starts up. Displaying as normal at boot:
Code: [Select]
NDFS32 NetDrive for OS/2 File System Driver (Large Files), V3.028

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 17
  • -Receive: 12
  • Posts: 533
    • View Profile
Re: NetDrive can't load module smbcln47??
« Reply #3 on: February 06, 2020, 04:45:12 pm »
You could try changing these files, this is part of a previous ticket. Comment if it works for you or not.

In the C:\usr\lib\ these two dlls appeared

smbcln47.dll │ 9910862│28/04/18│10:19a
smbnetap.dll │ 267180│28/04/18│10:45a

Copy these four files, to c: \ usr \ lib Overwriting those of the same name and everything seems fine.
smbcln49.dll │ 9963156│09/06/19│10:00a
smbcln49.map │ 881613│09/06/19│10:00a
smbnetap.dll │ 264069│24/03/19│ 1:33a
smbnetap.map │ 83288│24/03/19│ 1:33a

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 17
  • Posts: 728
    • View Profile
Re: NetDrive can't load module smbcln47??
« Reply #4 on: February 07, 2020, 04:51:09 am »
Hi Mathias,

...
Code: [Select]
[   local] internal plugin has been initialized.
NDF0033: The system can't load the module: SMBCLN47
NDF0029: [  ndpsmb] plugin has not been loaded.
NDF0007: The system error is SYS0002
Initialization completed. The control program is running.
NDF0016: Can't connect to file system driver.
NDF0015: NetDrive Control Program is already running.

...

So.. I have two questions now:
1) what is SMBCLN47?
2) How to get that thing working again?

Does 'smbclient --version' at CLI return anything?

This will tell you what verison of Samba client you have installed.

The DLL you show is part of the Samba client install, on my machine it is part of a working 4.10.10 release.

Now, not sure if this is your issue but I've been consistently seeing the following with my NetDrive: all of a sudden my Samba connections just go 'dead'. As in, no WPS/Drive objects anywhere (which normally bring up NAS or other LAN boxes storage devices) show-up.

To fix I have to kill NDCTL, re-start NDCTL and all seems to be good. No trap anywhere, it's almost like something about the Samba client (or NDCTL) just dies.

Mathias

  • Full Member
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 9
  • Posts: 161
  • using ArcaOS
    • View Profile
    • IRC
Re: NetDrive can't load module smbcln47??
« Reply #5 on: February 07, 2020, 08:24:47 am »
Roberto & Dariusz, thank you guys! : ))

As for changing files on the file system I will create an image and try this on a virtual machine first. (might take a moment..) --> I'll report back with the results.

As for smbclient --version:
Code: [Select]
{0}[c:\] smbclient --version
Version 3.3.16-eCS 1.1.4-804

I havn't touched this for ages (as you can see). Also only installing release updates from ArcaNoae Packet Manager, never experimental things. (besides Firefox 45.x of course. :>)
Also I have to say, this effect occured like out of nowhere. In one moment it still worked fine, next moment, net drive didn't want to establish an smb connection anymore.

I never had ANY issues with ArcaNoae mapper, besides freezing the whole desktop when starting up that tool. I suppose this is due to the flickering down below in the task bar, opening and closing things very fast. (Maybe a problem with Panorama being unable to catch up? Not sure. - But this does not happen often.)

Mathias

  • Full Member
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 9
  • Posts: 161
  • using ArcaOS
    • View Profile
    • IRC
Re: NetDrive can't load module smbcln47??
« Reply #6 on: February 07, 2020, 08:58:49 am »
You could try changing these files, this is part of a previous ticket. Comment if it works for you or not.

In the C:\usr\lib\ these two dlls appeared

smbcln47.dll │ 9910862│28/04/18│10:19a
smbnetap.dll │ 267180│28/04/18│10:45a

Copy these four files, to c: \ usr \ lib Overwriting those of the same name and everything seems fine.
smbcln49.dll │ 9963156│09/06/19│10:00a
smbcln49.map │ 881613│09/06/19│10:00a
smbnetap.dll │ 264069│24/03/19│ 1:33a
smbnetap.map │ 83288│24/03/19│ 1:33a

Hmm.. I have taken the smbcln49.dll and smbnetap.dll from the ArcaOS-install-CD. (But no .MAP files there)
Copying these to C:\USR\LIB does not change anything (still SYS0002 file not found)
When renaming the smbcln49.dll to smbcln47.dll the error message stays the same, BUT then I'll get SYS0123 (A file or volume label contains an incorrect character). - I suppose the DLL does not match to some other stuff..

And: In C:\USR\LIB there was none of these files! I've searched whole C:\ for smbcln*.* and the only find was the smbclient folder, not containing any of these. (of course)

Mathias

  • Full Member
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 9
  • Posts: 161
  • using ArcaOS
    • View Profile
    • IRC
Re: NetDrive can't load module smbcln47??
« Reply #7 on: February 07, 2020, 10:01:01 am »
Upgraded from ArcaOS 5.0.3 via upgrade function to ArcaOS 5.0.4 - Now it demands smbcln49.dll, when running ndctl!
Very interesting. ArcaOS 5.0.3 --> smbcln47.dll, ArcaOS5.0.4 --> smbcln49.dll

Copy'ed over smbcln49.dll and smbnetap.dll again from the ArcaOS install CD to my local C:\USR\LIB, as you said - and it works now! :D

No idea how and why my ArcaOS suddenly forgot these two files (I hope it's only them?!).. but ndctl AND ArcaMapper is working nicely  again. *__* - Thanks Roberto!

BUT.... there is a new issue (how could it be just working fine?! xD) - After ArcaOS upgrade from 5.0.3 to 5.0.4 I have a dead icon on my (default IBM) launchpad showing as a green bubble with a white question mark on top. I cannot right-click that icon.. as there is no contect menu. - How can I get rid of this icon (or exchange with another application)?
It used to be the 4OS/2 command prompt window link, which magically does not work anymore. - But 4OS/2 does! Launching the 4OS/2 window works fine, via Desktop --> Command Prompts --> 4OS/2 (window)

Mathias

  • Full Member
  • ***
  • Thank You
  • -Given: 27
  • -Receive: 9
  • Posts: 161
  • using ArcaOS
    • View Profile
    • IRC
Re: NetDrive can't load module smbcln47??
« Reply #8 on: February 07, 2020, 11:22:00 am »
Fixed. --> Had to ...
- recreate the "Shredder"
- link it on the launchpad
- drag the weird question mark symbol to the shredder... and it was gone. (tried the same with trashbin... but that crashed everything, including the desktop. :D)

So... everything fixed now. : ]

Thanks guys!! You're great!