Author Topic: [RESOLVED] VoiceType on ArcaOS ?  (Read 720 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 488
  • -Receive: 96
  • Posts: 2696
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
[RESOLVED] VoiceType on ArcaOS ?
« on: March 11, 2020, 05:08:58 pm »
Hi

VoiceType was removed from OS/2 Warp 4 since the convenience packs (4.51). I think that long time ago (very long time ago) someone about installing VoiceType on Warp 4.5x or maybe eComStation. I  really don't remember if that happen or if I dream it. Anyways, I didn't even cared at that time.

Today, I don't know why I want to experiment if the old Warp 4 VoiceType can be installed in some way in ArcaOS. Just as a nice experiment, complete AS IS as un-supported on a experimental VM.

If someone has some tips or links, please let me know.

Regards
« Last Edit: March 13, 2020, 03:57:40 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Sigurd Fastenrath

  • Sr. Member
  • ****
  • Thank You
  • -Given: 16
  • -Receive: 72
  • Posts: 444
    • View Profile
Re: VoiceType on ArcaOS ?
« Reply #1 on: March 11, 2020, 09:39:51 pm »
Once you have no ecomstation CD 2:Everything you Need is here, and yes, it does work. Thanks to Alex Taylor.

https://comp.os.os2.apps.narkive.com/rDbQf0ev/re-install-works

And this way you can get all the saldy cut Supplements like Bonuspac, Warpguide etc etc from Warp 4.

If you have the ecs cd2, it is better to use that like Roderick stated.
« Last Edit: March 11, 2020, 09:41:49 pm by Sigurd Fastenrath »

Roderick Klein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 21
  • Posts: 345
    • View Profile
Re: VoiceType on ArcaOS ?
« Reply #2 on: March 11, 2020, 09:40:08 pm »
Check an eComStation CD 2 \BONTRIAL\IBMBON\vt.cmd. The rexx script is pretty simple if you ask me :-)

Roderick

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 488
  • -Receive: 96
  • Posts: 2696
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: VoiceType on ArcaOS ?
« Reply #3 on: March 12, 2020, 04:31:19 pm »
Thanks for the tip.

I run the script but get this error (attached). I tried it running from the CD image, and copying it (IBMBON) to my desktop with the same results.

I don't know where the error.log is stored to check it out.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Roderick Klein

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 21
  • Posts: 345
    • View Profile
Re: VoiceType on ArcaOS ?
« Reply #4 on: March 12, 2020, 10:28:04 pm »
Uhuu look at he error message and what the log path l1: is ? C:\var\log.
Is there no log file in that directory.

Roderick

Carmen Bland Sr.

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 1
    • View Profile
Re: VoiceType on ArcaOS ?
« Reply #5 on: March 13, 2020, 12:48:21 am »
Hi Martin,

After reading the posts yesterday, I attempted to install IBM Works and I too received the same error message. To get the install to run successfully, I created the folder structure "c:\ecs\install\rsp" then executed the install again - hope this helps.

Carmen

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 488
  • -Receive: 96
  • Posts: 2696
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: VoiceType on ArcaOS ?
« Reply #6 on: March 13, 2020, 02:01:53 am »
Hi

I found the log where Roderick says. C:\var\log\vt.l1

Quote
03/12/2020  10:27:27 am   2      [CLIFI failed to read the partial response file] C:\ECS\INSTALL\RSP\vt.rsp
03/12/2020  10:27:27 am   0      [CLIFI] Appending file CURRENT.LOG failed!

and vt.l2
Quote
03/12/2020  10:27:27 am   [CLIFI Feature Id]
03/12/2020  10:27:27 am   Object install Start
03/12/2020  10:27:27 am   [CLIFI] Object Build Start
03/12/2020  10:27:27 am   [CLIFI] Object Build End
03/12/2020  10:27:27 am   Response File modify BootDrive Start
03/12/2020  10:27:27 am   Response File modify BootDrive End
03/12/2020  10:27:27 am   Response File modify MediaDrive Start
03/12/2020  10:27:27 am   Response File modify MediaDrive End
03/12/2020  10:27:27 am   Object Install Completion, exiting


Following Carmen's advice, creating "c:\ecs\install\rsp"  made the installer work. I rebooted and it seems that the WPS classes were registered and it seems that the required files are installed on C:\vt.

Thanks for the feedback. I will be trying it to check it out.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.