Author Topic: YUM  (Read 824 times)

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 67
  • Posts: 598
    • View Profile
YUM
« on: March 22, 2020, 03:27:32 pm »
I was adding a RPM package (lzlib) when all the sudden I received a VX-REXX error code 009,  This has happened before.  When it happens, all the installed and uninstalled packages disappear from YUM.  I could not get them to show again.  The first time it happened, I reinstalled ArcaOS to get YUM working again.  This time, I  tried installing an archived desktop.  The archive worked and brought all the packages back to YUM.  I could see them again.  It also eliminated the error messages.

When this error happens, it continues to happen.  Anytime YUM is started, I continue to get this error code.

Has anyone else seen this?
« Last Edit: March 22, 2020, 04:04:11 pm by David Graser »

Andreas Schnellbacher

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 26
  • Posts: 503
    • View Profile
Re: YUM
« Reply #1 on: March 22, 2020, 07:37:48 pm »
In cases like that it's the best idea to export the packages list, wipe the dirs and reinstall everything.

Probably not related: I ran two times into serious problems, both caused by simple package updates. The first one is months ago and the last one just a few days:

ANPM refers to continue before rebooting each time I try to run update. The output of yum shows more:

Code: [Select]
epm: D:\ > set lang=en_US

epm: D:\ > yum update
Config time: 0.353
Yum Version: 3.4.3
COMMAND: yum update
Installroot: /@unixroot
Setting up Package Sacks
pkgsack time: 0.299
Reading Local RPMDB
rpmdb time: 0.002
Setting up Update Process
Updating Everything
Building updates object
up:Obs Init time: 0.963
putting rpm in simple update
putting bzip2 in simple update
putting libgmodule-2_0-0 in simple update
putting python in simple update
putting os2-tcpip in simple update
putting openssl in complex update
putting emxrt in simple update
putting libstdc++ in simple update
putting python-pycurl in simple update
putting perl-threads-shared in simple update
putting popt-data in simple update
putting libc in simple update
putting libtiff in simple update
putting freetype in simple update
putting libxslt in simple update
putting db4-utils in simple update
putting sqlite in simple update
putting ncurses-base in simple update
putting os2-mm in simple update
putting libpng in simple update
putting dash-sh in complex update
putting libxml2 in simple update
putting ash in simple update
putting cpio in simple update
putting libglib-2_0-0 in simple update
putting netlabs-rel in simple update
putting perl-Scalar-List-Utils in simple update
putting sed in simple update
putting nspr in simple update
putting gettext-legacy in simple update
putting rexx_exe in simple update
putting expat in simple update
putting dash in complex update
putting gmp in simple update
putting findutils in simple update
putting os2-mpts in simple update
putting mmap in simple update
putting cube in simple update
putting fontconfig-legacy in simple update
putting nss-softokn-freebl in simple update
putting glib2 in simple update
putting nss in simple update
putting popt in simple update
putting info in simple update
putting popt-libs in simple update
putting yum in simple update
putting libkai in simple update
putting libgcc-fwd in simple update
putting file in simple update
putting icu in simple update
putting hunspell in simple update
putting perl in simple update
putting db4 in simple update
putting libgobject-2_0-0 in simple update
putting grep in simple update
putting curl in simple update
putting perl-threads in simple update
putting odin-exe-tools in simple update
putting poppler-qt in complex update
putting patch in simple update
putting readline in simple update
putting python-libs in simple update
putting diffutils in simple update
putting file-libs in simple update
putting fontconfig in complex update
putting bash in simple update
putting urpo in simple update
putting libgthread-2_0-0 in simple update
putting perl-libs in simple update
putting exceptq in simple update
putting yum-metadata-parser in simple update
putting perl-PathTools in simple update
putting libicu in simple update
putting pthread in simple update
putting libvpx in simple update
putting libssp in simple update
putting coreutils in complex update
putting zlib in simple update
putting bzip2-libs in simple update
putting poppler in complex update
putting pcre in simple update
putting ncurses-libs in simple update
putting gzip in simple update
putting gettext-libs in simple update
putting unzip in simple update
putting nss-util in simple update
putting cups-libs in simple update
putting os2-base in complex update
putting which in simple update
putting libmpc3 in simple update
putting mpfr in simple update
putting zip in simple update
putting rpm-libs in simple update
putting tcl in simple update
putting nss-softokn in simple update
putting ncurses in simple update
putting libcurl in simple update
putting libodin in simple update
putting binutils in complex update
processing openssl
processing dash-sh
processing dash
processing poppler-qt
processing fontconfig
processing coreutils
processing poppler
processing os2-base
processing binutils
up:simple updates time: 0.026
up:obs time: 0.002
up:condense time: 0.000
updates time: 1.251
Not Updating Package that is already updated: hunspell.i686 0:1.7.0-1.oc00
Not Updating Package that is already updated: cups-libs.i686 1:2.1.3-10.oc00
Not Updating Package that is already updated: libc.i686 1:0.1.2-1.oc00
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package cups-libs.i686 1:2.1.3-10.oc00 will be updated
Checking deps for cups-libs.i686 1:2.1.3-10.oc00 - ud
---> Package cups-libs.i686 1:2.2.12-1.oc00 will be an update
Checking deps for cups-libs.i686 1:2.2.12-1.oc00 - u
looking for ('libcn0.dll', None, (None, None, None)) as a requirement of cups-libs.i686 1:2.2.12-1.oc00 - u
---> Package hunspell.i686 0:1.7.0-1.oc00 will be updated
Checking deps for hunspell.i686 0:1.7.0-1.oc00 - ud
---> Package hunspell.i686 0:1.7.0-2.oc00 will be an update
Checking deps for hunspell.i686 0:1.7.0-2.oc00 - u
---> Package libc.i686 1:0.1.2-1.oc00 will be updated
Checking deps for libc.i686 1:0.1.2-1.oc00 - ud
---> Package libc.i686 1:0.1.3-1.oc00 will be an update
Checking deps for libc.i686 1:0.1.3-1.oc00 - u
---> Package poppler.i686 0:0.59.0-3.oc00 will be obsoleted
Checking deps for poppler.i686 0:0.59.0-3.oc00 - od
poppler-qt-0.59.0-3.oc00.i686 requires: poppler = 0.59.0-3.oc00
--> Processing Dependency: poppler = 0.59.0-3.oc00 for package: poppler-qt-0.59.0-3.oc00.i686
Potential Provider: poppler.i686 0:0.59.0-3.oc00
Mode is od for provider of poppler = 0.59.0-3.oc00: poppler.i686 0:0.59.0-3.oc00
Mode for pkg providing poppler = 0.59.0-3.oc00: od
Trying to update poppler-qt-0.59.0-3.oc00.i686 to resolve dep
No update paths found for poppler-qt-0.59.0-3.oc00.i686. Failure!
Searching pkgSack for dep: poppler
poppler-0.59.0-3.oc00.i686 is in providing packages but it is already installed, removing.
---> Package poppler-legacy-70.i686 0:0.59.0-3.oc00.L will be obsoleting
Checking deps for poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('jpeg8.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('freetyp6.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('tiff5.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('z1.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('libcx0.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('doscalls.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('smime3.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('openjp27.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('gcc1.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('lcms22.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('nss3.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('pthr01.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('stdcpp6.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('libc066.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('png1616.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('nspr4.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
looking for ('fntcnf1.dll', None, (None, None, None)) as a requirement of poppler-legacy-70.i686 0:0.59.0-3.oc00.L - u
--> Finished Dependency Resolution
Dependency Process ending
SKIPBROKEN: poppler-qt-0.59.0-3.oc00.i686 from installed has depsolving problems
SKIPBROKEN:  --> Package: poppler-qt-0.59.0-3.oc00.i686 (installed)
  -->     Requires: poppler = 0.59.0-3.oc00
  -->     Removing: poppler-0.59.0-3.oc00.i686 (installed)
  -->         poppler = 0.59.0-3.oc00
  -->     Obsoleted By: poppler-legacy-70-0.59.0-3.oc00.L.i686 (netlabs-rel)
  -->         poppler = 0.59.0-3.oc00.L
  -->     Installed: poppler-0.61.1-1.oc00.i686 (installed)
  -->         poppler = 0.61.1-1.oc00
  -->     Installed: poppler-legacy-65-0.49.0-2.oc00.L.i686 (installed)
  -->         poppler = 0.49.0-2.oc00.L
  -->     Installed: poppler-legacy-66-0.52.0-1.oc00.L.i686 (installed)
  -->         poppler = 0.52.0-1.oc00.L
  -->     Available: poppler-0.26.5-1.oc00.i686 (netlabs-rel)
  -->         poppler = 0.26.5-1.oc00
  -->     Available: poppler-0.26.5-2.oc00.i686 (netlabs-rel)
  -->         poppler = 0.26.5-2.oc00
  -->     Available: poppler-0.26.5-3.oc00.i686 (netlabs-rel)
  -->         poppler = 0.26.5-3.oc00
  -->     Available: poppler-0.29.0-0.oc00.i686 (netlabs-rel)
  -->         poppler = 0.29.0-0.oc00
  -->     Available: poppler-0.31.0-1.oc00.i386 (netlabs-rel)
  -->         poppler = 0.31.0-1.oc00
  -->     Available: poppler-0.33.0-1.oc00.i386 (netlabs-rel)
  -->         poppler = 0.33.0-1.oc00
  -->     Available: poppler-0.35.0-1.oc00.i386 (netlabs-rel)
  -->         poppler = 0.35.0-1.oc00
  -->     Available: poppler-0.38.0-1.oc00.i386 (netlabs-rel)
  -->         poppler = 0.38.0-1.oc00
  -->     Available: poppler-0.38.0-2.oc00.i686 (netlabs-rel)
  -->         poppler = 0.38.0-2.oc00
  -->     Available: poppler-0.38.0-3.oc00.i686 (netlabs-rel)
  -->         poppler = 0.38.0-3.oc00
  -->     Available: poppler-0.42.0-2.oc00.i686 (netlabs-rel)
  -->         poppler = 0.42.0-2.oc00
  -->     Available: poppler-0.47.0-1.oc00.i686 (netlabs-rel)
  -->         poppler = 0.47.0-1.oc00
  -->     Available: poppler-0.49.0-1.oc00.i686 (netlabs-rel)
  -->         poppler = 0.49.0-1.oc00
  -->     Available: poppler-0.49.0-2.oc00.i686 (netlabs-rel)
  -->         poppler = 0.49.0-2.oc00
  -->     Available: poppler-0.52.0-1.oc00.i686 (netlabs-rel)
  -->         poppler = 0.52.0-1.oc00
  -->     Available: poppler-0.59.0-2.oc00.i686 (netlabs-rel)
  -->         poppler = 0.59.0-2.oc00
  -->     Available: poppler-legacy-63-0.47.0-1.oc00.L.i686 (netlabs-rel)
  -->         poppler = 0.47.0-1.oc00.L
Depsolve time: 0.410
Error: Package: poppler-qt-0.59.0-3.oc00.i686 (installed)
           Requires: poppler = 0.59.0-3.oc00
           Removing: poppler-0.59.0-3.oc00.i686 (installed)
               poppler = 0.59.0-3.oc00
           Obsoleted By: poppler-legacy-70-0.59.0-3.oc00.L.i686 (netlabs-rel)
               poppler = 0.59.0-3.oc00.L
           Installed: poppler-0.61.1-1.oc00.i686 (installed)
               poppler = 0.61.1-1.oc00
           Installed: poppler-legacy-65-0.49.0-2.oc00.L.i686 (installed)
               poppler = 0.49.0-2.oc00.L
           Installed: poppler-legacy-66-0.52.0-1.oc00.L.i686 (installed)
               poppler = 0.52.0-1.oc00.L
           Available: poppler-0.26.5-1.oc00.i686 (netlabs-rel)
               poppler = 0.26.5-1.oc00
           Available: poppler-0.26.5-2.oc00.i686 (netlabs-rel)
               poppler = 0.26.5-2.oc00
           Available: poppler-0.26.5-3.oc00.i686 (netlabs-rel)
               poppler = 0.26.5-3.oc00
           Available: poppler-0.29.0-0.oc00.i686 (netlabs-rel)
               poppler = 0.29.0-0.oc00
           Available: poppler-0.31.0-1.oc00.i386 (netlabs-rel)
               poppler = 0.31.0-1.oc00
           Available: poppler-0.33.0-1.oc00.i386 (netlabs-rel)
               poppler = 0.33.0-1.oc00
           Available: poppler-0.35.0-1.oc00.i386 (netlabs-rel)
               poppler = 0.35.0-1.oc00
           Available: poppler-0.38.0-1.oc00.i386 (netlabs-rel)
               poppler = 0.38.0-1.oc00
           Available: poppler-0.38.0-2.oc00.i686 (netlabs-rel)
               poppler = 0.38.0-2.oc00
           Available: poppler-0.38.0-3.oc00.i686 (netlabs-rel)
               poppler = 0.38.0-3.oc00
           Available: poppler-0.42.0-2.oc00.i686 (netlabs-rel)
               poppler = 0.42.0-2.oc00
           Available: poppler-0.47.0-1.oc00.i686 (netlabs-rel)
               poppler = 0.47.0-1.oc00
           Available: poppler-0.49.0-1.oc00.i686 (netlabs-rel)
               poppler = 0.49.0-1.oc00
           Available: poppler-0.49.0-2.oc00.i686 (netlabs-rel)
               poppler = 0.49.0-2.oc00
           Available: poppler-0.52.0-1.oc00.i686 (netlabs-rel)
               poppler = 0.52.0-1.oc00
           Available: poppler-0.59.0-2.oc00.i686 (netlabs-rel)
               poppler = 0.59.0-2.oc00
           Available: poppler-legacy-63-0.47.0-1.oc00.L.i686 (netlabs-rel)
               poppler = 0.47.0-1.oc00.L
 You could try using --skip-broken to work around the problem
** Found 20 pre-existing rpmdb problem(s), 'yum check' output follows:
binutils-2.33.1-1.oc00.i686 is a duplicate with binutils-2.27-3.oc00.i686
bww-resources-rpm-1.1.3-1.oc00.noarch is a duplicate with bww-resources-rpm-1.1.2-1.oc00.noarch
bww-resources-rpm-1.1.4-1.oc00.noarch is a duplicate with bww-resources-rpm-1.1.3-1.oc00.noarch
coreutils-8.31-1.oc00.i686 is a duplicate with coreutils-8.26-2.oc00.i686
coreutils-common-8.31-1.oc00.i686 is a duplicate with coreutils-common-8.26-2.oc00.i686
dash-0.5.10.2-1.oc00.i686 is a duplicate with dash-0.5.9.1-2.oc00.i686
dash-sh-0.5.10.2-1.oc00.i686 is a duplicate with dash-sh-0.5.9.1-2.oc00.i686
fontconfig-2.13.1-3.oc00.i686 is a duplicate with fontconfig-2.13.1-2.oc00.i686
fontconfig-2.13.1-4.oc00.i686 is a duplicate with fontconfig-2.13.1-3.oc00.i686
klusrmgr-1.2.2-1.oc00.i686 is a duplicate with klusrmgr-1.2.1-1.oc00.i686
klusrmgr-1.3.1-1.oc00.i686 is a duplicate with klusrmgr-1.2.2-1.oc00.i686
openssl-1.0.2t-1.oc00.i686 is a duplicate with openssl-1.0.2q-1.oc00.i686
openssl-libs-1.0.2t-1.oc00.i686 is a duplicate with openssl-libs-1.0.2q-1.oc00.i686
os2-base-0.0.1-1.oc00.i686 is a duplicate with os2-base-0.0.0-19.oc00.i686
os2-base-0.0.1-2.oc00.i686 is a duplicate with os2-base-0.0.1-1.oc00.i686
os2tk45-rc-4.5.2-10.oc00.i686 is a duplicate with os2tk45-rc-4.5.2-9.oc00.i686
os2tk45-readme-4.5.2-10.oc00.noarch is a duplicate with os2tk45-readme-4.5.2-9.oc00.noarch
poppler-0.61.1-1.oc00.i686 is a duplicate with poppler-0.59.0-3.oc00.i686
poppler-qt-0.61.1-1.oc00.i686 is a duplicate with poppler-qt-0.59.0-3.oc00.i686
wget-1.20.3-2.oc00.i686 is a duplicate with wget-1.18-3.oc00.i686

That was not fixable, as yet. I was able to export the packages list and will re-install all packages in a few days.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 169
  • Posts: 2423
    • View Profile
Re: YUM
« Reply #2 on: March 22, 2020, 07:58:05 pm »
Poppler seems to be broken currently. My workaround is to update a few packages at a time and avoid poppler.

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 16
  • Posts: 708
    • View Profile
Re: YUM
« Reply #3 on: March 22, 2020, 09:59:04 pm »
David,
I had a couple of VR messages pop up here and there (can't recall if they matched the exact code you're seeing though), but luckily never resulting in a major catastrophe.

You could certainly add '/deb' to the command line and look to see what anpm.dbg file contains. There may be enough there to tell you where things are going wrong.

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 67
  • Posts: 598
    • View Profile
Re: YUM
« Reply #4 on: March 22, 2020, 10:17:05 pm »
David,
I had a couple of VR messages pop up here and there (can't recall if they matched the exact code you're seeing though), but luckily never resulting in a major catastrophe.

You could certainly add '/deb' to the command line and look to see what anpm.dbg file contains. There may be enough there to tell you where things are going wrong.

Hi Darciusz

This is only the second time this has happened.  The first time was on another partition.  However, now that I know how to recover by installing a previous WPS archive, I will not pursue the matter.  Thanks for the suggestion though.  Maybe this will help someone else if it ever happens to them.

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 176
    • View Profile
Re: YUM
« Reply #5 on: March 23, 2020, 10:58:09 am »
Poppler seems to be broken currently. My workaround is to update a few packages at a time and avoid poppler.
hmm poppler is broken? I wonder about that, as there is no ticket for it. And I update it regularly on some installations and saw no issue so far.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

TeLLie

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 79
    • View Profile
Re: YUM
« Reply #6 on: March 23, 2020, 03:18:15 pm »
Hi,

I have poppler installed and use for several progs...
Saw no problems when installing..
Dave what kind of probs you have/get ??

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 169
  • Posts: 2423
    • View Profile
Re: YUM
« Reply #7 on: March 23, 2020, 03:40:57 pm »
I just found this yesterday and I seem to have some other errors which I was hoping to look at more along with the poppler one, but basically
Code: [Select]
Error: Package: poppler-utils-0.84.0-1.oc00.pentium4 (netlabs-exp)
           Requires: popple94.dll

Looking now, it looks like a typo in the requirements and should be looking for poppler84.dll.
I'll see if the internet is working well enough to file a bug.

TeLLie

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 79
    • View Profile
Re: YUM
« Reply #8 on: March 23, 2020, 03:51:30 pm »
Hi Dave,

I have a popple94.dll                                                           │ 1,592,166│02/04/20
And i use i686 version
« Last Edit: March 23, 2020, 03:56:40 pm by TeLLie »

Andreas Schnellbacher

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 26
  • Posts: 503
    • View Profile
Re: YUM
« Reply #9 on: March 23, 2020, 05:25:38 pm »
Looking now, it looks like a typo in the requirements and should be looking for poppler84.dll.
You probably mean popple84.dll. OS/2 DLLs need to comply with the 8.3 naming scheme. But why shouldn't popple94.dll work?

Andy Willis

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 10
  • Posts: 207
    • View Profile
Re: YUM
« Reply #10 on: March 25, 2020, 02:05:10 am »
I just found this yesterday and I seem to have some other errors which I was hoping to look at more along with the poppler one, but basically
Code: [Select]
Error: Package: poppler-utils-0.84.0-1.oc00.pentium4 (netlabs-exp)
           Requires: popple94.dll

Looking now, it looks like a typo in the requirements and should be looking for poppler84.dll.
I'll see if the internet is working well enough to file a bug.

I get the same error here.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 11
  • -Receive: 169
  • Posts: 2423
    • View Profile
Re: YUM
« Reply #11 on: March 25, 2020, 02:22:02 am »
Netlabs-exp seems to be off-line and we have the older unfixed RPM. https://github.com/bitwiseworks/poppler-os2/issues/1.

Andreas Schnellbacher

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 26
  • Posts: 503
    • View Profile
Re: YUM
« Reply #12 on: March 25, 2020, 10:00:46 am »
Thanks for adding that issue.