Author Topic: Updated Uniaud32 build  (Read 75883 times)

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 125
  • Posts: 885
  • Karma: +77/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #315 on: December 28, 2020, 02:02:25 am »
Hopefully the same fix will get 4.19.x working, I'll know shortly....

https://smedley.id.au/tmp/uniaud32-linux-4.19.163-20201228.zip - works in Virtualbox with ac97 and hda hardware

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #316 on: December 28, 2020, 02:24:53 am »
Paul,

  4.17 works the same as 4.16 here - only get sound from a hard boot. With 4.17 though, I get a slight delay from system sounds - the item cross-hatches, hesitates, then the sound occurs, then the item opens. Also, alsahlp$ doesn't show the typical info.

  4.19 does not give sound no matter what I do, it boots fine, but no sound. I also detect the hesitation with this one, only with no sound. Alsahlp$ files attached...

Regards,

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 604
  • -Receive: 122
  • Posts: 3289
  • Karma: +27/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #317 on: December 28, 2020, 02:39:05 am »
Hopefully the same fix will get 4.19.x working, I'll know shortly....

https://smedley.id.au/tmp/uniaud32-linux-4.19.163-20201228.zip - works in Virtualbox with ac97 and hda hardware

Version uniaud32-linux-4.19.163-20201228.zip is working fine on my Thinkpad L420.
- No Traps, sound and volume control working.
For the moment it is a keeper for my Thinkpad L420.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #318 on: December 28, 2020, 02:59:42 am »
Paul,

  Installed the debug version of 4.19, rebooted and got a TrapE in UNIAUD32. Rebooted again and after disk checks, it booted and I had sound! I'll attach an alsahlp$. The hesitation is there but different now, items cross-hatch and start, then the sound is heard late. Rebooted again and TrapE. Then again and after disk checks it booted...

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 125
  • Posts: 885
  • Karma: +77/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #319 on: December 28, 2020, 03:44:16 am »
Hi Dave,

  Installed the debug version of 4.19, rebooted and got a TrapE in UNIAUD32. Rebooted again and after disk checks, it booted and I had sound! I'll attach an alsahlp$. The hesitation is there but different now, items cross-hatch and start, then the sound is heard late. Rebooted again and TrapE. Then again and after disk checks it booted...

Any chance of a dump after the trap?

Cheers,

Paul

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #320 on: December 28, 2020, 12:20:10 pm »
 OK, got it... where to send?

OS4User

  • Sr. Member
  • ****
  • Thank You
  • -Given: 97
  • -Receive: 16
  • Posts: 306
  • Karma: +9/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #321 on: December 28, 2020, 01:53:29 pm »

Eugene Tucker

  • Full Member
  • ***
  • Thank You
  • -Given: 59
  • -Receive: 11
  • Posts: 162
  • Karma: +6/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #322 on: December 28, 2020, 03:42:09 pm »
No trap here but no sound.

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 613
  • Karma: +1/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #323 on: December 28, 2020, 05:06:53 pm »
It has given me trap in debug and release. In ver 4.19.163
saludos

TeLLie

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 10
  • Posts: 121
  • Karma: +3/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #324 on: December 28, 2020, 05:07:17 pm »
Hi Paul
No traps but also no sound on my W530 thats for the  uniaud32-linux-4.14.202-20201227.zip
But the uniaud32-linux-4.19.163-20201228.zip provide nice sound :)

Thankz for all
« Last Edit: December 28, 2020, 05:12:31 pm by TeLLie »

Dariusz Piatkowski

  • Hero Member
  • *****
  • Thank You
  • -Given: 15
  • -Receive: 32
  • Posts: 982
  • Karma: +21/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #325 on: December 28, 2020, 06:34:21 pm »
Hi Paul!

https://smedley.id.au/tmp/uniaud32-linux-4.19.163-20201228.zip - works in Virtualbox with ac97 and hda hardware

No TRAP here, no sound either, debug log attached.

I did notice something though, not sure if this is of significance or not. Once booted, the numbering of controls (as it shows up in UniMix) is different from the current working driver (that being AOS 2.02.06).

I've captured the PMUnixMix debug console output for both the working and this latest drop in case the comparison may tell you something.

Thanks!
-Dariusz

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 125
  • Posts: 885
  • Karma: +77/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #326 on: December 28, 2020, 09:10:04 pm »
https://smedley.id.au/tmp/uniaud32-linux-4.19.163-20201228.zip - works in Virtualbox with ac97 and hda hardware

hi, tried on on my comp

What hardware is this? I presume previous Uniaud builds worked?

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 125
  • Posts: 885
  • Karma: +77/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #327 on: December 28, 2020, 09:13:38 pm »
Hi Dariusz,
https://smedley.id.au/tmp/uniaud32-linux-4.19.163-20201228.zip - works in Virtualbox with ac97 and hda hardware

No TRAP here, no sound either, debug log attached.

I did notice something though, not sure if this is of significance or not. Once booted, the numbering of controls (as it shows up in UniMix) is different from the current working driver (that being AOS 2.02.06).

I've captured the PMUnixMix debug console output for both the working and this latest drop in case the comparison may tell you something.

Thanks!
-Dariusz

Thanks - I'll review later today. I don't *think* the reordering of controls is an issue - I've seen this before when bumping the version of the linux code. Remember, the code in the AOS driver is from ~2011 - the linux 4.19 code was released in October 2018 - so there's been 7 years of code development.

I'm also seeing no sound on a T60, so will do some investigations locally.

Cheers,
Paul

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 125
  • Posts: 885
  • Karma: +77/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #328 on: December 28, 2020, 09:14:55 pm »
Hi Roberto,

It has given me trap in debug and release. In ver 4.19.163

Does your system have a serial port? It would be interesting to see where in the boot cycle your system is trapping.

Cheers,

Paul

OS4User

  • Sr. Member
  • ****
  • Thank You
  • -Given: 97
  • -Receive: 16
  • Posts: 306
  • Karma: +9/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #329 on: December 28, 2020, 09:36:22 pm »
https://smedley.id.au/tmp/uniaud32-linux-4.19.163-20201228.zip - works in Virtualbox with ac97 and hda hardware

hi, tried on on my comp

What hardware is this? I presume previous Uniaud builds worked?

CA0106/CA0111 [SB Live!/Audigy/X-Fi Series]       
I did not check previous    but  uniaud   usually works ok