Author Topic: Updated Uniaud32 build  (Read 397725 times)

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2095
  • Karma: +160/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #165 on: August 10, 2020, 11:58:53 pm »
OK, please test with:
http://smedley.id.au/tmp/uniaud32-linux-3.12.74-20200810.zip
http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip

Fixes my X250 and sound works nicely for the 1st time.

It works for me too (great job Paul)
Sound is very nice

Great - now to work out why the original code fails!

Renee Senger

  • Newbie
  • *
  • Posts: 47
  • Karma: +0/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #166 on: August 11, 2020, 01:23:52 am »
OK, please test with:
http://smedley.id.au/tmp/uniaud32-linux-3.12.74-20200810.zip
http://smedley.id.au/tmp/uniaud32-linux-3.14.79-20200810.zip
My tests with:
CardInfo.id: NVidia
CardInfo.Driver: HDA-Intel
CardInfo.Name: HDA NVidia
CardInfo.LongName: HDA NVidia at 0xebef8000 irq 23
CardInfo.MixerName: VIA VT1708S
CardInfo.Components: HDA:11064397,18490397,00100000

UNIAUD 20200506 TEST
.No sound output every reboot
 .Master Front Playback Volume is reset to zero (both channels)
 .Front Playback Volume is reset to zero (both channels)
.Volume.exe has no effects. All have to be controlled by mixer (unimix.exe)


UNIAUD32-LINUX-3.12.74-20200810 TEST
.Sound output after boot. Very good!
.Volume.exe all operational. Very good!

 
UNIAUD32-LINUX-3.14.79-20200810 TEST
.Sound output after boot. Very good!
.Volume.exe all operational. Very good!

Good work Paul!

« Last Edit: August 11, 2020, 02:32:55 am by Martin Iturbide »

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2095
  • Karma: +160/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #167 on: August 11, 2020, 06:02:09 am »
Thanks to everyone for their testing and feedback, it's gratifying to hear these are improving things for some users, and so far at least, don't appear to have any negative effects.

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2095
  • Karma: +160/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #168 on: August 12, 2020, 11:18:29 am »
Hey All,

Updated to 3.16.85 - http://smedley.id.au/tmp/uniaud32-linux-3.16.85-20200812.zip

Works in Virtualbox (Sigmatel HDA), and on a Thinkpad X250 (Realtek HDA) - I get a Trap 000E on a T60 with Analog Devices HDA that I'll investigate in due course.

This one was the biggest challenge since the bump from 3.5 -> 3.8 - lots of changes so I'm bound to have broken something :) so in reality, I'm pleasantly surprised that 2/3 tests work OK.

Cheers,

Paul

David McKenna

  • Hero Member
  • *****
  • Posts: 751
  • Karma: +24/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #169 on: August 12, 2020, 12:11:50 pm »
 Paul,

 Get a Trap000e here as well... do you need a screen shot?

Regards,

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2095
  • Karma: +160/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #170 on: August 12, 2020, 12:55:49 pm »
Get a Trap000e here as well... do you need a screen shot?

Not at this stage, let me fix my T60 first, if you still get traps once that is resolved, then I'll ask for a screenshot.

Yours is Realtek hardware?

In the morning I'll try my old favourite of backlevelling hda_intel.c, and assuming that fixes things, work through the changes.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4748
  • Karma: +41/-1
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #171 on: August 12, 2020, 03:46:22 pm »
Hi
Updated to 3.16.85 - http://smedley.id.au/tmp/uniaud32-linux-3.16.85-20200812.zip

I just tried it on a Thinkpad L420. No traps. Produce sounds. Volume control works.
Seems to be working fine for me. I will report if I find something.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

roberto

  • Hero Member
  • *****
  • Posts: 810
  • Karma: +3/-6
    • View Profile
Re: Updated Uniaud32 build
« Reply #172 on: August 12, 2020, 05:39:07 pm »
Hello
Another trap ... over here with HDA-Intel in HP
Saludos

Eugene Tucker

  • Sr. Member
  • ****
  • Posts: 369
  • Karma: +12/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #173 on: August 12, 2020, 07:06:59 pm »
The latest wprks out a trap on my Dell Inspiron 15R 5537. But for som reason I am unable to load browser url pages.

Renee Senger

  • Newbie
  • *
  • Posts: 47
  • Karma: +0/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #174 on: August 13, 2020, 02:06:26 am »
Hey All,

Updated to 3.16.85 - http://smedley.id.au/tmp/uniaud32-linux-3.16.85-20200812.zip


More one sound interface tested:

Detected UNIAUD version 2.02.05
Detected 1 audio adapter(s)
Card info for adapter 0:
  num: 0
  id: ICH5
  driver: ICH4
  name: Intel ICH5
  longname: Intel ICH5 with CMI9739 at irq 17
  mixer: C-Media Electronics CMI9739
  componenets: AC97a:434d4961

Tests were done with Package 20200506, uniaud32-linux-3.12.74, uniaud32-linux-3.14.79 and the last uniaud32-linux-3.16.85.
In all tests sound hardware is not identified by os/2 (ArcaOS 5.0.5), although uniaud32.sys is normally loading at boot.
Seems that are not any sound hardware. Applications like Klondike Solitaire, Mahjongg Solitaire, with sound enabled by default, show messages of "No device driver found" .

To know if was not an ALSA problem, I boot a live cd of linux Ubuntu 12.10 with ALSA version 1.0.24. All sound works as expected, without problems.

unimix -list resulted from uniaud32-linux-3.16.85 and pci.exe are attached.

Remy

  • Hero Member
  • *****
  • Posts: 646
  • Karma: +9/-1
    • View Profile
Re: Updated Uniaud32 build
« Reply #175 on: August 13, 2020, 12:18:48 pm »
Hey All,

Updated to 3.16.85 - http://smedley.id.au/tmp/uniaud32-linux-3.16.85-20200812.zip


More one sound interface tested:

Detected UNIAUD version 2.02.05
Detected 1 audio adapter(s)
Card info for adapter 0:
  num: 0
  id: ICH5
  driver: ICH4
  name: Intel ICH5
  longname: Intel ICH5 with CMI9739 at irq 17
  mixer: C-Media Electronics CMI9739
  componenets: AC97a:434d4961

Tests were done with Package 20200506, uniaud32-linux-3.12.74, uniaud32-linux-3.14.79 and the last uniaud32-linux-3.16.85.
In all tests sound hardware is not identified by os/2 (ArcaOS 5.0.5), although uniaud32.sys is normally loading at boot.
Seems that are not any sound hardware. Applications like Klondike Solitaire, Mahjongg Solitaire, with sound enabled by default, show messages of "No device driver found" .

To know if was not an ALSA problem, I boot a live cd of linux Ubuntu 12.10 with ALSA version 1.0.24. All sound works as expected, without problems.

unimix -list resulted from uniaud32-linux-3.16.85 and pci.exe are attached.

What are your driver parameters in the config.sys ?
Did you try with /A:1 ?

Renee Senger

  • Newbie
  • *
  • Posts: 47
  • Karma: +0/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #176 on: August 13, 2020, 07:26:31 pm »


What are your driver parameters in the config.sys ?
Did you try with /A:1 ?
[/quote]

With uniaud32.sys /A:1 in config.sys I get the error messages below:

Universal Audio Driver for OS/2 v2.02.05-SVN
Based on Linux 3.16.85
Copyright 2005-2020 Netlabs http://www.netlabs.org
Copyright 2000-2020 The ALSA Project

ERROR: Initialization failed
OSS32_Initialize: FAILEDpci_register-driver: query_device found fd 8086:24d5 class=40100 checking bt87x
OS/2 Universal Audio MMPM/2 Driver v1.9.7
Copyright 2000-2002 InnoTek Systemberatung GmbH
Copyright 2002 IBM Corporation
Mantained by Netlabs http://www.netlabs.org

Unable to attach 32-bit driver

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2095
  • Karma: +160/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #177 on: August 14, 2020, 12:03:39 am »
Hi Renee,

Hey All,

Updated to 3.16.85 - http://smedley.id.au/tmp/uniaud32-linux-3.16.85-20200812.zip


More one sound interface tested:

Detected UNIAUD version 2.02.05
Detected 1 audio adapter(s)
Card info for adapter 0:
  num: 0
  id: ICH5
  driver: ICH4
  name: Intel ICH5
  longname: Intel ICH5 with CMI9739 at irq 17
  mixer: C-Media Electronics CMI9739
  componenets: AC97a:434d4961

Tests were done with Package 20200506, uniaud32-linux-3.12.74, uniaud32-linux-3.14.79 and the last uniaud32-linux-3.16.85.
In all tests sound hardware is not identified by os/2 (ArcaOS 5.0.5), although uniaud32.sys is normally loading at boot.
Seems that are not any sound hardware. Applications like Klondike Solitaire, Mahjongg Solitaire, with sound enabled by default, show messages of "No device driver found" .

To know if was not an ALSA problem, I boot a live cd of linux Ubuntu 12.10 with ALSA version 1.0.24. All sound works as expected, without problems.

unimix -list resulted from uniaud32-linux-3.16.85 and pci.exe are attached.

An alsa log would be interesting.
copy alsahlp$ alsa-cmi9739.log

Paul Smedley

  • Hero Member
  • *****
  • Posts: 2095
  • Karma: +160/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #178 on: August 14, 2020, 11:36:15 am »
For anyone who was getting a TRAP000E with 3.16.85, can you test with http://smedley.id.au/tmp/uniaud32-linux-3.16.85-20200814.zip ?

Seems a function I'd stubbed was causing the tarp (thank's to Steven for his help in setting up a dump partition and helping with analysis).

David McKenna

  • Hero Member
  • *****
  • Posts: 751
  • Karma: +24/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #179 on: August 14, 2020, 12:08:52 pm »
 Paul,

  This 3.16 version is working here... Realtek-ALC887-VD.

Regards,