Author Topic: Updated Uniaud32 build  (Read 79808 times)

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 617
  • Karma: +1/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #300 on: December 26, 2020, 11:34:49 pm »
Sorry, another TRAP. The good thing is that I tried it on the 26th, before you created it.
saludos

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #301 on: December 27, 2020, 12:28:19 am »
Hi Dave,

Just happened to be browsing OS2World when your post appeared, so installed the release 4.14.202 version and it works! Congratulations! I'll keep running with it and let you know if any issues arise, but so far system sounds, PMUniMix and MP3's work.... thanks again!

Woohoo! Good news! I'll see if I can test with the X250 and T60 later today to get some more data.

Cheers,

Paul

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #302 on: December 27, 2020, 12:29:33 am »
Hi,

Sorry, another TRAP. The good thing is that I tried it on the 26th, before you created it.

I might need a trapdump - let's see first if I can recreate here on bare metal - so far I've only tested ac97 and hda using Virtualbox (Sigmatel hardware)

Cheers,

Paul

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 616
  • -Receive: 123
  • Posts: 3313
  • Karma: +28/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #303 on: December 27, 2020, 02:15:01 am »
Hi
Testing appreciated: https://smedley.id.au/tmp/uniaud32-linux-4.14.202-20201227.zip

I tried it on the Thinkpad L420.
- No traps on boot, but no sound.
Let me know if something else can be tested.

I returned to "uniaud32-linux-4.0.9-20200816.zip" to get sound back.


Regards
« Last Edit: December 27, 2020, 02:17:35 am by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Andy Willis

  • Full Member
  • ***
  • Thank You
  • -Given: 0
  • -Receive: 12
  • Posts: 223
  • Karma: +2/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #304 on: December 27, 2020, 03:41:54 am »
OK.... it took a while - but I finally produced sound with HDA hardware (albeit virtualised) with 4.14.202...

Testing appreciated: https://smedley.id.au/tmp/uniaud32-linux-4.14.202-20201227.zip

Not sure I fully understand why the change I made to OSS32_WaveClose() fixed things, but I'll worry about that later!!

Sound working on my Thinkpad W530

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #305 on: December 27, 2020, 08:30:01 am »
4.19.x is still trapping for me, so meanwhile, here's a build of 4.16.18 - https://smedley.id.au/tmp/uniaud32-linux-4.16.18-20201227.zip

roberto

  • Hero Member
  • *****
  • Thank You
  • -Given: 19
  • -Receive: 13
  • Posts: 617
  • Karma: +1/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #306 on: December 27, 2020, 11:32:15 am »
TRAP 4.16.18
saludos

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #307 on: December 27, 2020, 02:33:00 pm »
 Paul,

  After successfully using 4.14 for a few hours yesterday, when I booted up this morning I got a TrapE in UNIAUD32. Tried to boot a few times but no go. I could get a trap dump if you want.

  Installed 4.16 and it works (at least at first) too. It is a little different in that volume is very loud (but not distorted) and I only get 22 controls with Unimix where I got 44 with older versions. PMUnimix only show 3 volume controls where I had 9 before. This has no practical implications (can't use surround anyway) but thought I should mention.

Regards,
« Last Edit: December 27, 2020, 03:07:39 pm by David McKenna »

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #308 on: December 27, 2020, 02:48:31 pm »
 Went ahead and rebooted with 4.16, and now I get no sound (but it does boot). Alsahlp$ attached....

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #309 on: December 27, 2020, 09:21:03 pm »
Went ahead and rebooted with 4.16, and now I get no sound (but it does boot). Alsahlp$ attached....

Looks like Uniaud16 can't open the device - possibly related to the change I made that made sound work (at least initially).

Was this a hard reboot (power off) or a soft reboot?

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #310 on: December 27, 2020, 09:58:12 pm »
 Hi Paul,

  That was a soft reboot. Tried a power off, then restart and now sound is back, although loud with only 3 volume controls in PMUnimix. I'll upload alsahlp$....

Edit: Hmmm... now there are 25 controls listed by Unimix -names and 4 volume controls in PMUnimix. Strange...

Regards,
« Last Edit: December 27, 2020, 10:15:07 pm by David McKenna »

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #311 on: December 27, 2020, 10:11:45 pm »
Hi Paul,

  That was a soft reboot. Tried a power off, then restart and now sound is back, although loud with only 3 volume controls in PMUnimix. I'll upload alsahlp$....

Regards,

OK interesting - I'll have to mess around some more with the code I changed to get sound sorta working. First though, I want to work out why 4.19.x is trapping. Last night I discovered that v4.18 and v4.17 trap in the same place - so now I "just" need to work out what changed between v4.16 and v4.17 :)

Cheers,

Paul

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #312 on: December 27, 2020, 11:36:18 pm »
Update on hardware testing:

Thinkpad T60 (Analog Devices codec) - no sound with 4.14.x or 4.16.x

Thinkpad X250 (Realtek codec) - no sound with 4.14; sound with 4.16.x

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #313 on: December 28, 2020, 12:34:05 am »
Hi All,

Hi Paul,

  That was a soft reboot. Tried a power off, then restart and now sound is back, although loud with only 3 volume controls in PMUnimix. I'll upload alsahlp$....

Regards,

OK interesting - I'll have to mess around some more with the code I changed to get sound sorta working. First though, I want to work out why 4.19.x is trapping. Last night I discovered that v4.18 and v4.17 trap in the same place - so now I "just" need to work out what changed between v4.16 and v4.17 :)

OK that wasn't too hard - seems krealloc() is causing issues still - I knew it was a dirty hack. For now, I reverted some code in 4.17's pcm_lib.c to the code from 4.16 and I get sound in Virtualbox:
https://smedley.id.au/tmp/uniaud32-linux-4.17.19-20201228.zip

Hopefully the same fix will get 4.19.x working, I'll know shortly....
« Last Edit: December 28, 2020, 02:17:29 am by Paul Smedley »

David Graser

  • Hero Member
  • *****
  • Thank You
  • -Given: 0
  • -Receive: 90
  • Posts: 682
  • Karma: +44/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #314 on: December 28, 2020, 01:35:35 am »
Hi All,

Hi Paul,

  That was a soft reboot. Tried a power off, then restart and now sound is back, although loud with only 3 volume controls in PMUnimix. I'll upload alsahlp$....

Regards,

OK interesting - I'll have to mess around some more with the code I changed to get sound sorta working. First though, I want to work out why 4.19.x is trapping. Last night I discovered that v4.18 and v4.17 trap in the same place - so now I "just" need to work out what changed between v4.16 and v4.17 :)

OK that wasn't too hard - seems krealloc() is causing issues still - I knew it was a dirty hack. For now, I reverted some code in 4.17's pcm_lib.c to the code from 4.16 and I get sound in Virtualbox:
https://smedley.id.au.au/tmp/uniaud32-linux-4.17.19-20201228.zip

Hopefully the same fix will get 4.19.x working, I'll know shortly....

Should be
https://smedley.id.au/tmp/uniaud32-linux-4.17.19-20201228.zip