Author Topic: Updated Uniaud32 build  (Read 79465 times)

Eugene Tucker

  • Full Member
  • ***
  • Thank You
  • -Given: 60
  • -Receive: 12
  • Posts: 165
  • Karma: +7/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #630 on: July 20, 2021, 03:19:30 pm »
I will give them a try. Maybe tomorrow too much to do today.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 615
  • -Receive: 123
  • Posts: 3311
  • Karma: +28/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #631 on: July 20, 2021, 04:03:00 pm »
Hi Eugene
I will give them a try. Maybe tomorrow too much to do today.
Please let me know also the model of your Sound Blaster Recon card to post is on the wiki as working or non working.  ;D

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #632 on: July 20, 2021, 11:15:16 pm »
I will give them a try. Maybe tomorrow too much to do today.
Let me know - after a sleep, I think I know how to fix some of the hacks that were in yesterday's build. I'll try and address those this evening.

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #633 on: July 21, 2021, 11:11:29 am »
I will give them a try. Maybe tomorrow too much to do today.
Let me know - after a sleep, I think I know how to fix some of the hacks that were in yesterday's build. I'll try and address those this evening.

OK https://smedley.id.au/tmp/uniaud32-linux-5.10.50-20210721.zip should properly support ca0132 hardware
« Last Edit: July 21, 2021, 11:13:44 am by Paul Smedley »

Eugene Tucker

  • Full Member
  • ***
  • Thank You
  • -Given: 60
  • -Receive: 12
  • Posts: 165
  • Karma: +7/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #634 on: July 21, 2021, 02:33:06 pm »
Well thank you so very much I will it a try soon the other one lead to a setacular crash.

Eugene Tucker

  • Full Member
  • ***
  • Thank You
  • -Given: 60
  • -Receive: 12
  • Posts: 165
  • Karma: +7/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #635 on: July 21, 2021, 02:42:00 pm »
Well I got sound. It is loud and the system is irradic. Mouse is very slow. PMMix is slow but comes up. I wil have to play with it but sound and no crash.

Hajo

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #636 on: July 21, 2021, 07:12:51 pm »
My soundblaster z initializes (click sound) but boot stops afterwards. No initilization message. I created this partition on real disk with virtual box, so I can boot without virtual box, but I don't have any input devices after arcaos comes up on physical hardware. In virtualbox this driver works like all the others before  :)

My subscription ended short before USB3.0 drivers were released and I don't think that I will resubscribe to get input devices on physical machine.

Regards

Hajo

Paul Smedley

  • Hero Member
  • *****
  • Thank You
  • -Given: 62
  • -Receive: 127
  • Posts: 886
  • Karma: +79/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #637 on: July 21, 2021, 11:10:40 pm »
Well I got sound. It is loud and the system is irradic. Mouse is very slow. PMMix is slow but comes up. I wil have to play with it but sound and no crash.

OK cool - I'll try and check my patches this evening - it's possible I screwed something up when reworking some code that wouldn't compile with openwatcom...

Andi B.

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 28
  • Posts: 592
  • Karma: +7/-1
    • View Profile
Re: Updated Uniaud32 build
« Reply #638 on: July 22, 2021, 09:03:37 pm »
I installed latest warpin package on a fairly fresh ArcaOS beta. I still have no sound on this system. Think I never had sound. If yes then it must have been a very old uniaud but I don't remember. Attached the logs. Maybe you see what's going wrong.

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #639 on: July 22, 2021, 10:42:26 pm »
 Hi Andi,

  I looked at your files and was surprised to see you have the identical sound hardware as myself (Realtek ALC887-VD). Here it works perfectly. One thing I notice in your testlog file is this:

----- Checking G:\CONFIG.SYS ---------------------------------------------------
ERROR: DEVICE=G:\IBMCOM\MACS\MMRE.OS2
ERROR: DEVICE=G:\IBMCOM\MACS\E100B.OS2
ERROR: DEVICE=G:\IBMCOM\MACS\E1000B.OS2
       Load order violation. All MAC drivers must come after all
       IFS statements and all network drivers

 Maybe correcting those errors (by putting those lines at the end of CONFIG.SYS) might help?

Regards,

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 615
  • -Receive: 123
  • Posts: 3311
  • Karma: +28/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Updated Uniaud32 build
« Reply #640 on: July 23, 2021, 02:21:40 am »
Hi Andi. B

I installed latest warpin package on a fairly fresh ArcaOS beta. I still have no sound on this system. Think I never had sound. If yes then it must have been a very old uniaud but I don't remember. Attached the logs. Maybe you see what's going wrong.

I checked some other hardware reports and there are ones that says that "8086:8C20 - Intel 8 Series/C220 Series Chipset High Definition Audio Controller" works with Uniaud. Maybe is the config.sys that David M says, or some other trick with unimix.exe.

It is as "DEVICE=G:\MMOS2\UNIAUD32.SYS /v /A:0" maybe it is "/A:1"

Andi, which is the Brand/model of you mainboard ? or machine and model if it is a retail machine. I want to check if was previously reported and include it on the wiki if applies.

Regards
« Last Edit: July 23, 2021, 02:48:50 am by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Andi B.

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 28
  • Posts: 592
  • Karma: +7/-1
    • View Profile
Re: Updated Uniaud32 build
« Reply #641 on: July 23, 2021, 09:05:19 am »
It's an Asus H87-Pro motherboard.

I saw the config.sys error message too. But this is what the ArcaOS installer made. I had only a quick look at the config.sys (it's included in the testlog) and think it's the ISO ifs line which triggers this error message. Again, this is a rather fresh ArcaOS installation. I didn't change ifs or nif lines in config.sys by myself. Of course worth to check as soon as I'm on this machine again....

Edit: No difference when putting IFS=G:\sys\bin\STUBFSD.IFS ISOFS before the NIF drivers. /A:0 or /A:1 or /A:2 - nothing produces sound.
« Last Edit: July 24, 2021, 06:45:57 pm by Andi B. »

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 13
  • -Receive: 26
  • Posts: 356
  • Karma: +15/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #642 on: July 25, 2021, 03:27:39 pm »
Hi Andi,

  Just had another look at your uniaud log file and it looks like UniAud was never properly installed because there are no [UNIAUDxxx] sections in your MMPM2.INI file. Try re-installing using the latest AN version (Uniaud-20210320.wpi) which should create those sections for you. Reboot and see if it works...

Regards,
« Last Edit: July 25, 2021, 03:48:24 pm by David McKenna »

Andi B.

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 28
  • Posts: 592
  • Karma: +7/-1
    • View Profile
Re: Updated Uniaud32 build
« Reply #643 on: July 26, 2021, 09:00:23 am »
Thanks David. Before I posted I installed latest .wpi from David from here - ftp://ftp.netlabs.org/pub/uniaud/Uniaud-20210721-beta.exe. As previous install attempts did not work I hoped this wpi would do it. Unfortunately not.

Do you have a clue how to repair MMPM2.INI. Obviously the wpi didn't do it. Neither on my work partition nor on the fairly new ArcaOS beta partition.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 78
  • Posts: 834
  • Karma: +25/-0
    • View Profile
Re: Updated Uniaud32 build
« Reply #644 on: July 26, 2021, 09:09:53 am »
Post it here or attach and I will fix it for you.