Author Topic: Question about USB Audio (Input / Output).  (Read 4894 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 547
  • -Receive: 114
  • Posts: 3061
  • Karma: +17/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Question about USB Audio (Input / Output).
« on: August 19, 2020, 04:34:27 pm »
Hi.

I never took the time to test USB audio devices and I want to see if I can make work some hardware I have around on OS/2.

First some questions:
1) Is there any special thing you have to do if Uniaud is already working on the computer and you want to test an additional USB Audio output/speaker?
2) Are USB Mics or USB Audio input working on OS/2?
3) When you can an USB camera that has included an mic (also USB), is there a way to make the USB mic to work ?

I have the following hardware a want to try:
- USB Audio Fairy - Audio Output and Input -  C-Media USB Audio  0D8C:000C
- USB Karaoke Adapter - Only audio Inputs -  This thing has a switch with two modes.
-- 1) 046D:0A03  - Logitech USB Microphone  according to some sites)
-- 2) 1415:0000 - Sony SingStar USBMIC by Nam Tai E&E Products Ltd. or OmniVision Technologies, Inc.

I want to start my test with the USB 12.07 package, there is also the USB Basic Class 1 Audio Driver 12.07. Do I need both?

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 61
  • Posts: 1441
  • Karma: +1/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #1 on: August 19, 2020, 05:58:39 pm »
Quote
I want to start my test with the USB 12.07 package, there is also the USB Basic Class 1 Audio Driver 12.07. Do I need both?

Two things:

1) Make sure you use the USB audio driver(s) from <DVD>:\CID\SERVER\ARCAPKG\USBAUD2.WPI. That is the one that gets installed with a NEW install. The other one, that gets installed with an UPDATE install is garbage.

2) ArcaOS 5.0 comes with a program called ASWITCH, which automatically switches between USB audio, and UniAud (when no audio is playing, and you plug/unplug a USB device). You find the setup program in the Multimedia folder.

The CMedia device will likely just work (I have 2 brands, that use the same chip). I don't know about the others. I haven't tried the audio input, but output works fine.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 547
  • -Receive: 114
  • Posts: 3061
  • Karma: +17/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Question about USB Audio (Input / Output).
« Reply #2 on: August 19, 2020, 09:37:42 pm »
Hi.


Two things:

1) Make sure you use the USB audio driver(s) from <DVD>:\CID\SERVER\ARCAPKG\USBAUD2.WPI. That is the one that gets installed with a NEW install. The other one, that gets installed with an UPDATE install is garbage.

2) ArcaOS 5.0 comes with a program called ASWITCH, which automatically switches between USB audio, and UniAud (when no audio is playing, and you plug/unplug a USB device). You find the setup program in the Multimedia folder.

That was very good. I installed "USBAUD2.WPI", enables ASWITCH from the MM folder and works very good with the USB Audio Fairy (C-Media USB Audio  0D8C:000C). It uses USBAUDIO.SYS Lar's version 10.234. Should I try usbaud2.sys to see if it also works?

Now I hope that someone with experience call tell me if the Audio USB input is supported or not.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 547
  • -Receive: 114
  • Posts: 3061
  • Karma: +17/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: Question about USB Audio (Input / Output).
« Reply #3 on: August 19, 2020, 10:04:14 pm »
Hi

I updated USBAUDIO.SYS to the one from AN, 12.07, just try it out. I just replaced the USBAUDIO.SYS file, I don't know if I missed something on the procedure. .
Now it sounds very distorted, I think I'm experiencing the same issue of Igor on this thread. I reverted to Lars' USBAUDIO.

Regards
« Last Edit: August 19, 2020, 10:33:04 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 61
  • Posts: 1441
  • Karma: +1/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #4 on: August 20, 2020, 04:32:58 am »
Quote
I updated USBAUDIO.SYS to the one from AN, 12.07, just try it out. I just replaced the USBAUDIO.SYS file, I don't know if I missed something on the procedure. .
Now it sounds very distorted, I think I'm experiencing the same issue of Igor on this thread. I reverted to Lars' USBAUDIO.

Yeah, that is the old IBM version. Apparently it does work with one, or two, USB devices, but it isn't even worth trying it. Lars' (and Wim's)  version is probably as good as USB audio ever gets.

Quote
Should I try usbaud2.sys to see if it also works?

If you have a USBaudio2 device, definitely try it. If you don't have a compatible device. it isn't going to do anything for you. I know that it loads, for me, but I don't have a device that will use it.

Quote
Now I hope that someone with experience call tell me if the Audio USB input is supported or not.

I think it is supposed to be supported, but I don't know what needs to be done to make it work. Try it.

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 4
  • -Receive: 41
  • Posts: 232
  • Karma: +7/-0
    • View Profile
    • Wim's home page
Re: Question about USB Audio (Input / Output).
« Reply #5 on: August 20, 2020, 10:19:13 am »
Quote
Now I hope that someone with experience call tell me if the Audio USB input is supported or not.
Yes. Both playback and recording are supported with the Lars Erdmann USB 10.234 audio drivers.

I used the Conceptronic CSOUNDU to develop and test Audio Class 1.0 recording support.

I used the Behringer UMC204HD to develop and test Audio Class 2.0 recording support.
« Last Edit: August 20, 2020, 10:22:44 am by Wim Brul »

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 397
  • Karma: +0/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #6 on: August 22, 2020, 10:46:00 am »
Quote
I want to start my test with the USB 12.07 package, there is also the USB Basic Class 1 Audio Driver 12.07. Do I need both?

Two things:

1) Make sure you use the USB audio driver(s) from <DVD>:\CID\SERVER\ARCAPKG\USBAUD2.WPI. That is the one that gets installed with a NEW install. The other one, that gets installed with an UPDATE install is garbage.

2) ArcaOS 5.0 comes with a program called ASWITCH, which automatically switches between USB audio, and UniAud (when no audio is playing, and you plug/unplug a USB device). You find the setup program in the Multimedia folder.

The CMedia device will likely just work (I have 2 brands, that use the same chip). I don't know about the others. I haven't tried the audio input, but output works fine.

No ASWITCH here under ArcaOS 5.0 !!! where is it ?

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 397
  • Karma: +0/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #7 on: August 22, 2020, 11:42:36 am »
I searched under ArcaOS 5.0.5 DVD, I found aswitch files I copied under MMOS2 and run aswitch.
Plugged an usb dac to it but didn't work and since then, no more audio under ArcaOS !
"removed the dac, no speaker audio, removed aswitch files, no speaker audio...."
How to reverse and get audio back using auniaud drivers ?   

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 4
  • -Receive: 41
  • Posts: 232
  • Karma: +7/-0
    • View Profile
    • Wim's home page
Re: Question about USB Audio (Input / Output).
« Reply #8 on: August 22, 2020, 02:37:57 pm »
I searched under ArcaOS 5.0.5 DVD, I found aswitch files I copied under MMOS2 and run aswitch.
Plugged an usb dac to it but didn't work and since then, no more audio under ArcaOS !
"removed the dac, no speaker audio, removed aswitch files, no speaker audio...."
How to reverse and get audio back using auniaud drivers ?
I have ArcaOS 5.0 installed. I never used ASWITCH, nor <DVD>:\CID\SERVER\ARCAPKG\USBAUD2.WPI. What I would do:

Go to System Setup, Multimedia Setup. On the System, Default WAVE Device Selection page, Select the uniaud device and press Enter.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 71
  • Posts: 742
  • Karma: +14/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #9 on: August 22, 2020, 02:52:43 pm »
Hi Wim,

if you are talking about the Multimedia Setup Object Extension that I have written:
I have no clue if ArcaOS also delivers that extension. Can you see if the ArcaOS package (USBAUD2.WPI) contains the DEFDEV.DLL file (the DLL that implements the Multimedia Setup Object Extension) ? The WPI command line tool (WIC.EXE) should be able to list the WPI content.

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 4
  • -Receive: 41
  • Posts: 232
  • Karma: +7/-0
    • View Profile
    • Wim's home page
Re: Question about USB Audio (Input / Output).
« Reply #10 on: August 22, 2020, 03:51:24 pm »
Hi Lars,

Hi Wim,

if you are talking about the Multimedia Setup Object Extension that I have written:
I have no clue if ArcaOS also delivers that extension. Can you see if the ArcaOS package (USBAUD2.WPI) contains the DEFDEV.DLL file (the DLL that implements the Multimedia Setup Object Extension) ? The WPI command line tool (WIC.EXE) should be able to list the WPI content.

Yes, I was talking about that Multimedia Setup Object Extension written by you (part of the audio part of usbdrv234.zip).
But I have no clue either whether or not ArcaOS delivers that extension. I have no access to that USBAUD2.WPI either. 

David McKenna

  • Sr. Member
  • ****
  • Thank You
  • -Given: 12
  • -Receive: 24
  • Posts: 328
  • Karma: +12/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #11 on: August 22, 2020, 04:26:58 pm »
 Lars,

  I don't see defdev.dll in the ArcaOS USBAUD2.WPI package....

Regards,

Rich Walsh

  • Full Member
  • ***
  • Thank You
  • -Given: 1
  • -Receive: 13
  • Posts: 137
  • Karma: +1/-0
  • ONU! (OS/2 is NOT Unix!)
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #12 on: August 22, 2020, 07:53:46 pm »
I don't see defdev.dll in the ArcaOS USBAUD2.WPI package....

It was removed because I fixed Multimedia Setup ('stpm.exe'). The version in AOS 5.0.5 is actually capable of changing the default output on its own - Lars' add-on is no longer needed if you run 5.0.5 or later.


Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 397
  • Karma: +0/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #13 on: August 22, 2020, 09:30:00 pm »
I searched under ArcaOS 5.0.5 DVD, I found aswitch files I copied under MMOS2 and run aswitch.
Plugged an usb dac to it but didn't work and since then, no more audio under ArcaOS !
"removed the dac, no speaker audio, removed aswitch files, no speaker audio...."
How to reverse and get audio back using auniaud drivers ?
I have ArcaOS 5.0 installed. I never used ASWITCH, nor <DVD>:\CID\SERVER\ARCAPKG\USBAUD2.WPI. What I would do:

Go to System Setup, Multimedia Setup. On the System, Default WAVE Device Selection page, Select the uniaud device and press Enter.

In fact, what I did was to coppy ASWITCH and ASWITCHSETUP into my  ArcaOS 5.0.2 mmos2 folder and run ASWITCHSETUP.
No and as you suggest, i checked  Multimedia Setup and set the DEFAULT WAVEAUDIO device under  OS2 Audio: WAVE instead of under USB Adapter after having removed ASWITCH from under startup folder.

I think it would nice having a manual reverse option in case of end user doing unpredictable actions :D 

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 397
  • Karma: +0/-0
    • View Profile
Re: Question about USB Audio (Input / Output).
« Reply #14 on: August 22, 2020, 09:30:49 pm »
I don't see defdev.dll in the ArcaOS USBAUD2.WPI package....

It was removed because I fixed Multimedia Setup ('stpm.exe'). The version in AOS 5.0.5 is actually capable of changing the default output on its own - Lars' add-on is no longer needed if you run 5.0.5 or later.

stpm.exe was then changed too. Good to know it