OS/2, eCS & ArcaOS - Technical > Mail-News

Mail disappeared SeaMonkey

(1/2) > >>

Per E. Johannessen:
When booting AOS today I got the message "The program pointed to by the SET RUNWORKPLACE= line in config.sys could not be started".
I then replaced os2.ini and os2sys.ini with recent backed up versions and the system boots fine and all seems intact except e-mail folders which I have on a JFS partition.

Started SeaMonkey mail and it showed only 3 of 7 mail accounts, but there are no mails in any of them, also the subfolders are not displayed. In each accounts folder there are only four files; Inbox, Inbox.msf, Trash, and Trash.mfs, and they all seem to have been recreated today by SeaMonkey.
All other folders and files on this JFS partition are OK.

Before restoring mail from a back up I'd like to try to recover the files. (The back up is unfortunately a couple of weeks old.)

So far I've only tried JUne and it does not find the missing files. JRescuer seems to be for JFS volumes which are "unavailable" so I have not tried it.

Ideas anyone?

Dave Yeo:
Have you actually looked in your profile to see if the mbox files are still there? They should be somewhere under Mail, perhaps under Local Folders with the name of the folder.
If you're lucky, SM just lost track of them and they can be saved. I'd suggest first making a copy of your profile and then looking for the missing files. Sometimes it is just prefs.js that got damaged and restoring that from your backup will restore stuff. Other times it is the msf files got broken, they can be rebuilt but you may need to recreate the folder, shut down SM, copy the mbox file over new one, restart SM and click on the mail folder, open the properties, and click fix folder or such.
Frequent backups are a good idea, even keeping a couple of backups on your hard drive as often something like you experienced happens. I've had prefs.js get zeroed out, and profiles.ini likewise get zeroed out. Both very easy to restore.

Per E. Johannessen:
Yes I have checked the profiles folder and now I noticed that more folders/files are missing:
in \profiles\fakename.xyz\ there is only one folder named MAIL which contains 3 subfolders, one for each mail account, and each of them only contains the files I mentioned before, (the empty files created today; Inbox, Inbox.msf, Trash and Trash.mfs).

Just discovered another thing; tried to start OpenOffice Calc and it now starts with presenting the "Welcome to OpenOffice" like it does after a fresh installation. The OO package is installed on the same partition as the SeaMonkey mail stuff. I was using OO Calc a lot yesterday and at one point I had to restart it due to some calculation functions stopped working and after restarting it all worked again. As far as I can see all OO directories/files are where they should be. Other programs on this partition work fine.

Hi Per

Might be worth taking a look at the drive using DFSee - www.dfsee.com - to see if that can recover missing files.



Per E. Johannessen:
I've already used DFSee but only to check for errors and it did not find any.
Looks like I have to read the manual before using any of DFSee's recovery tools......


[0] Message Index

[#] Next page

Go to full version