OS/2, eCS & ArcaOS - Technical > Internet

socket () fails: Protocol family not supported

(1/2) > >>

R.M. Klippstein:
I get this error iduring boot of ArcaOS 5.0.3. This is not a problem with ArcaOS 5.0.3 rather a problem with ME! I've inadvertantly screwed something up and have no idea how to attack this error.  Is it possible there is something I might copy from another ArcaOS install (I have 5.0.2 thru 5.05 installed   and working!) that would fix this problem?
Thanks for any ideas, I know next to nothing about sockets & Protocols.


Hi klipp

Looks like a possible tcpip problem.

If you use Text Editor to create an empty file called ALTF2ON.$$$ IN \os2\boot and then reboot it may be possible to spot which driver is involved.



Just a guess,

make sure you have file "protocol" in your %ETC% directory (and "services" if that is also missing).

R.M. Klippstein:
Thanks Dave and Lars, Dave's ALTF2ON$$ showed a Adapter that needed to be removed, That fixed the problem, but now I've removed ALTF"ON$$ from but still get the expanded config listing. I tried ALTF2OFF$$ but didn't turn it off. (no big deal!).
One last question, I used to know where to look to see which ArcaOS was installed on a machine, but I've forgotten the location, Anyone Help?


Andreas Schnellbacher:

--- Quote from: R.M. Klippstein on August 28, 2020, 01:49:09 am ---which ArcaOS was installed on a machine

--- End quote ---


[0] Message Index

[#] Next page

Go to full version