OS/2, eCS & ArcaOS - Technical > Multimedia

Removing commercials from recorded TV programs

(1/4) > >>

Michael Snyder:
I play golf, sort of.  I also like to watch golf instructional videos on the Golf Channel, and record them for future viewing.  I have used a WinTV PVR card and EmperoarTV for this purpose for years, and it still works fine.  I don't want to see the commercials more than once, so for years I have used ProjectX to cut them out, mplex to put the audio and video back together, and ffmpeg to convert the resulting .mpg file to a small .avi file for storage.  The latter two things have stopped working correctly.  They worked under ArcaOS 5.0, but at some point they stopped.  I'm at 5.0.5 now.

If I run ProjectX under Golden Code java, it appears to work, but the .mp2 and .m2v files cannot be reassembled by mplex.  The audio seems to be OK, because the file that mplex produces has audio, but no video, but I've no way to check either of them except that they either mplex or not.  If I use the jave in 5.0.5, the program loads, but when I try to add a file, it crashes with no error message at all.

I recently copied the .mpg file produced by EmperoarTV to my OpenSUSE system and ran ProjectX under whatever java it has.  The resulting files were able to be multiplexed with mplex after I cut out the commerials.  The file will play in VLC, but cannot be converted to .avi with ffmpeg in Linux or in ArcaOS.  It will convert to an .mkv file with Handbrake, but at about twice the size of the former .avi files.

Is anyone else using ProjectX in ArcaOS for this sort of activity?  What java are you using?  Is there an easier way to do what I am doing in ArcaOS?


Dave Yeo:
I don't know the programs and searching for mplex doesn't help. Can you bypass the mplex step and just use FFmpeg to mux the audio and video in an AVI? What formats does ProjectX spit out?
FFprobe is a useful program included with FFmpeg to find out what format a file is.

Martin Iturbide:
Hi Michael.

I have no experience with those programs, but just to inform the rest, can you confirm the version that you are using under ArcaOS:
- projectx_v0.90.4.00-2006-03-31-rel2.zip
- mplex-1.6.2.zip
Are those?


Martin Iturbide:

I just made a quick test with Project-X 0.91 and OpenJDK on ArcaOS, and it runs. I don't know if it will work correctly since I don't know how to use it.
I only changed the path of the "startos2.cmd" file.


Martin Iturbide:

I can not run mplex 1.6.2 on ArcaOS. It says it was compiled with innotek gcc, so it is an old port.
I get:

--- Code: ---[C:\HOME\DOWNLOADS\MPLEX-1.6.2]mplex
SYS1804: The system cannot find the file LIBC06B4.

--- End code ---
Maybe someone with compiling experience can recompile it (there is a build.cmd file on it), or maybe port some newer version.



[0] Message Index

[#] Next page

Go to full version