Author Topic: VirtualBox 5.0.51 networking  (Read 570 times)

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 49
  • Posts: 1276
  • Karma: +10/-0
    • View Profile
VirtualBox 5.0.51 networking
« on: February 04, 2021, 04:15:28 pm »
I know this might be an old question but I can't remember how to do it.  I have just installed VBox 5.0.51 on my OS/2 ArcaOS test machine ind installed win XP.  That works but...  When I try to connect to any of my NAS boxes on the local network (192.168.0.xxx) they are not seen, indeed nothing on the local network is seen since VBox appears to think it is on 10.0.2.xxx subnet.

Can anyone remember how to change that 10.xxx.xxx.xxx subnet to a 192.xxx.xxx.xxx subnet?  Otherwise I will have to revert an old computer back to XP rather than dumping it to make more room. 

Andi B.

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 25
  • Posts: 559
  • Karma: +3/-1
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #1 on: February 04, 2021, 04:54:48 pm »
Can't you give your NAS a second (alias) IP address? If not you can try to attach a second network adapter to your guest and give this second one a fixed IP. In contrary to your first which uses one given by VBOX (DHCP).

But I'm not sure if this all works. Our network support is very limited. I think we can only use NAT. Maybe it works better when you attach a drive letter in your host for your NAS and then share this drive to your guest via shared folders.

 

Doug Bissett

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 61
  • Posts: 1441
  • Karma: +1/-0
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #2 on: February 04, 2021, 09:36:40 pm »
Quote
Can anyone remember how to change that 10.xxx.xxx.xxx subnet to a 192.xxx.xxx.xxx subnet?  Otherwise I will have to revert an old computer back to XP rather than dumping it to make more room

In the VBox Network settings, I use:
Attached to: NAT
Name: <blank>
Under Advanced:
Adapter type: Intel Pro /1000 MT...  (You DO need to have the driver ready to install in XP)
Promiscuous mode defaults to Deny
Mac address is created by VBox.

When I boot XP, it queries my router, and gets a DHCP address. It has been a while since I tried, but I think this configuration will NOT "talk" to the host machine, but it will "talk" to the other machines on the network (should include a NAS). Use the Shared folders feature to "talk" to the host machine.

You can use Bridged network, to "talk" to the host machine, as well as the rest of the network, but that requires the ancient TAP driver. It works, but will slow your whole network to a crawl.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 49
  • Posts: 1276
  • Karma: +10/-0
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #3 on: February 05, 2021, 02:35:33 am »
Thanks Andi and Doug but I am still stuck on the 10.x.x.x subnet as supplied by VBox which means everything on my 192.x.x.x network is not accessible.

Doug, I installed the Intel card driver at the VBox network settings and the driver in XP - i did remember that from years ago, but it does not change the VBox DHCP server or turn it off.

Now the search is, how to turn off the VBox DHCP server so that VBox uses the DHCP server in my managed switch like everything else on the network.

Ian Manners

  • Global Moderator
  • Sr. Member
  • *****
  • Thank You
  • -Given: 49
  • -Receive: 32
  • Posts: 400
  • Karma: +5/-0
  • I am the computer, it is me.
    • View Profile
    • ComKal Networks Australia
Re: VirtualBox 5.0.51 networking
« Reply #4 on: February 05, 2021, 08:02:50 am »
Hi Ivan,

In your x:\mptn\bin\setup.cmd file (you can do it from the TCP/IP setup panel but I havent used that for decades),
Add an alias for your other network, you will also have to add routing for the extra network.

Quote
ifconfig lan0 10.0.0.10 netmask 255.255.255.0  (any options you might be using go here)
ifconfig lan0 192.168.1.10 alias

route add default 10.0.0.1 -netmask 255.255.255.255
route add -net 192.168.1.0 192.168.1.1 -netmask 255.255.255.255

The extra lines are:-
   ifconfig lan0 192.168.1.10 alias
and
  route add -net 192.168.1.0 192.168.1.1 -netmask 255.255.255.255

Adjust 192.168.1.10 and the route 192.168.1.0 to 192.168.1.1 to your preference.

type route at a command prompt to show the help information.
Not sure if this will help going through the VBox interface but I see no reason for VBOX to clobber extra nets.
Cheers
Ian B Manners

Andi B.

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 25
  • Posts: 559
  • Karma: +3/-1
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #5 on: February 05, 2021, 09:42:56 am »
Quote
Now the search is, how to turn off the VBox DHCP server so that VBox uses the DHCP server in my managed switch like everything else on the network.
You don't need to turn off a DHCP server. If you want a client to use static IPs you've to set up the client that way. In your example you can always go to WinXP network TCP/IP settings and supply a fixed IP to XP. I suggested that for the second network adapter cause I think it does not work with the NAT setting of VBOX as we wanted it.

Ians suggestion is probably the better way to go - setup the host to use both networks (IP ranges 192.168.1.x and 10.0.2.x <-- mind .2 cause that's what VBOX uses per default for adapter 0).

BUT I didn't get it to work this way. Probably of VBOX NAT. Maybe cause of my limited network knowledge. I ended up in using 2 network adapters in WinXP VBOX guest - first one gets address 10.0.2.x, second one gets 10.0.3.x. Now as my privat network runs at (beside others) 10.0.2/24 too WinXP was not able to NAT to the rest of my network at the same network (10.0.2/24). Hence I set up VBOX so that there is no cable attached to WinXP/guest network adapter 0. And added a second network adapter to WinXP. So my WinXP now runs over adapter 1 (10.0.3/24) and VBOX NAT it into the rest of my network (10.0.2/24).

Quote
Thanks Andi and Doug but I am still stuck on the 10.x.x.x subnet as supplied by VBox which means everything on my 192.x.x.x network is not accessible.
I think this is a wrong assumption. Mind my limited network knowledge but to my understanding VBOX NAT these two. Unfortunately you can't test via ping cause ping does not work with our VBOX (and NAT). But I can f.i. surf the net via my router or print to my network printer although I can't ping to these.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 49
  • Posts: 1276
  • Karma: +10/-0
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #6 on: February 07, 2021, 09:03:42 pm »
Thank all for trying to help.  It ended up that VBox is not goint io do what I wanr - it won't even pick up a USB port so using a USB Stick is also out.

In the end I have decided to convert one of my mini ITX boxes to run XP - it sits on a shelf under my desk, connects to a KVM switch that allows me to use my keyboard and trackball and one of the three monitors I have around me.

Maybe, one day there will be a version of VBox that runs on an OS/2 host and uses the attributes of the latest AMD processors.  Until such time I have gained some space on the hard disk by deleting it.

Andi B.

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 25
  • Posts: 559
  • Karma: +3/-1
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #7 on: February 08, 2021, 10:29:29 am »
Thank all for trying to help.  It ended up that VBox is not goint io do what I wanr - it won't even pick up a USB port so using a USB Stick is also out.
You also wanted USB for the guest? USB on OS/2 based hosts is very limited. No clue why someone wants to expose these limited USB support to a guest. TTBOMK it does not work in our VBOX OS/2 port anyway. Given the limitation of the host system it does not make much sense to put work into USB support for the guest.

Basic network support is there. Shared folders from the host and they work much faster then in the older port. But don't expect better network support in a guest (NAS connection speed) than at host level.

I use a WinXP guest and work with data shared by the host. So these files (my work) are on my OS/2 host and included in my regular backups. Even when the virtual machine would crash (and it does as it needs so much shared mem). Printing to network attached printer works, connecting my banking software via Internet works, .... But don't expect a guest will ever support hardware better than the host. 

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 49
  • Posts: 1276
  • Karma: +10/-0
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #8 on: February 08, 2021, 12:07:44 pm »
Hi Andy,

I had hopes of being able to run a couple of programs that work on XP but not very well on Linux and not at all on OS/2.  One is the full display from my weather station (on Linux it will only display on a browser after messing about), the other is the collecting the information from a data logger and processing it.

Thanks for your comments.

Bernhard Pöttinger

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: VirtualBox 5.0.51 networking
« Reply #9 on: February 12, 2021, 04:54:37 pm »
Hi Ivan,

it should be no problem to connect your XP VM to your NAS in your local network. I have ArcaOS 5, with virtualbox 5.0.61. and my Windows XP VM can mount shares on a samba server. In our XP configuration setup networking as NAT (and not NAT-networking), choose as network adapter PCnet-FAST III and check "cable connected". In your Windows XP you have to install the correct driver, and than your VM schould receive 10.0.2.15/24 automatically. Maybe your XP guest cannot resolv the name of your NAS, so use the IP of the NAS or create entrys in the file C:\windows\system32\drivers\etc\hosts. My samba server connection is established with the following command

C:>net use Z:  \\fileserver\home\bernhard /user:openit\bernhard <password>
The command completed successfully

The machine fileserver has the IP 192.168.197.106.

best regards
Bernhard