Author Topic: OS2AHCI not defaulting on VirtualBox installation  (Read 434 times)

Eric Erickson

  • Jr. Member
  • **
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 60
  • Karma: +0/-0
    • View Profile
OS2AHCI not defaulting on VirtualBox installation
« on: September 25, 2020, 08:13:04 pm »
It took me awhile to figure this out, but if I do an install (5.0.5) on physical hardware, the OS2AHCI Drivers are included in the default list of DASD Drivers (along with DANI's). But if I do the same thing in a VirtualBox install that has the no IDE, but only AHCI controllers, the default driver selection does not include OS2AHCI. I have to always go in and add the drivers to the boot process in order to prevent the dreaded 'OS/2 is unable to operate your hard disks' message.

Anyone else noticed this and is this significant enough that I should open a ticket on it?

Cheers,

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 532
  • -Receive: 105
  • Posts: 2860
  • Karma: +5/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS2AHCI not defaulting on VirtualBox installation
« Reply #1 on: September 26, 2020, 01:22:16 am »
Hi Eric

Do you mean:
1) VirtualBox with all SATA. HDD and CD-ROM (Pic 1)
2) Boot the ISO with "Default Values". (Pic 2)
3) Get the error message that it can not find the installer. (Pic 3)

Is this the issue?
Maybe it can good to open a ticket. 
But, as you said, the workaround is easy, to boot with "own values" and add AHCI.

Regards
« Last Edit: September 26, 2020, 01:25:08 am by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 532
  • -Receive: 105
  • Posts: 2860
  • Karma: +5/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS2AHCI not defaulting on VirtualBox installation
« Reply #2 on: September 26, 2020, 01:27:55 am »
Hi

But maybe, instead of putting AHCI on the default boot, they will say to stick on what it says on this article:
https://www.arcanoae.com/wiki/arcaos/installation-planning/virtual-machine-configuration/oracle-vm-virtualbox/

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Eric Erickson

  • Jr. Member
  • **
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 60
  • Karma: +0/-0
    • View Profile
Re: OS2AHCI not defaulting on VirtualBox installation
« Reply #3 on: September 26, 2020, 05:35:10 pm »
Martin,

Its not that it can not find the installer message. I get the 'OS/2 Can not operate your Hard Drive" message. Its more an annoyance that if you install on physical hardware with AHCI (SATA) only drives, the default installer options add the OS2AHCI Driver to the initial boot menu. If install in a virtualbox with only AHCI Controllers for your attached devices, the default does not include OS2AHCI and you have to manually add it in. I just find that an annoyance and inconsistent actions between the two installation environments.

I think I will open a ticket, just to see what the 'official' line is.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 532
  • -Receive: 105
  • Posts: 2860
  • Karma: +5/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: OS2AHCI not defaulting on VirtualBox installation
« Reply #4 on: September 26, 2020, 05:57:33 pm »
I think I will open a ticket, just to see what the 'official' line is.

Agree !!
Martin Iturbide
OS2World NewsMaster
... just share the dream.