OS/2, eCS & ArcaOS - Technical > Applications

FreeRDP - we have options!!!

<< < (2/4) > >>

Mathias:
I'm using FreeRDP also on my OS/2 box at work. It's kind of the control center from where I connect to everywhere via VNC or FreeRDP.

In general I DO like the FreeRDP client for OS/2 as it is quite stable, captures key combos (even when NOT in full screen) and most importantly it DOES simply work as expected... while linux clients like Remmina tend to "loose" their ability to map-through key combos to the remote system. Like for instance pressing ALT+F4 to close a window on the remote side.. works.. next time I do this.. it closes the remmina client, EVEN THOUGH I am in full screen .... >_< WOAAH!
So with the current Remmina release you'd always have to check, if the remote machine or the local machine is being targeted, by pressing WINDOWS + R to see if the remote machine either displays the "Run box", which is the proof that it currently works, OR nothing happens (as the local system cannot do anything with WINDOWS + R).. then you know.. it's broken currently, and you need to go out of full screen, and reenter full screen... and theeeere it works again... until it decides to stop working the next time you try it... or the 2nd to next time.. you never know.

This NEVER happened to me with FreeRDP on OS/2. Appears to be very stable and does the job just right.
Excellent stuff that!

The benefit (for me) also is, that connections to remote hosts (or applications) come as a WPS icon, which visually shows if connected or not.

Imagine a situation like that:
10, 15 or even 20 hosts, all connected at the same time via FreeRDP, showing they are connected via the WPS icon.
Now somebody connects to one of these hosts, disconnecting your session.
On a windows machine... you'd now start to find out which RDP session got disconnected.
On a OS/2 machine you see that right away, since the WPS icon shows, it's not in use anymore!

AWESOME. This way you can save time and can connect right back.

But, where there is light, there are shadows also, and so I DO have one complaint:
FreeRDP on OS/2 somehow cannot manage the third level key assignments on DE keyboards.
As for example when I want to type a \ backslash, I'd usually do ALT_GR + ß
ß alone does work...
But ALT_GR does not work over FreeRDP.
So, as a workaround I always need to use CTRL + ALT + ß to send the \ backslash to the remote machine.. which is a bit odd.

This is not critical, but becomes annoying, when you constantly are reminded that ALT_GR is not properly supported by the FreeRDP port to OS/2.

Besides that effect, FreeRDP is AWESOME and needs to be supported. : )

Andreas Schnellbacher:
Have you tried Ctrl+Alt instaed of AltGraf? That applies to Virtual PC an maybe also to the OS/2 version of VirtualBox. BTW: I had only tried Andrey's Rdesktop and it worked well. It supports only RDP.

(With Rdesktop, I had the problem that my German keyboard worked as if it was an en_US one. But it turned out that the server was set to en, while all MS RDP clients change the language to the remote language, without having to switch the language on the server. Andrey and Lewis found that out and my keyboard worked well after changing the server's language.)

Mathias:
hehe yep, as said CTRL + ALT + key I did try, and it works. This is my workaround for the moment.

Target machine are: DE Windows Server 2012 R2, DE Windows Server 2016 and simple DE Windows 10.

Maybe I should write to Andrey Vasilkin and bring this to his attention. Maybe he just don't know.. : )
Well.. besides that effect, it ll works flawlessly. : )

Andreas Schnellbacher:
Glad that it works. IIRC, I had found it in the Virtual PC doc.

Lutz Wagner:

--- Quote from: Dariusz Piatkowski on September 30, 2020, 03:34:00 pm ---With FreeRDP you can certainly be a single-click away from having access to a Firefox 'whatever version' you need ... locally on your OS/2 WPS literally as if it was just another PM window.
--- End quote ---
That's exactly what I'm dreaming of. So I installed the FreeRDP-package, and it works fine on my patched Windows-7-home-PC.

BUT not in application-program-mode.

What I did: I generated a second WPS-object, exactly like the first (working) one, with the only modification being the "Remote App"-tab. I specified path and filename of the firefox-exe on that Win7-PC.

To check this path and filename I opened a Windows-commandline session (cmd.exe) and typed that path and filename into it. And yes, Firefox/Win started up.

But doing the same by means of my WPS-icon nothing happenes at all. No Firefox starting up, no error in the log file. For a fraction of a second the icon gets shaded, then nothing.

Do I have to meet some special prerequisites on that Win7-machine?

Thanks for any idea.

Lutz Wagner

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version