Author Topic: Thunderbird using 100% CPU on newly installed ArcaOS 5.0.6  (Read 3486 times)

Bennie Nelson

  • Newbie
  • *
  • Thank You
  • -Given: 1
  • -Receive: 1
  • Posts: 27
  • Karma: +2/-0
    • View Profile
Re: Thunderbird using 100% CPU on newly installed ArcaOS 5.0.6
« Reply #45 on: December 18, 2020, 01:06:02 am »
Seems that what is happening is that without finding sscore.dll, it falls back on UsePollMode() which must have a bug somewhere on our system, possibly in the timer stuff. Someone else mentioned that the Bitwise builds of Firefox didn't have this issue.
Have you tried it with the screensaver installed but not activated? You can nuke the .dssaver directory in %HOME% to return it to a newly installed state. Seems that the VirtualBox environment may make the problem more noticeable. I'll experiment here or perhaps reboot to Linux and use VBox.

Yes, for now, I'll install the screensaver, but leave it disabled. Firefox and Thunderbird work fine, and I'm happy with the solution (and ArcaOS 5.0.6).

Bennie

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 219
  • Posts: 3078
  • Karma: +50/-0
    • View Profile
Re: Thunderbird using 100% CPU on newly installed ArcaOS 5.0.6
« Reply #46 on: December 18, 2020, 02:51:24 am »
Seems just having sscore.dll on the LIBPATH is good enough, though I'm not sure yet how it affects the housecleaning. It's seeming like SSCore_GetInactivityTime() was added to the screensaver just for this. I'll keep investigating as others are having a similar problem.