Author Topic: OpenSSH_7.7p1 tcgetattr: Invalid argument  (Read 1315 times)

Bernhard Pöttinger

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 24
  • Karma: +1/-0
    • View Profile
OpenSSH_7.7p1 tcgetattr: Invalid argument
« on: December 03, 2020, 10:24:43 am »
Hi,
I have updated my rpm packages and so openssh-clients version 7.7p1 was installed. This version has some problems:

Code: [Select]
[C:\]ssh -V
OpenSSH_7.7p1, OpenSSL 1.0.2t  10 Sep 2019

[C:\]ssh prometheus
root@prometheus's password:
[b]tcgetattr: Invalid argument[/b]
Last login: Thu Dec  3 08:31:12 2020 from einstein.intern.openit.at
[root@prometheus ~]#
LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=20034694 lock=0x1
pid=0x0041 ppid=0x003e tid=0x0001 slot=0x0078 pri=0x0200 mc=0x0000 ps=0x0010
C:\USR\BIN\SSH.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

The external process was cancelled by a Ctrl+Break or another process.

The problem is the line "tcgetattr: Invalid argument". I have an older Version as OpenSSH_5.3p1 as wpi installed; this version does not show the error and is working proper. Is there a solution for version 7.7p1.

best regards


Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 184
  • Karma: +1/-0
    • View Profile
Re: OpenSSH_7.7p1 tcgetattr: Invalid argument
« Reply #1 on: December 03, 2020, 12:26:22 pm »
Hi,
I have updated my rpm packages and so openssh-clients version 7.7p1 was installed. This version has some problems:

Code: [Select]
[C:\]ssh -V
OpenSSH_7.7p1, OpenSSL 1.0.2t  10 Sep 2019

[C:\]ssh prometheus
root@prometheus's password:
[b]tcgetattr: Invalid argument[/b]
Last login: Thu Dec  3 08:31:12 2020 from einstein.intern.openit.at
[root@prometheus ~]#
LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=20034694 lock=0x1
pid=0x0041 ppid=0x003e tid=0x0001 slot=0x0078 pri=0x0200 mc=0x0000 ps=0x0010
C:\USR\BIN\SSH.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

The external process was cancelled by a Ctrl+Break or another process.

The problem is the line "tcgetattr: Invalid argument". I have an older Version as OpenSSH_5.3p1 as wpi installed; this version does not show the error and is working proper. Is there a solution for version 7.7p1.

best regards
please write mail to info@bitwiseworks.com. we can then workout the issue way better than in here. as I have new builds since longer but never uploaded so far.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

Rick Smith

  • Jr. Member
  • **
  • Thank You
  • -Given: 0
  • -Receive: 2
  • Posts: 54
  • Karma: +3/-0
    • View Profile
Re: OpenSSH_7.7p1 tcgetattr: Invalid argument
« Reply #2 on: January 21, 2021, 04:56:50 am »
Hi,
I have updated my rpm packages and so openssh-clients version 7.7p1 was installed. This version has some problems:

Code: [Select]
[C:\]ssh -V
OpenSSH_7.7p1, OpenSSL 1.0.2t  10 Sep 2019

[C:\]ssh prometheus
root@prometheus's password:
[b]tcgetattr: Invalid argument[/b]
Last login: Thu Dec  3 08:31:12 2020 from einstein.intern.openit.at
[root@prometheus ~]#
LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=20034694 lock=0x1
pid=0x0041 ppid=0x003e tid=0x0001 slot=0x0078 pri=0x0200 mc=0x0000 ps=0x0010
C:\USR\BIN\SSH.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

The external process was cancelled by a Ctrl+Break or another process.

The problem is the line "tcgetattr: Invalid argument". I have an older Version as OpenSSH_5.3p1 as wpi installed; this version does not show the error and is working proper. Is there a solution for version 7.7p1.

best regards

Just curious if you had got this working? I am on 5.3 and I can’t sftp, run ssh-agent. I can ssh in to the arca vm but my kB doesn’t act as expected. I can’t backspace or use del or arrow keys.. is 7.7 fix any of this?

Regards,

Rick

Bernhard Pöttinger

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 8
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Re: OpenSSH_7.7p1 tcgetattr: Invalid argument
« Reply #3 on: January 24, 2021, 07:45:06 pm »
Hi Rick,

I have used an openssh wpi package

http://hobbes.nmsu.edu/download/pub/os2/apps/internet/telnet/openssh-5.3p1-bin.zip

which is working well; the openssh packages installed with yum do not work correctly.

best regards
Bernhard

Alex Taylor

  • Sr. Member
  • ****
  • Thank You
  • -Given: 12
  • -Receive: 19
  • Posts: 291
  • Karma: +0/-0
    • View Profile
Re: OpenSSH_7.7p1 tcgetattr: Invalid argument
« Reply #4 on: January 28, 2021, 01:38:40 pm »
The SSHD port has always been a bit rough around the edges. Make sure your TERM setting is something reasonable, whatever the documentation recommends or perhaps 'os2'.

Also see what your login shell is: CMD, TNPIPE, or VIOROUTE. If one of those doesn't work well, try one of the others.  (I always found TNPIPE seemed to work most smoothly, but it has some limitations.)