OS/2, eCS & ArcaOS - Technical > Web applications

Seamonkey that plays well with firefox 45.9

(1/2) > >>

David Kiley:
I recently installed arcaos 5.06 on real hardware - and everything went great.
But then I tried to install seamonkey-2.7.2.r2.en-us.os2-wpi.wpi (It looked to me that was the latest version?) and i'm not
sure what it did but installing it seemed to frag both firefox and seamonkey - neither would load after doing that.

It seems that installing browsers is more complicated then I remember.. last time I played with OS/2 (ecomstation 1.2) you could just unzip into a folder and launch the browser.

So anyways just wondering if anyone knows how to safely install seamonkey without doing that.

Dave Yeo:
Use the latest. https://hobbes.nmsu.edu/?search=SeaMonkey&stype=any&sort=type_name&dir=%2F 2.42.9ESR. Note, it looks like I screwed up naming the i686 version, seamonkey-2.42.en-US.os2-i686-15112020.zip.
Mozilla apps have always had problems due to using the same DLL names, and now dependencies can cause problems as well.

David Kiley:
Well it did it again unfortunately. Installing the yum rpm requirements then results in both firefox and thunderbird not being able to load.
I'm getting the message Couldn't load xul.dll (faulty module libvpx4) when trying to start firefox - and "couldn't load xpcom" when trying to load thunderbird.

Seamonkey is working great though 8)

I looked through the readme but I must be missing something. Any ideas would be appreciated.

Dave Yeo:
You need to install libvpx-legacy-4 with ANPM or YUM. Libvpx got updated at some point so newer builds link against newer libvpx. To be safe you could also install libvpx-legacy-2.

David Kiley:
Thanks Dave - really appreciate it. libvpx-legacy-4 worked without issue, and now everything is loading without errors.


[0] Message Index

[#] Next page

Go to full version