OS/2, eCS & ArcaOS - Technical > Storage

USB 3 Hard drives

(1/2) > >>

Dave Yeo:
Hi, there's been various discussions about USB 3 hard drives here and on the testers list so I thought I'd start a new dedicated thread.
I've acquired a Seagate Slim Drive USB 3 2TB drive for backup purposes which worked well with USB 2, peaking at about 19 MB/s.
Now I acquired this, https://www.ebay.ca/itm/USB-C-PCI-E-Express-Card-USB-3-1-2-Port-Controller-Adapter-HUB/133124878295?hash=item1efedc6fd7:g:OCYAAOSwjm5dOpkd which showed up within 3 days in my mail. Unluckily the needed cables from a different supplier haven't shown up yet. So I lucked out and picked up a 6 foot USB C to USB A cable at London Drugs for $7 bucks, it's rated at 5Gb/s, USB 3 speed.
Testing by transferring an ArcaOS ISO using File Commander, I see speeds of 90-98 MB/s, under Linux, Using MC and an EXT4 partition, the speeds are about 100-110 MB/s for really big files with the odd really high peak. Seems pretty decent, at that testing with the Mozilla source tree (about 5GB's of mostly small files) it is still about 30 MB/s, speeding up for large files and slowing down for small files. It's actually faster then my SSD on a SATA 2 port and may be the fastest drive in my system.
Problems, I have a 1 TB JFS partition for backing up to. Given a power failure or system crash, chkdsk runs for hours before quitting  with

--- Code: ---JFS0101: CHKDSK  Insufficient dynamic storage available for required workspace

--- End code ---

I guess I'll repartition as even though after ejecting and remounting the drive seems fine, who knows.
The other problem is all attempts to benchmark with diskio or sysbench locks the system hard, requiring the big red button to reboot and that hours long chkdsk.
Copying files, using rsync and such seem to work fine.
I must say I'm impressed so far with the hard drive speed, unlike other reports. Not sure if due to the USB C controller or what.
Edit, USBTree reports,

--- Code: ---USB driver version = 12.8
----- USB device tree ---------------------------------------------------------
DS 07f0=4ff8

Controller 0: USBXHCD$
Root Hub 0 (4 ports) 1B21:2142
  Port 1: Device 0BC2:AC2D (MSD)-(SCSI)-(BO)(MSD)-(SCSI) SS Seagate RSS LLC

--- End code ---

Andi B.:

--- Quote ---Testing by transferring an ArcaOS ISO using File Commander, I see speeds of 90-98 MB/s,
--- End quote ---
This is the first test I saw which proofs that more than 20-25 MB/s is possible with ArcaOS and USB. It contradicts the feedback I got from others. You seem to be the first person which was able to transfer data with more than USB2 speed. Seems this Asmedia chip is better supported by our drivers than my Intel.

A quick question, how are you measuring the file transfer speed and can it be setup to record it automatically?  All my big file backups happen at night when I am abed to both USB 3 mounted drives and NAS boxes with Ext4 partitions.

Martin Iturbide:
Hi Dave

Sorry to ask and don't add anything to the discussion, I will like to include this card to the OS2World wiki supported hardware.

Is the back port for power using the SATA power cable? It is required, right?

Do you have any more hardware information like the chipset that it uses? Is there any hardwareID on which it is recognized on pci.exe?


Dave Yeo:
Hi Ivan. As said, I was using File Commander to copy the ISO's (Midnight Commander on Linux) and the source tree. Rsync also outputs speeds, mostly low for small files and higher for large files. The output of rsync could be piped to a log file.

Hi Martin, yes, the back port has a SATA power cable plugged in. I bought a Y cable, then had to extend it as this Dell only had 4 SATA power cables, exactly the right length to reach the HD's and DVD's. Remember, it is USB C, which is supposed to be capable of delivering more power for charging and such. Not sure if I'd trust the power supply to deliver lots of amps but this USB drive worked fine on USB 2 power.
I looked at various USB 3 controllers as well, they mostly took the old style of HD power cable and all seemed to need external power compared to what the PCI-E bus can deliver.
This card also needed an X4 PCI-E slot, I have it plugged into the 2nd physical X16 slot which is wired as a X8. Most of the USB 3 cards used 1 lane and plugged into a X1 slot. As this computer is old and only 2nd generation PCI-E, I figured using 4 lanes (actually seems to only use 2 lanes) would be an advantage.
Don't have much more info, the card came with a little CD with Windows and Mac drivers and that was about it.
PCI reports,

--- Code: ---Bus 3 (PCI Express), Device Number 0, Device Function 0
Vendor 1B21h ASMedia Technology Inc.
Device 2142h ASM2142 USB 3.1 Host Controller
Command 0006h (Memory Access, BusMaster)
Status 0010h (Has Capabilities List, Fast Timing)
Revision 00h, Header Type 00h, Bus Latency Timer 00h
Self test 00h (Self test not supported)
Cache line size 64 Bytes (16 DWords)
PCI Class Serial, type USB (UHCI), programming interface 30
Subsystem ID 21421B21h Unknown (Generic ID)
Subsystem Vendor 1B21h ASMedia Technology Inc.
Address 0 is a Memory Address (64-bit) : E1A00000h..E1A07FFFh
System IRQ 58, INT# A
New Capabilities List Present:
  Message Signalled Interrupt Capability
    MSI is enabled
    MSI function can generate 64-bit addresses
  MSI-X Capability
  Power Management Capability, Version 1.2
    Does not support low power State D1 or D2
    Supports PME# signalling from mode(s) D0
    PME# signalling is currently disabled
    3.3v AUX Current required : 55 mA
    Current Power State : D0 (Device operational, no power saving)
  PCI Express Capability, Version 2
    Device/Port Type :
      Legacy PCI Express Endpoint Device
    Device Capabilities :
      Unsupported Request Severity is Fatal
    Device Status :
      Correctable Error Detected
      Unsupported Request Detected
      AUX Power Detected
    Link Capabilities :
      Maximum Link speed : Unknown (03h)!!
      Maximum Link Width : x2
      Link Port Number   : 0
    Link Control :
      Common Clock Configuration In Use
    Link Status :
      Current Link speed : Unknown (02)!!
      Current Link Width : x2

--- End code ---


[0] Message Index

[#] Next page

Go to full version