Author Topic: Restoring T450S backup to M93P Tiny - USB HID woes  (Read 1079 times)

Ibrahim Hakeem

  • Jr. Member
  • **
  • Thank You
  • -Given: 3
  • -Receive: 4
  • Posts: 87
  • Karma: +2/-0
    • View Profile
Restoring T450S backup to M93P Tiny - USB HID woes
« on: December 24, 2020, 09:00:10 am »
Hi all.

As the title summarizes, I recently got my hands on a Lenovo Thinkcentre M93P Tiny - mainly to have something a bit more practical to run at my desk rather than my T450S. I initially ran a fresh install of ArcaOS 5.0.6 which mainly worked... save for the keyboard input which was repeating keystrokes if you typed at any reasonable speed.

After running into this roadblock, I figured restoring a backup of my Thinkpad T450S to the computer (using the setup USB and DFSEE) might yield better results but I'm now in the situation where I'm no longer able to use any USB mouse or keyboard post-boot. The computer will still recognize my USB disks but no HID devices. The USB stack I'm currently using is the Arca Noae 12.07 driver package.

I'd much rather work from this state rather than a fresh install as the environment is already perfectly configured and ready to go (save for the USB HID situation).

Does anyone have any advice or pointers on where to go from here?

Thanks in advance  :)
« Last Edit: December 24, 2020, 10:31:59 am by Ibrahim Hakeem »

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 229
  • Posts: 3216
  • Karma: +62/-0
    • View Profile
Re: Restoring T450S backup to M93P Tiny - USB HID woes
« Reply #1 on: December 24, 2020, 10:07:47 am »
OHCI vs ECHI drivers? Post the USB parts of the config.sys. Ideally would be to have the config.sys of the failed install. Output of PCI would be nice too.

Ibrahim Hakeem

  • Jr. Member
  • **
  • Thank You
  • -Given: 3
  • -Receive: 4
  • Posts: 87
  • Karma: +2/-0
    • View Profile
Re: Restoring T450S backup to M93P Tiny - USB HID woes
« Reply #2 on: December 24, 2020, 11:00:19 am »
OHCI vs ECHI drivers? Post the USB parts of the config.sys. Ideally would be to have the config.sys of the failed install. Output of PCI would be nice too.

I'll do a stock install on a different hard drive and report back with the output of PCI as well as the usb sections of config.sys from the T450S image. As for the drivers currently being used, I believe they're EHCI.

Ibrahim Hakeem

  • Jr. Member
  • **
  • Thank You
  • -Given: 3
  • -Receive: 4
  • Posts: 87
  • Karma: +2/-0
    • View Profile
Re: Restoring T450S backup to M93P Tiny - USB HID woes
« Reply #3 on: December 24, 2020, 01:13:57 pm »
So upon a quick comparison between the two config.sys files' USB sections, I saw that the installation with the working mouse/keyboard has two back-to-back references to:
Quote
BASEDEV=USBEHCD.SYS

The section from which this was obtained is as follows:
Quote
BASEDEV=USBD.SYS
BASEDEV=USBEHCD.SYS
BASEDEV=USBEHCD.SYS
BASEDEV=USBXHCD.SYS
BASEDEV=USBHID.SYS
BASEDEV=USBCDROM.ADD /CDS:1
BASEDEV=USBMSD.ADD /REMOVABLES:8 /FLOPPIES:0

Whereas the restored backup from my T450S only has one. After adding that extra line into my config.sys file, it would seem the problem has totally gone away and that I am able to use a mouse and keyboard properly once again. I'm a little bit perplexed as to why referring to the same BASEDEV twice in config.sys would have this effect, but I am honestly relieved the solution was this straightforward.

The repeating keystroke problem is still here, but it's nowhere near as often as it was before. Everything seems to be working alright now.

I've attached a copy of the PCI report in case you're still interested  ;D

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 52
  • Posts: 1327
  • Karma: +13/-0
    • View Profile
Re: Restoring T450S backup to M93P Tiny - USB HID woes
« Reply #4 on: December 24, 2020, 02:14:25 pm »
It depends on the number of discrete USB chips you have - one driver per chip, miss one and have something plugged into that port, it won't work.

My older Ryzen based boards need the following:

Quote
BASEDEV=USBD.SYS
basedev=usbxhcd.sys
basedev=usbxhcd.sys
basedev=usbxhcd.sys
basedev=usbxhcd.sys
BASEDEV=USBUHCD.SYS
BASEDEV=USBUHCD.SYS
BASEDEV=USBEHCD.SYS
BASEDEV=USBEHCD.SYS
 
but my new third generation Ryzen board is going to need several more usbxhcd lines to cover the number of chips it has.

Andreas Schnellbacher

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 40
  • Posts: 733
  • Karma: +13/-0
    • View Profile
Re: Restoring T450S backup to M93P Tiny - USB HID woes
« Reply #5 on: December 24, 2020, 02:16:15 pm »
Peter's usbcfg might help in such a case.

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 52
  • Posts: 1327
  • Karma: +13/-0
    • View Profile
Re: Restoring T450S backup to M93P Tiny - USB HID woes
« Reply #6 on: December 25, 2020, 11:59:54 pm »
It should when he updates it to show USB 3.

Ibrahim Hakeem

  • Jr. Member
  • **
  • Thank You
  • -Given: 3
  • -Receive: 4
  • Posts: 87
  • Karma: +2/-0
    • View Profile
Re: Restoring T450S backup to M93P Tiny - USB HID woes
« Reply #7 on: December 27, 2020, 10:44:34 am »
Peter's usbcfg might help in such a case.

It absolutely would! I'll definitely keep this utility in mind the next time I need to pull something like this off  :)