OS/2, eCS & ArcaOS - Technical > Storage

Regarding the Netlabs FAT32 driver

(1/2) > >>

Ibrahim Hakeem:
After seeing Dariusz's recent thread, I'm now using the Netlabs FAT32 driver instead of the AN one and life is already so much more convenient.

All is not well in paradise however... Does anyone get any stability/access issues with this driver and if so, are there any good tricks on avoiding those problems (Namely the SYS0266 error)? I'm finding I have to reinstall the driver and reboot a few times afterward in order to get it to read/write FAT32 partitions (all formatted with DFSEE) which otherwise run fine on my other non OS/2 environments.

Thanks in advanced as always  :)

I take it you have the latest version installed?
Also make sure that no duplicates exist anywhere. That was at least true for eCS (that installed its own version into a different directory).
I'll have to check what SYS0266 stands for.
As always, make sure that ALL IFS drivers come first in config.sys (at least before all other drivers).. There's a kernel deficiency that will lead to unpredictable side effects if you do not do this.

Ibrahim Hakeem:
I'm running 0.10.r383 on ArcaOS and I've verified there are no duplicates, the line referring to FAT32.ifs is as follows:

--- Quote ---ifs=C:\OS2\BOOT\FAT32.ifs /cache:2048 /h /q /ac:* /largefiles /fat /exfat
--- End quote ---

All IFS references are just after the first line which I think is required for JFS to start:

--- End quote ---

Neil Waldhauer:

--- Quote ---SYS0266: The specified file was not copied.

EXPLANATION: Either the source and target files are not in the same
file system or the operating system does not support COPY for this
file system.

ACTION: Check the source and target file names and retry the operation.

--- End quote ---

Dariusz Piatkowski:
Hi Ibrahim,

For what it's worth, here is the order of the IFS statements in my CONFIG.SYS (just in case that's playing a havoc in your case):


IFS=G:\OS2\JFS.IFS /CACHE:262144 /LW:8,30,6 /AUTOCHECK:*




REM ****************************************************
REM * FAT32 - the following three lines are DEFAULT  ***
REM * installation parameters                        ***
REM ****************************************************
REM IFS=G:\OS2\BOOT\FAT32.IFS /cache:2048 /h /q /ac:* /LARGEFILES /FAT
REM CALL=G:\OS2\CACHEF32.EXE /f /p:2 /m:50000 /b:250 /d:5000

rem CALL=G:\OS2\CACHEF32.EXE /F /M:50000 /B:250 /D:5000


--- End code ---

Note the non-default options for FAT32 driver in my setup, I shut off the cache processing (/CACHE:0) and do not run CACHEF32 at all. I found that this produced the better result on my system.

Keep in mind please that this is solely based on the fact that I'm only interested in pulling data off of a DSLR camera storage card, that's a very clean: "mount, copy and eject" process. If I had a larger storage device that I intended to do a lot more file operations on I would most likely keep the CACHE enabled.

Regarding your issue, how about just try with '/FAT' parameter only? I had actually removed this specification so that FAT32 driver figures out on-the-fly what it needs to support given the device that's connected. My DSLR cards are all FAT32. I also do NOT load the LOOP.ADD driver as I have no need for it. So while the initial install included it, for now I have it shut off (the less complexity, the better).


[0] Message Index

[#] Next page

Go to full version