OS/2, eCS & ArcaOS - Technical > Multimedia

Desktop weirdness

<< < (2/5) > >>

Dariusz Piatkowski:

--- Quote from: Doug Bissett on January 12, 2021, 10:56:53 pm ---
--- Quote ---Something else he could try is to clean up the INI files with something like XFIX or CLEANINI.  It may do nothing but experience says that when the INI files get too large because of junk staying there strange things happen to the Desktop on startup.
--- End quote ---

That's a thought. I know that he was cleaning the INI files, perhaps he forgot, and it got away from him, or he may not have been doing it properly.


--- End quote ---

Don't most of our (if not all) INI maintenance tools routinely backup the INI files before you start doing anything on them (I know CHECKINI does, as I use it here)??? So there is a chance the previous un-touched version is still out there.

In parallel to this, OS/2 backs up the INI files as well...sometimes the OS2SYS and OS2 may be a touch out of sync, but otherwise look for the *.BAK versions of these two out in \OS2 directory.

Andreas Schnellbacher:
IIRC this may happen if one has accessed the archived desktops in \OS2\ARCHIVES or the desktop from another OS/2 installation with the WPS. That should only be made with non-WPS file managers. (The same applies to the templates folder.)

To clean the startup folder problem, I see two options:

The first one is to restore an old archive, as David has written.

The second one is to edit OS2.INI: PM_Workplace:Startup. There should be only one key. (XWP's startup folders should not appear here.) How to find the correct one: The key name represents almost the hex. object handle of the startup folder. Prepend it with a '3' ('3' for a file object, '2' for an abstract object). Mine is 15CE. That means that the object handle is 315CE.

Open the properties notebook of the folder named "Startup". Icon -> Details... -> Object handle. Here the entry is 0x315CE, which looks correct.

About templates: IIRC there exist VIO tools by Steven or Rich to clean them.

Rich Walsh:

--- Quote from: Doug Bissett on January 12, 2021, 10:12:35 pm ---I have used the VOICE HelpDesk thing in the past, but that won't work any more (Telus has blocked everything), so I can't have a look.

--- End quote ---

You should re-read "HelpDesk.txt".

--- Code: ---  Alternate Ports
  Hosts that already run an SSH server on Port 22 may want to configure
  HelpDesk to use another port.
  Note: using an alternate port may enable connections from clients who
  are behind a firewall that blocks port 22. Try using the port for a
  well-known service such as http (80) or some flavor of email that is
  less likely to be blocked.

--- End code ---

BTW... what ever happened to the once-standard advice of "Run checkini"?

--- Code: ---=================================================
 Checking PM_Workplace:Startup

║ Remove stored reference to non-existing or faulty startup folder ?  ║
║     NOTE: Objects in this folder will no longer be autostarted!     ║
║                YES               │               NO                 ║

--- End code ---

Doug Bissett:

--- Quote ---You should re-read "HelpDesk.txt".
--- End quote ---

I did. It was working, before Telus replaced my old modem (actually a router as well) with a new one. Now, it seems that NO incoming traffic can get through. Alternate ports don't work. I suspect that they have, somehow, blocked the modem from accepting it's own address. Out going is okay, incoming seems to be blocked. Period. I can't even ping my own outside address (not that that means much).

I can make Helpdesk work through my own router, but not through the modem. I even tried my cell phone connection. It is with Public Mobile (which is owned by Telus), and it does the same thing. I can get out, but not in. I haven't, yet, tried to do a direct connection to my brother's computer (he is with Sympatico which is Bell Canada), and I wouldn't be surprised if they block that sort of thing too. It will be a major project to get him to open a port in his modem (especially when I don't know anything about his modem).

Telus was, at one time (when they were Alberta Government Telephones), a leader in internet technology. Now, they can't even run an e-mail server, and they farmed that out to GMail, which is nothing short of a royal pain. Unfortunately, there aren't a lot of options, and most, if not all, of the alternatives are even worse. I am looking at getting a business account, which is, of course, more expensive (but that is why they block things).

--- Quote ---BTW... what ever happened to the once-standard advice of "Run checkini"?
--- End quote ---

Well, I asked my brother to do it, but I don't think he has done it yet. It would be so much easier if I could just go there and fix the problems. The biggest problem is, that he has lived with the problem for a while, without telling me, so going back is probably not an option any more.

Dave Yeo:
Off-topic, I got the mail telling me that I'm being moved to Gmail from Telus mail yesterday. I've started experimenting with gmx.com for mail.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version