Author Topic: USB Audio - Issues with some Devices  (Read 2069 times)

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 593
  • -Receive: 121
  • Posts: 3256
  • Karma: +26/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: USB Audio - Issues with some Devices
« Reply #15 on: January 16, 2021, 05:07:55 pm »
Thanks Lars.

I had de-installed USBAudio with "minstall" first. Rebooted and installed your drivers with "minstall" again, all the 4 packaged included and rebooted. I'm using ArcaOS 5.0.6.

To test, first I tried the "HP Gaming Headset H320GS" which was working before and I confirmed it still records audio with its USB mic with DTAPE. With this I guess the USBAUDIO driver is installed correctly since it worked.

Now I tried the USB Mic first: C-Media Electronics USB Mic (0D8C:013C). It did not work.

First I tried a lsusb just to be sure it is recognized.
Code: [Select]
[X:\]lsusb
Bus 001 Device 001: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 002: ID 05c8:0317 Cheng Uei Precision Industry Co., Ltd (Foxlink)
Bus 001 Device 003: ID 147e:1002 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 004: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller

Later I used DTAPE to test with the same settings that I used "HP Gaming Headset H320GS". The program gives me a "Hardware Error".

I also tried "Audio Recorder" and I got a similar hardware error.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #16 on: January 16, 2021, 07:18:57 pm »
Try this.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #17 on: January 16, 2021, 07:44:19 pm »
If it still does not work, I'd need you to activate tracing for major code 238.
How this is done is described in the readusb.txt. I would need a formatted trace. That will hopefully tell me enough about what is going wrong so that I can fix it.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 593
  • -Receive: 121
  • Posts: 3256
  • Karma: +26/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: USB Audio - Issues with some Devices
« Reply #18 on: January 17, 2021, 02:26:40 am »
Hi Lars

I followed the instructions.

- Added these on the config.sys.
Code: [Select]
TRACEBUF=2048 /M=W,Q,NODTI /D=ALL
TRACE=ON 238
- Rebooted, Attached the USB mic C-Media Electronics USB Mic (0D8C:013C).
- Executed DTAPE, produced the Hardware error twice
- Executed record.exe and produced the Hardware error twice
- Saved the .ftf file as formatted.

I hope it can give some hints.
Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #19 on: January 17, 2021, 12:47:33 pm »
What sampling rate,num channels, bit depth did you select ? Did you indeed select record ?
Did you do the same as the screen shot you posted ?
I need to know this so that I know if the app request matches to what is requested from the driver or not.
As I said, the multimedia subsystem is a mess.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #20 on: January 17, 2021, 01:02:41 pm »
ok, had a look at the trace.
I assume that you asked for recording in both cases (which I am pretty certain is true).
What I can see already is that the system insists on calling the driver for "playback" which of course is wrong and also, as we know, the device cannot do "playback". No wonder it returns with an error (even though it correctly reports back that it can do "record").

Can you do me a favor and repeat this, including tracing, with the original 10.237 driver set ? I just want to know where we started initially.

If I have this picture I hopefully can find a hackaround.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 593
  • -Receive: 121
  • Posts: 3256
  • Karma: +26/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: USB Audio - Issues with some Devices
« Reply #21 on: January 17, 2021, 02:10:57 pm »
Hi Lars

- On DTape I used. "Record Type -> PCM, 44100, 16bits, mono, microphone."
- For Audio Recorder I'm using "record /a2 /b16 /c1 /f44100".

I had tried back again with 10.237, I attach the trace.

What I did was:
- Boot, attach the mic, run lsusb to confirm it is attached.
- run Dtape - New  ->Record, get the error. I repeated the record again on to get the error a second time.
later
- Command line, and do "record /a2 /b16 /c1 /f44100", get the error. Repeat the command to get the error a second time.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #22 on: January 17, 2021, 06:29:04 pm »
ok, that's why the very same error appears twice (you run it twice).
So for RECORD, I assume that /b16 /c1 /f44100 mean 44100 Hz, 16 bits, mono just like you use for DTAPE, correct ?

What does /a2 mean ?

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #23 on: January 17, 2021, 11:06:12 pm »
ok, try attached. Also try with "playback + record" devices.
Take trace as you did before.
I ONLY updated USBAUDIO.SYS but not yet USBAUD2.SYS. Means, you need to test a audio class 1 device but I think you did. Make sure you do a full minstall as I had to update USBAUDIF.DLL along with the driver.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #24 on: January 17, 2021, 11:27:04 pm »
Sorry, needed to update.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #25 on: January 18, 2021, 01:59:13 am »
and again.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 593
  • -Receive: 121
  • Posts: 3256
  • Karma: +26/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: USB Audio - Issues with some Devices
« Reply #26 on: January 18, 2021, 03:48:11 am »
Hi Lars

I tried your newer driver. The error on DTAPE and Record has changed.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 77
  • Posts: 824
  • Karma: +24/-0
    • View Profile
Re: USB Audio - Issues with some Devices
« Reply #27 on: January 18, 2021, 09:32:38 am »
That's actually a good sign as it gives me a better clue of where it goes wrong.
But please also send me trace. Screenshots help but don't give enough detail of why it goes wrong. But also send screenshots.

Can you please do me a favor and take a trace on recording with DTAPE and RECORD with the 10.237 drivers and a device that at least supports "playback" (in short: one that already worked in the past) ? I'll need to compare and see when and how it succeeds.

In order to not drive you nuts: for the time being it is sufficient to replace USBAUDIF.DLL, USBAUDIO.SYS, USBAUD2.SYS and reboot. Restore these files once you took the trace mentioned above.

You can also send to my private email address. I think you have that.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 593
  • -Receive: 121
  • Posts: 3256
  • Karma: +26/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: USB Audio - Issues with some Devices
« Reply #28 on: January 18, 2021, 03:20:33 pm »
Hi Lars

I uploaded on my last message the "USBAudio-10-238-2021-01-17.ftf" file which has the new error with 10.238.

Here it is the 10.237 using the HP USB headphones that works with playback and recording the mic. Same test by recording a file with DTAPE and record.exe, and later reproduce it to test the playback.

Regards
Martin Iturbide
OS2World NewsMaster
... just share the dream.

Martin Iturbide

  • OS2World NewsMaster
  • Global Moderator
  • Hero Member
  • *****
  • Thank You
  • -Given: 593
  • -Receive: 121
  • Posts: 3256
  • Karma: +26/-0
  • Your Friend Wil Declares...
    • View Profile
    • Martin's Personal Blog
Re: USB Audio - Issues with some Devices
« Reply #29 on: January 18, 2021, 03:24:08 pm »
Hi again.

I thought that the best way will be to create a ticket on the USB Netlabs Trac.
I just created it: http://trac.netlabs.org/usb/ticket/92

But I just noticed that the upload size of files are limited to 256.0 KB. I'm not sure where to fix that on Trac and if is possible with my level access.

Regards
« Last Edit: January 18, 2021, 04:12:02 pm by Martin Iturbide »
Martin Iturbide
OS2World NewsMaster
... just share the dream.