Author Topic: WebCam Driver Question  (Read 4248 times)

Remy

  • Sr. Member
  • ****
  • Thank You
  • -Given: 1
  • -Receive: 15
  • Posts: 410
  • Karma: +0/-0
    • View Profile
Re: WebCam Driver Question
« Reply #60 on: February 14, 2021, 02:00:41 am »
High Martin,

First check your webcam is working.
Try this for video
webcam /m/s |ffprobe -v error -show_entries stream=width,height -of default=noprint_wrappers=1:nokey=0 -i -
You should get default video size if it is working or an error message
If mjpeg isn't working ! try yuyv
webcam /u/s |ffprobe -v error -show_entries stream=width,height -of default=noprint_wrappers=1:nokey=0 -i -

Try this for audio
(from your output, my be you'll have 4 supported sample rate)
webcam /a24000 |ffprobe -v error -show_streams \PIPE\Webcam\Audio |more
You'll find in it 24000 or if not supporting, default supported sample rate is provided into the displayed messages
note: |more for better review messages or you can route them into a text file

You can test other sample rate to find out which ones are supported
Here, same sample rates you can try:
8000  11025 16000 24000 32000 22050 44100 48000

If you get information in both cases, than your webcam works.
Then, after starting webcam /a24000, run ffmpeg -y -i \PIPE\Webcam\Audio -c:a copy audio.wav 
« Last Edit: February 14, 2021, 02:14:42 am by Remy »

Wim Brul

  • Full Member
  • ***
  • Thank You
  • -Given: 5
  • -Receive: 43
  • Posts: 234
  • Karma: +11/-0
    • View Profile
    • Wim's home page
Re: WebCam Driver Question
« Reply #61 on: February 14, 2021, 12:40:59 pm »
Hi Wim

This is what I get:

webcam.exe /a24000:
Code: [Select]
[X:\HOME\DOWNLOADS\WEBCAM00-20210120]webcam.exe /a24000
started.
format:mjpg
 acquire webcam
 set configuration
 negotiate video format
/a server (audio) On-Line.
 obtain video format
 commit video format
 set video alt interface
 set audio frequency
 starting iso video
 set audio mike volume
 set audio alt interface
 starting iso audio
[00000057]
obtain audio error.

Hi Martin, thank you for testing.  The [00000057] error code means parameter error and it occurs because webcam.exe uses the wrong isochronous frame length for audio. I have to correct that. This error has to be corrected first so do not spend more time in trying to get it working for audio.

Wim

P.S. Added: I think I got it fixed. Use the attached Webcam00-20210214.zip and see what does.
« Last Edit: February 14, 2021, 04:40:59 pm by Wim Brul »