Author Topic: YUM libc-01.6.-1 local  (Read 1762 times)

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
YUM libc-01.6.-1 local
« on: January 25, 2021, 04:47:59 pm »
trying to install libc-01.6.-1 via YUM in my pc - that is not connected with the net - i get the message to reboot and restart the program.
when i do this i just get the same message again and again..

ivan

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 52
  • Posts: 1316
  • Karma: +13/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #1 on: January 25, 2021, 07:58:48 pm »
You need the computer to be connected to the internet to be able to use YUM to download the RPM, unpack and install it.

If the computer can not be connected to the internet there is another way you might be able to install it.  First download the RPM file from http://rpm.netlabs.org/release/00/i386/i686/ - you might need to dig about a bit to find what you want.  When you have it downloaded you then need to unpack it using cpio.exe (you may need to run rpm2cpio.first, I forget as I have it setup in a program).  Once you can do that you should be able to extract it to the unixroot directory structure.

I know the RPM/YUM purists will get all up in arms saying you don't do it that way but that is the weak point of the RPM/YUM system since it was introduced years ago by SUSE Linux.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3105
  • Karma: +53/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #2 on: January 25, 2021, 09:09:29 pm »
What I did during my dial up days was have a local repository. Use wget to download the RPM's, optionally copy to a USB stick for the laptop, create the right directory structure, run createrepo, add it to the list of repositories and use YUM or ANPM to install. Worked fine, no internet needed besides the initial download of the RPM's (and if needed the initial setup) and installing createrepo.
Andreas's problem may have been not installing libcx at the same time as libc, not sure how he did it.

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #3 on: February 02, 2021, 09:15:16 pm »
having the same issue with libcx-.0.6.9-2.oc00.i686.rpm

i have older versions of both packages installed.
how can i install both new versions at the same time - if that is the solution?
tried to include both filenames with "quick installation". but that does not work..

@ivan: before i was using zip-files and copied them manually. but i'd really prefer to use yum.
my problem is, that there are many packeges that demand a missing dll which is incuded in other packages that are also not installable due to the same reason.  if i only could install the qt5-packages i'd be able to install many others for example.

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3105
  • Karma: +53/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #4 on: February 02, 2021, 09:47:10 pm »
Have you tried the command line?

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #5 on: February 02, 2021, 09:51:19 pm »
no. what do i need to type there?

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 221
  • Posts: 3105
  • Karma: +53/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #6 on: February 03, 2021, 01:04:08 am »
I think just yum install filename, like
Code: [Select]
yum install libcx-.0.6.9-2.oc00.i686.rpm


Might be yum update.
If that doesn't work, we can try setting up a local repository for you.

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #7 on: February 03, 2021, 03:17:33 pm »
tried. here's what i get:
[E:\DESKTOP]yum install D:\install\repo\libc-0.1.6-1.oc00.i686.rpm
file:///D%3Ainstallrepo/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open
 file /D%3Ainstallrepo/repodata/repomd.xml"
Versuche anderen Spiegel-Server.
Fehler: Cannot retrieve repository metadata (repomd.xml) for repository: local.
Please verify its path and try again

btw. when i start ANPM i get:

"Cannot retrieve repository metadata (repomd.xml) for repository: local. Please verify its path and try again
Temporarily disabling repository: local"

my entry there is:

[local]
name = My local repo
baseurl = file:D:\install\repo
enabled=1

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 184
  • Karma: +1/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #8 on: February 03, 2021, 05:43:29 pm »
tried. here's what i get:
[E:\DESKTOP]yum install D:\install\repo\libc-0.1.6-1.oc00.i686.rpm
file:///D%3Ainstallrepo/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open
 file /D%3Ainstallrepo/repodata/repomd.xml"
Versuche anderen Spiegel-Server.
Fehler: Cannot retrieve repository metadata (repomd.xml) for repository: local.
Please verify its path and try again

btw. when i start ANPM i get:

"Cannot retrieve repository metadata (repomd.xml) for repository: local. Please verify its path and try again
Temporarily disabling repository: local"

my entry there is:

[local]
name = My local repo
baseurl = file:D:\install\repo
enabled=1

did you follow http://trac.netlabs.org/rpm/wiki/RpmHowToEndUsers#LocalRPMrepository ?
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #9 on: February 03, 2021, 07:07:00 pm »
did that.
still it didn't work. realized that the slashes were changed to "\". changed them back to "/"
and the initial erroro message dissappeared ;-)
all works fine so far.
also managed now to install my libc.dll

most of the prevously uninstallabe packages are now installable.
there's only 10 left that won't work (bash, cups, cups-client, cups-libs,db4-utils, openssl, openssl-libs, python and python-libs)
« Last Edit: February 03, 2021, 07:42:17 pm by andreas »

Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 184
  • Karma: +1/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #10 on: February 04, 2021, 09:36:06 am »
did that.
still it didn't work. realized that the slashes were changed to "\". changed them back to "/"
and the initial erroro message dissappeared ;-)
all works fine so far.
also managed now to install my libc.dll

most of the prevously uninstallabe packages are now installable.
there's only 10 left that won't work (bash, cups, cups-client, cups-libs,db4-utils, openssl, openssl-libs, python and python-libs)

no error message no help I'd say. and what does "yum check-update" say? As you can't install whats already installed. "yum update" is needed then.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #11 on: February 04, 2021, 02:11:34 pm »
here are the error mesages:
bash:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-client:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-libs:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

db4-utils:
ERROR with transaction check vs depsolve:db4 = 4.8.30-9.oc00 wird ben”tigt von db4-utils-4.8.30-9.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

readline:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

attached you find a png-file that shows what i get when i ask for updates.


Silvan Scherrer

  • Full Member
  • ***
  • Thank You
  • -Given: 9
  • -Receive: 9
  • Posts: 184
  • Karma: +1/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #12 on: February 05, 2021, 03:52:53 pm »
here are the error mesages:
bash:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-client:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

cups-libs:
ERROR with transaction check vs depsolve:cups-filesystem = 1:2.2.12-1.oc00 wird ben”tigt von cups-1:2.2.12-1.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

db4-utils:
ERROR with transaction check vs depsolve:db4 = 4.8.30-9.oc00 wird ben”tigt von db4-utils-4.8.30-9.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

openssl-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

python-libs:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

readline:
ERROR with transaction check vs depsolve:readln6.dll wird ben”tigt von (installiert) lua-5.3.4-2.i686readln6.dll wird ben”tigt von (installiert) hunspell-1.7.0-2.oc00.i686readln6.dll wird ben”tigt von (installiert) gawk-4.0.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) sqlite-3.28.0-1.oc00.i686readln6.dll wird ben”tigt von (installiert) bc-1.07.1-1.oc00.i686readln6.dll wird ben”tigt von (installiert) gutenprint-5.3.3-2.oc00.i686Bitte melden Sie diesen Fehler unter http://trac.netlabs.org/rpm/

attached you find a png-file that shows what i get when i ask for updates.
you miss packages. using a local repo is working well, but you have to know what you do and how to interpret error messages. as we have no idea what you already have downloaded it's hard to tell which package you exactly miss. but for sure you miss some readline packages. most probably the legacy one.
kind regards
Silvan
CTO bww bitwise works GmbH

Please help us with donations, so we can further work on OS/2 based projects. Our Shop is at https://www.bitwiseworks.com/shop/index.php

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #13 on: February 05, 2021, 04:03:02 pm »
attached you find some screenshots that show all packages i have installed

andreas

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 1
  • Posts: 36
  • Karma: +3/-0
    • View Profile
Re: YUM libc-01.6.-1 local
« Reply #14 on: February 05, 2021, 04:38:04 pm »
installing readline-legacy-6 helped a lot thanks. now there's only the three cups-packages and db4-utils left that don't work.