Author Topic: pmMail and TLS 1.2  (Read 923 times)

Martin Vieregg

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 11
  • Posts: 262
  • Karma: +2/-0
    • View Profile
pmMail and TLS 1.2
« on: July 15, 2021, 07:09:59 pm »
My E-Mail provider sent me an E-Mail some weeks ago that TLS 1.0 and TLS 1.1 is no more supported in the future. Since yesterday, I cannot receive mails anymore with the current pmMail 3.24 version. Sending E-Mails is still working.

I get the very helpful account error message

Code: [Select]
Error: Error 0
I do not find any content about TLS in the pmMail documentation.

The more detailed query in english language is here:
https://www.os2.org/viewtopic.php?p=20613#p20613

Sean Casey

  • Jr. Member
  • **
  • Thank You
  • -Given: 12
  • -Receive: 7
  • Posts: 93
  • Karma: +2/-0
    • View Profile
Re: pmMail and TLS 1.2
« Reply #1 on: July 15, 2021, 08:28:23 pm »
Stunnel, which is provided with PMMail, supports TLSv1.3 tunneling.  Look for the readme in your \PMMail\BIN\Stunnel directory.  Would TLSv1.3 work with your provider?

Martin Vieregg

  • Sr. Member
  • ****
  • Thank You
  • -Given: 0
  • -Receive: 11
  • Posts: 262
  • Karma: +2/-0
    • View Profile
Re: pmMail and TLS 1.2
« Reply #2 on: July 16, 2021, 09:32:20 am »
Thank you for your hints. I added the following to my stunne.conf:

Code: [Select]
;TLS Version (Strato since 7/2021)
sslVersion = TLSv1.2

The first trial failed, because in the General Settings of pmMail 3.24, page Secure Transfer, there was still an old stunnel.exe version selected.

Then I realized that if no sslVersion switch is selected, the new stunnel.exe version also works. It seems that it select TLS 1.2 as default.
« Last Edit: July 16, 2021, 10:15:41 am by Martin Vieregg »