OS/2, eCS & ArcaOS - Technical > Applications

SSH

(1/1)

Rick Smith:
Greetings,

I am trying it again to get ssh working.. Ive given up on sshd running on arca its just not working well.  But I would like to ssh from arca to any number of computers on my network.  I can do this it seems without too much problem just minor visual stuff with TERM.  My problem is I cannot get ssh-agent to work at all, its there I just get a weird error when trying to start it...

unix_listener: cannot bind to path C:\\var\\temp/ssh-FPcXYw7bbYMq/agent.60: Too
many open files in system

I have scoured the internet for this error and while I could find people with the same error all their suggestive fixes are for linux ie 'eval' ssh-agent .. which will not work on arca... I need to get this working as none of my servers allow password authentication and while I can include the key in my ssh command I would like to be able to skip that with ssh-agent.

All help appreciate, hope you are all well.

Rick

Rick Smith:
Greetings.

I solved starting the agent....

However when running ssh-add to add a key I get

could not open a connection to your authentication agent?

Fix one thing break another I guess... ssh and sshd are working well tho.... just would be nice to get agent working...

Rick

Rob:
How did you start the agent? I'm having the same problem.

Navigation

[0] Message Index

Go to full version