OS/2, eCS & ArcaOS - Technical > Hardware

USB 3 and AMD Ryzen third gen processors.

(1/3) > >>

This is more of an observation but... On my MSI B550 motherboard with a Ryzen 3 third gen processor I have noticed an anomaly now that I have been able to switch off the SMT, hyperthreading 'feature' on the MB.

If I plug in a USB stick and start to copy anything to or from it, and I try to use the USB trackball, or a mouse, the pointer freezes in place and it requires a CAD restart to get motion back.

Now I am wondering if this is a problem with our USB 3 driver not being able to do more than one thing at once or do I have to look for something else in the UEFI bios.

Any ideas?

Andreas Schnellbacher:

--- Quote from: Remy on March 06, 2021, 07:00:53 pm ---If I remember, hyperthreading 'feature' was always told not been well supported...

--- End quote ---
"Supported" are only Intel systems with deactivated HT. But Ivan wrote that he has already switched HT off.

Dave Yeo:
Hi Ivan, testing by plugging in a second mouse into my USB3.1 card and USB3 drive also into the card, as soon as I started copying files to the USB HD, the second mouse seized up. First mouse and keyboard plugged into USB2 keeps working fine.
After stopping the copy and ejecting the USB drive, mouse still didn't work. Unplugging and replugging in the mouse brought it back to life.
Hmm, further testing shows the mouse only freezes when actually transferring files, not simply reading and as soon as the copy is over, with the drive still plugged in, unplugging and plugging the mouse back in brings it back to life.
So yes, copying files does seem to screw up the mouse, freezing it, but simply unplugging and plugging back in fixes it here. Never noticed before as I usually use the built in USB2 for most everything.
Do you have one controller or more? If more, using a different port might help and replugging it might be better then CAD.
Tests done with unified wireless mouse + keyboard, only mouse hooked up to the receiver plugged into the USB3.1 port.
Edit, I asked about this on the testers list.

This usually indicates a stalled pipe (of one device) that is not properly cleared. That's typically an error in the class driver, I'd suspect USBMSD.ADD. But it could also be USBMOUSE.SYS.

Hi Dave,

I have tried the 'plug in another USB mouse' on joy although it works on all my other Ryzen gen 1 and gen 2 based systems.  Looking at the block diagram for the MB it would appear there are a number of USB 2 ports as well as the USB 3 ones but the message I am getting from the UFEI bios is that those USB 2 ports work through a USB 3 passthrough, so I am back to wondering why this is happening.  BTW, there is no problem when I run a live linux DVD on that board and copy files to/from a USB stick to a plug in SATA drive.

Thank Lars for your thoughts - any ideas on how to test?

Edit: Just thought I should add the block diagram.


[0] Message Index

[#] Next page

Go to full version