OS/2, eCS & ArcaOS - Technical > Hardware

Quatech SSP-100 Serial Port PCMCIA in ArcaOS

<< < (3/6) > >>

Martin Iturbide:

--- Quote from: ExPLIT on March 15, 2021, 01:16:17 am ---2) SSP100.SYS is definit the serial port driver for SSP-100 PCMCIA Serial card. Installed from Quatech original CD.

--- End quote ---

My mistake I confused "SSP100.SYS" with "SPP100.SYS"

ExPLIT, do you have a version number of the QCOM.SYS and QVCOM.SYS drivers you are using? The latest version I was able to find is 3.23.



--- Quote from: Martin Iturbide on March 15, 2021, 03:28:46 am ---My mistake I confused "SSP100.SYS" with "SPP100.SYS"

ExPLIT, do you have a version number of the QCOM.SYS and QVCOM.SYS drivers you are using? The latest version I was able to find is 3.23.

--- End quote ---
I use the same driver version!.

By the way, problem is solved from other direction:

It seems, that ArcaOS install an old (or not full) implementation of PCMCIA Card Services.
I installed this version:


Which updates PCMCIA Driver but unfortunately not for my Cardbus chipset.
After installing
PCCard Services R5 from Hobbes and reinstalling them afterwards from Selective install i saw, that my Ricoh R5C476 II Name changed in Hardware Manager.
Now its recognised as "CardBus" and not as "Socket Controller".

Now the Qtech SSP-100 is correctly recognised as serial card in the gui.
For the serial port i use PSCOM.SYS
Serial Port is recognised in the device manager.

QCOM.SYS still not working (not recognised the card).

Thanks guys for your help!


Martin Iturbide:

So, the PCMCIA Driver is now working and showing you an inserted PCMCIA card in the GUI. (By using the PCCard_5_2002-04-04.zip driver).

QCOM.SYS is not working, so the "Quatech SSP-100 Serial Port PCMCIA" is not working yet?


Doug Bissett:
I have been sort of following this, but it is not entirely clear what you are really trying to do.

I have two PCMCIA modems, that do work fine (well, I no longer have a telephone line to connect them to, but ZOC communicates with them), when I take the time to set it up properly (they are just serial ports, with a modem attached). PCMCIA is very sensitive to the order of the lines in CONFIG.SYS, and you probably need the /VW switch on the ACPI.PSD line (if you use ACPI.PSD, which you probably should). You would need the proper PCMCIA driver (sounds like you might have that, but see below), and the COM driver (use PSCOM.SYS). All that does (is supposed to do) is create a normal COM port. Check that with the MODE command. Then, if you need software (if any) for the attached device, you need the OS/2 version (a windows driver isn't going to work).

That may be a "pretend" PCMCIA adapter. I found this information for IBM Thinkpads: http://www.thinkwiki.org/wiki/Ricoh_R5C476. Since your machine is actually quite new (in the life span of PCMCIA), you may have one of them (which would require it's own driver, probably not available for OS/2). In ArcaOS go to a command and run C:\sys\install\DETECT\pci.exe to get a list of what is actually attached (be sure to attach everything, then boot, then run the program). That should tell you which PCMCIA controller you actually have. Redirect the output to a file, and post it here.

ArcaOS does not install everything that you will need, but they do supply what is available for supporting the base PCMCIA. You need to supply any other OS/2 drivers that may be required, and add appropriate lines to CONFIG.SYS. It is in the DOCS, but the DOCS are ancient, and they don't tell you the whole story. I suggest getting my LCSS (Logical Config.Sys Sort - it is at HOBBES) to be sure that the lines are in the proper order, and position, in CONFIG.SYS. Also be aware, that "old notebooks" may have more than one serial port built in (possibly only used when attached to a dock). You may also need to have it all connected when you boot so it can do a proper configuration.

You might have better luck (and better performance) with a USB serial adapter, but be sure to get one that is known to actually work. I have a Belkin branded one, that almost works, but it depends on what you actually use it for. Years ago, I was able to operate a modem, but it didn't work with my UPS, or when trying to do a serial port trace.

Hello guys. Need to reopen this topic again. After Update to ArcaOS my PCMCIA Configuration is somehow back to default, and i am not able to activate my SSP-10 again the same way i did it before.

I know PCMCIA and OS/2 / ArcaOS is pain in the ass, but maybe someone can just point me out the main things.

My questions are rather simple:
As i found out earlier, the standard ArcaOS PCMCIA Driver (PCMCIA.SYS) is not the newest.I think its IBM Card Services Version 5.0.
Read somewhere, that the "CardBus Socket Services Version 8.0" ffrom IBM from the Yar 2004 are somehow "broken"
Is that the case, why ArcaOS didnt implement them?

After PCMCIA Installation many drivers are loaded in the config.sys, what thees drivers do, where i can read, what are they for, which parameters theu use etc.


REM (Intel PCMCIA Driver, which recognize my Ricoh Ricoh R5C476(II) just fine

REM (Intel PCMCIA Driver, which is also compatible with my Ricoh Ricoh R5C476(II)



PS: At the moment my Quatech SSP-100 Serial Port PCMCIA Card got the Power, but is recognized as Memory card and not as SSP-100 and i think, the Bridge (or Socket) didnt get the IRQ.
On Windows i got IRQ 20 and 21 for my CardBus Controller (Slots)
IRQ 20 is shared with Realtek LAN Chip.

How i can force the driver to get IRQ 20 and 21?



[0] Message Index

[#] Next page

[*] Previous page

Go to full version