OS/2, eCS & ArcaOS - Technical > Hardware

Quatech SSP-100 Serial Port PCMCIA in ArcaOS

<< < (6/6)

Mark Szkolnicki:
Good Afternoon ExSPLIT!

A Happy New Year to you as well!

I'm glad you found a solution that worked - as I mentioned, people in this forum are very creative in the way we need to approach problems with ArcaOS - many times the solution is unexpected and the solution not perfect, but we have found through the collective memory here, from roughly thirty years of this operating system, to apply legacy solutions to things, as well as find solutions to address current and future issues. We get a lot of help from examining what the very active Linux community does currently, and attempt to use their solutions a lot, adapted to our situation (CUPS support is a perfect example of that, as it has given us access to printers we could not use otherwise)

--- Quote from: ExPLIT on December 31, 2021, 03:29:28 am ---
Thanks Mark for the long and very useful answer!

I think i have solved (kind of) the puzzle:
Got my Quatech SSP-100 PCMCIA Card recognised with PCMCIA Socket Services 8.0.
PCMCIA Controller Driver, which i succesflully used is Intel SS2PCIC.SYS
commercial Driver APSoft SSPCIC.SYS also recognizes my PCMCIA Controller Ricoh R5C476 II but i got it not working with it.

--- End quote ---

As I mentioned previously, there are so many different drivers out there related to PCMCIA controllers especially and many I remember seeing in the past were even named the same but were totally different - sometimes you had to examine what date the driver was created to see which version was the correct one.

--- Quote ---
The magic tric was in this line:

While the ArcaOS Socket Services 5.0 need the /R:500 to operate in the 5.0 Version of socket Services (Default one is 2.0)
in the newer IBM Socket Services 8.0 this switch should be removed.

After i removed /R:500 switch, i got the message, that the Card Services Version are 8.0 and suddenly the SSP-100 was recognized as a Modem (COM1), got Power and seems to work.

--- End quote ---

Also not surprising.

If you are following a discussion in another thread, on Zip IDE drives, you will find mention of the Danis506 hard drive driver, which was contributed originally by Daniela Engert, who was very talented at developing those types of drivers, being a software engineer - without her Dani drivers ArcaOS would not exist now, as IBM discontinued enhancing their hard drive support driver years before.

A driver version may have the same name but, because its been updated or enhanced, certain switches may be legacy or may be obsolete or only needed under certain circumstances.

From EDM/2 (http://www.edm2.com/index.php/PCMCIA.SYS )

PCMCIA.SYS - This Card Services driver for OS/2 provides base support for PC Cards:

/R:200  Specify that card services will conform to the PCMCIA 2.0 standard. This is the default value.
/R:500  Specify that card services will conform to the PCMCIA 5.0 standard instead of the PCMCIA 2.0 standard which is the default value.
/P In previous releases, this parameter disabled the hardware interrupt which was used by OS/2 Socket Services drivers to notify clients of a change in status. Neither the new Card Services nor Socket Services drivers for OS/2 use a hardware interrupt to signal PCMCIA status changes. So this parameter is no longer needed.

So the /R:500 switch was needed for v5, as you mentioned - it is obviously not necessary  and obsolete for v8.0 of Cardbus.

--- Quote ---
PS: Sorry, I don't find yet an Screenshot tool for ArcaOS, so i made some pictures:

--- End quote ---

I use a very useful piece of legacy software called PMView


The OS/2 version still works and is updated occasionally but is a for pay software.

It can do screen capture and read and display many graphics types as well as other features.

--- Quote ---
Hardware Manager, PCIINFO and Card Services.

The most curious thing that i found out (might be also useful for another Ricoh R5C476II CardBus enabled Notebooks (Like ThinkPads X2x, X4x, A30):
Later ThinkPads (like X3x, X4x, X6x, T4x) have later Ricoh Cardbus Controller, which also emulates R5C476II.

The PCMCIA Serial Card is only enabled and got Power, when an FAT-formatted SD-Card is in the SD-Card slot  !
The sound absolutely unbelievable, but when i boot without SD-card in the slot - the PCMCIA Card didn't get power and is not recognized at all.

Here are relevant parts of my CONFIG.SYS:

REM *** PCCARD 8 ***

--- End quote ---

I suspect one of the device statements above may be the culprit - as I mentioned, if your not planning to use any other PCMCIA devices you can probably comment them out. I guess it depends on how the removable SD card reader is being handled by ArcaOS (if it is - can you read the card, is a drive letter assigned for it, and if so is the drive readable or unreadable?).

We have many SD readers that are not able to be read under ArcaOS.

From EDM/2 ( http://www.edm2.com/index.php/PCM2ATA.ADD)

PCM2ATA.ADD - Driver for PCMCIA hard disk drives.

/S:n - Specifies the number of PC Card slots. /S:1 shows that there is only one PC Card slot. When this parameter is not set, the number of PC Card slots is set to 2.
/P:hhhh - Specifies the lower limit for the I/O address of the ATA card. The device driver assigns the next usable I/O address from this lower limit to the card. When this parameter is not set, the device driver looks for a usable address and assigns it to the card.
/EXIRQ:n - Specifies the IRQ level that is not assigned to the card. You can set more than one IRQ level.
/NOBEEP - Specifies not to beep when a storage card is installed. When this parameter is not set, you will hear a beep every time a storage card is installed into the PC Card slot.
 /B - Specifies that OS/2 has started from an ATA card. When this parameter is set, there will be no redundancy in assigning the logical drive to the slot where OS/2 was booted. It depends on the ATA card whether you can start OS/2 from it.
/STBTIME:n - Specifies the time (from 1 to 21 minutes) until entering standby mode. When the ATA card is not accessed for the time specified by this parameter, the ATA card enters standby mode (only when your ATA card supports standby mode). When this parameter is not specified, standby mode for the ATA card is disabled.
/MDRV:n - Specifies the number of extra drives that can be used in addition to the number of PC Card slots available for the PCMCIA storage devices. When this parameter is not specified, no extra drive is given to the device driver. The extra drives can be activated by the PCMCIA ATA Card Mount utility.
/!DM - Specifies not to use OS2DASD.DMD as the device manager. When this parameter is set, OS2PCARD.DMD is used instead.

From https://groups.csail.mit.edu/mac/ftpdir/thinkpad/old-archive/HTML/tp-1998/msg00867.html

OS2PCARD.DMD : Storage Driver for OS/2
PCMSSDIF.SYS :Storage Driver for OS/2 (Interface)
PCM2SRAM.SYS - Storage Driver for OS/2 (SRAM)
PCM2FLSH.SYS - Storage Driver for OS/2 (FLASH)
FLSH2MTD.SYS :Storage Driver for OS/2 (FLASH MTD)   

As those all have to do with storage or memory, that might solve your problem related to the SD Card, but again you also can keep things as they are - sometimes if it ain't broke you don't fix it.

2Martin - I also included the references above for your Wiki's, if it is useful  M

--- Quote ---

--- End quote ---

I ran into this statement related to the Quatech Drivers in the OS2COM.PDF which may explain whats happening:

2.3.4 Quatech PCMCIA Serial Port Adapters

Do not place parameters on the QCOM.SYS command line for these products.
The client device drivers take parameters for PCMCIA serial ports. See the client
driver documentation for details.

So I assume that it is the SSP-100 driver that is providing the info, as the SSP-100 manual indicates it is a "parent/child device". However it also might be that the QCOM driver needs to be placed where PSCOM.SYS is. But as I've said, no need to fix if it is working the way you want it.

The explanation may also be below.

--- Quote ---


Quatech QCOM and QVCOM Drivers did not find UART and i have disabled them. For now i use PSCOM and VCOM.
PSCOM need to be set to COM2 (2, 3F8, 4), otherwise SSP100.SYS cant use COM1. A bit strange, but for now it works.
I am happy, that the whole story somehow find an happy end. Learned a lot.... :)

--- End quote ---

I still suspect some other serial device is present in your computer ExPLIT that is taking the first COM it can find, unless you override the statement as you did above.

Reading up on PSCOM.SYS ( http://www.edm2.com/index.php/PSCOM.SYS ), I see it is required for serial communications on ACPI systems of which ArcaOS is one, with the following parameters:

/V - Verbose
/W - Wait verbose mode. Displaying pauses with a "Press Enter to continue..." message.
/F - Find COM ports on PCI combo (serial/parallel) cards automatically.

Also to specify address and interrupt manually, it indicates to use the syntax (port,address,IRQ), e.g.:
Set COM3 and COM4 at address 3E8 on IRQ 4 and 2E8 on IRQ 3 which you did.

it does not indicate whether it is a direct replacement for COM.SYS but it has the same switches, so I assume it is.

That could also explain the reason the QCOM drivers do not work - it also makes me wonder whether, if I upgrade the tower with the Quatech ESD-100D card, whether the extra COM ports there will not work - an interesting experiment to try (I have two OS/2 based partitions on each system so nothing lost in way of functionality if that does occur.

2Martin - another little tidbit that may help someone in future.

Perhaps whoever writes and maintains PSCOM.SYS can enlighten us as to its capabilities (and how it interacts with VCOM.SYS or not.

But thank you for the post, ExPLIT as I've learned quite a bit here as well - hope everything you wanted works out for the best and a fine day to you!


Dave Yeo:
For screen capture, the official application that will (does?) ship with ArcaOS is https://hobbes.nmsu.edu/download/pub/os2/apps/graphics/scrncapt/Gotcha_2-0-1-0.wpi simple and works.
I also use Embellish, I believe this was the last one and includes registration info, https://hobbes.nmsu.edu/download/pub/os2/apps/graphics/paint/Embellish_2-02.zip
Of course PMView is perhaps the best currently supported one.


[0] Message Index

[*] Previous page

Go to full version