Author Topic: Virtualbox, eCS and USB 12.08  (Read 885 times)

Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 78
  • Posts: 834
  • Karma: +25/-0
    • View Profile
Virtualbox, eCS and USB 12.08
« on: April 11, 2021, 10:04:26 pm »
I am using eCS under Virtualbox (currently version 6.1.16).
I just tried to install USB 12.08, as a first test, I only enabled USB 2.0 (OHCI and EHCI) under Virtualbox.
However, when I restart the system, the desktop will hang. I attempted to repair the desktop and also tried to restart multiple times but the result is always the same. I reverted back to my own USB driver set and the desktop will properly populate. I had commented out any drivers that might cause a problem.

Anyone have any experience with USB 12.08 under Virtualbox ? Only with ArcaOS or also with eCS ?

Rene Hvidsoe

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Posts: 44
  • Karma: +0/-0
    • View Profile
Re: Virtualbox, eCS and USB 12.08
« Reply #1 on: April 12, 2021, 08:06:16 am »
Hi Lars,

I have tried Arcanoa USB 12.08 under ArcaOS 5.06 on real HW and have same issue. Desktop hangs everytime. When go back to USB 12.07 of Arcanoa drivers all works normally again.

Needs more test why happens.


Lars

  • Hero Member
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 78
  • Posts: 834
  • Karma: +25/-0
    • View Profile
Re: Virtualbox, eCS and USB 12.08
« Reply #2 on: April 12, 2021, 11:00:39 am »
It's a comforting thought that I am not the only one.
And since it happens also on real HW, I can be sure that someone will file a bug :-)

Pete

  • Hero Member
  • *****
  • Thank You
  • -Given: 1
  • -Receive: 51
  • Posts: 1098
  • Karma: +4/-0
    • View Profile
Re: Virtualbox, eCS and USB 12.08
« Reply #3 on: April 12, 2021, 04:52:09 pm »
Hi All

No problem booting to a working AN 5.0.5+ Desktop on real hardware with usb12.08 installed here.

However, I may be seeing a related problem: shortly after copying files to or from USB2 or USB3 attached drives I get a system hang - locks up solid, no mouse or keyboard - requiring a reboot via press of Reset button. This hang happens around a couple of minutes after copying has finished and USB drive is ejected. REMming out the config.sys xhcd lines makes no difference.

A couple of hours ago after copying some files to USB2 drive and ejecting USB2 drive I fired up Seamonkey visited these forums started scrolling the current VSlick discussion and had a TRAP - should have taken a photo... Doubt if it was an os2world.com problem, wonder if it was related to the system hangs mentioned above.

I do not see these problems with 12.07


Regards

Pete

Dave Yeo

  • Hero Member
  • *****
  • Thank You
  • -Given: 13
  • -Receive: 226
  • Posts: 3153
  • Karma: +59/-0
    • View Profile
Re: Virtualbox, eCS and USB 12.08
« Reply #4 on: April 12, 2021, 06:08:12 pm »
Come to think of it, I'm also getting hangs, usually after starting SM, which takes a while to start here, too many tabs open. I was blaming SM.
Today, it happened twice, first time I hit the big red button. 2nd time I walked away, came back after 5 or more minutes and the system had come back to life. It is weird because even the mouse cursor stops moving, no keyboard or anything but it does usually eventually return to life. I've been running the 12.08 versions for a while and hadn't associated the lock ups with it.
OTOH, I no longer lose a mouse plugged into the XHCI port when copying files to a USB3 drive.
Anyways, might be an idea to wait for quite a while to see if the system comes back to life

Neil Waldhauer

  • Hero Member
  • *****
  • Thank You
  • -Given: 14
  • -Receive: 62
  • Posts: 747
  • Karma: +20/-0
    • View Profile
    • Blonde Guy
Re: Virtualbox, eCS and USB 12.08
« Reply #5 on: April 13, 2021, 05:12:46 am »
I just installed USB 12.08 on my Virtual Box system. No problems observed so far.

Maybe it is widescreen that is causing your crash? ;)
Expert consulting for ArcaOS, OS/2 and eComStation
http://www.blondeguy.com