OS/2, eCS & ArcaOS - Technical > Setup & Installation

Booting with NVMe

<< < (2/5) > >>

Greg Pringle:
I had tried the USB stick method and there was a hang after leaving the config.sys editor after the end on the manual install F10. I will some variations.

David McKenna:
 I've also been struggling to get this to work. I put NVME.ADD in the root of the USB ArcaOS 5.0.6 install boot drive. Booted from it, choose boot with own values, add the NVME driver on the drives page, checked config.sys - the driver is listed as BASEDEV=NVME.ADD, hit F10, the boot continues, then hangs at the ArcaOS logo (needs a hard reboot). Tried different orders of disk drivers, but all hang.

 The driver works fine booted from my SATA drive, and I have created a volume on the NVME drive and formatted it and copied files back and forth with no issues. Just can't seem to boot with it loaded on the USB boot stick...


Neil Waldhauer:
If you want to boot from NVMe drive, and you use AirBoot, how are you going to install AirBoot on NVMe drive? That's why you need to boot from the installer USB stick.

If you have another drive besides NVMe one, better read this page from the Arca Noae wiki.


Doug Bissett:
I got a Vantec PCIe adapter, and installed a 250 GB Samsung 980 PRO (PCIe 4.0 NVMe M,2). It works well, after the driver loads, but I cannot boot from it. The problem is that it is mounted on a plug in card, that the BIOS doesn't know about, so it won't boot from it (because it doesn't know it is there). Air Boot also cannot "see" it, because BIOS doesn't know about it. Most (if not all) machines cannot boot from a plug in card, if the BIOS doesn't know about it. This is true for USB too.

If you have a machine, that knows about the adapter, it should boot from it.

Then again, it really doesn't make much sense to waste one of those things for boot code, unless you boot 14 times a day, or it is your only choice. I am still thinking about how to use it effectively. At least it is non volatile, so it remembers what was put on it, unlike what the RAMDISK does.

David McKenna:

 I don't use Air-boot. The problem was I couldn't boot the install USB stick with the NVME driver added (it worked without NVME), but it turns out somehow unexpectedly /VW was being added to the ACPI.PSD line in CONFIG.SYS only if I choose to add NVME - no idea why - so I removed the /VW and now can boot the USB install stick with NVME. Now to try installing...



[0] Message Index

[#] Next page

[*] Previous page

Go to full version