Author Topic: Help Appreciated: ArcaOS Installation Adventure on Thinkpad T480 with NVMe Disk  (Read 5852 times)

Sigurd Fastenrath

  • Hero Member
  • *****
  • Posts: 577
  • Karma: +27/-0
  • OS/2 Versus Hardware - Maximum Warp!
    • View Profile

it is time for me to try to shift "Bare Metal Arcaos" to a new level: I am trying to install ArcaOS 5.0.6 from USB Stick on my Thinkpad 25/2. In fact it is a self assembeld Thinkpad T480 in a Thinkpad 25 case. The "originally" Thinkpad 25 was based on a T470 Model, with Intel core i7 7th Generation. As the 8th Generation was such a boost, I decided to modify one on my own, inspired by an internet blog.

I will report here my tries and fails, trials and errors, as well as success, if it may happen. The availability of the NVMe Driver developed by ArcaNoae opended this door.

Thanks a lot for this new tremendous effort, Arca Noae!
And another driver enhancement gives me hope: Paul Smedleys Uniaud driver.

Last year I was able to get ArcaOS to run on this T25/2, but that time I had an AHCI SSD and the sound did not work that time. I already did have ArcaOS to run on the Originally Thinkpad 25, but had to swap the NVMe that time with the AHCI SSD.

Edit: this Installations have all been made by cloning with dfsee, due to the lack of USB 3 drivers at that time.

As I do not want to open and close (assemble and disassemble) the Thinkpad very often - it has some really stupid plastic things, that are easy to break and not to fix, I assembeld it with an 1 TB NVMe Drive, and hoped to see the NVME OS/2 driver to come alive. And here it is. :)

So, this evening I started from scratch.

I really appreciate your hints and tipps and your help!!! Please do not hesitate to write your thoughts and opinions! Well, but it does not make sense to discuss about the reason "WHY I do this" and "That it does make no sense". No chance to persuade ;D me

So, first a brief introduction to the hardware (this Laptop has each and any Top hardware, that was available for the Lenovo T480 generation, I tried to maximize it in every way):

Hardware Specs:

- Thinkpad 25 Palmrest, LCD Cover, Keyboard, Trackpad, Touchpad
- Thinkpad T480 Hardware:
- Intel Core i7-8650 CPU, 4 cores, 4 threads
- 32GB RAM
- Nvidia 150MX Graphic with 2 GB
- Smart Card Reader
- Fingerprint Reader
- Windows Hello camera
- Web Camera
- USB 3 and Thunderbolt 3
- SD Card Reader (Full Size)
- Intel LAN (perfect for Intel 1000EB driver from ArcaNoae)
- Intel WLAN
- Fibocom WWAN
- FullHD Screen with Touch Support (!)
- Samsung EVO 970 1TB NVMe
- Two batteries, one swapable

Special BIOS Settings:

- Disable Secure Boot
- Enable Boot Option "Boot both, UEFI and Legacy, Legacy First"

Already installed software:

- Used DFSEE to create the following SSD Layout:
- MBR Mode
- AIRBoot Manager 1.1.4 installed
- Partition 1, Primary, 16GB, for ArcaOS
- Partition 2, Primary, 150GB, Windows 10 64 Pro already installed
- Remaining Space an SSD left free so far

Next Post is about my first attempt to install.
« Last Edit: April 17, 2021, 02:47:16 pm by Sigurd Fastenrath »

Sigurd Fastenrath

  • Hero Member
  • *****
  • Posts: 577
  • Karma: +27/-0
  • OS/2 Versus Hardware - Maximum Warp!
    • View Profile
This evening my first attempt, so far promising but not succesfull.

First I created an ARCOS 5.0.6 USB Stick as described in the Readme.
In addition I copied the files
to the Boot directory of the stick (as mentioned in the other Thread here in this Forum about "Installation NVme"

I plugged in the Stick and started.

During Start of the Laptop I pressed F12 and choosed the USB Stick as boot media.

The adventure begins  ;D

On the first picture ( I am still not able to figure out how to place pcitures here in this text )you can see, that it boots from the Stick.

And you can see the first "problem" as well: what I call the "memory hole", it recognizes only 1 of the 32 GB RAM.

The process itself goes well, and so you can see in the second and third picture, that it starts in bare metal, the T480.

On the fourth and fifth picture you can see the Preeboot Options that I left as they are, well done ArcaNoae!

The sixth picture shows the two things I marked (Well switching to German is a "minority change" I would guess ::) ):
- Edit config.sys before boot (i do really appreciate this point! Arca Noae makes it really easy to add drivers this way!)
- Skip hardware validation (this makes it easier for me when Windows i.e. is already installed)

The seventh Picture shows the ongoing boot after I pressed F10.

Picture 8 shows the Editor window that opened almost imediatly, and the Line I added there:
I added the /V Switch to be able to see if the driver loads or not

The ninth Pictures proofs, the Driver is loaded! Great!

But then, the installation stops complainig: can not find the ARCAINST.ISO file (see Picture 10).

Picture 11 does proof, that this file is on the stick.

So, what do you suggest, what did go or what did I made wrong?

Stay tuned for more! :D

Sigurd Fastenrath

  • Hero Member
  • *****
  • Posts: 577
  • Karma: +27/-0
  • OS/2 Versus Hardware - Maximum Warp!
    • View Profile
Here the last 5 Pictures:


  • Hero Member
  • *****
  • Posts: 1303
  • Karma: +9/-0
    • View Profile
Hi Sigurd

I have bumped into this problem on my Desktop system.

The underlying problem is that the usb stick failed to reattach during the boot process - the system ejects the usb stick and reattaches it as part of the boot process.

After a lot of faffing around I came to the conclusion that the fault was with the usb stick in use as install continued when using a different make usb stick. The usb sticks that failed were both "cheapies" off ebay.

During the "faffing" mentioned above I did manage to get install to continue with 1 of the "cheapies" by physically removing the usb stick and reinserting just before the system looked for the usb stick. Timing is critical and I cannot remember the exact point of reinsertion but the usb stick can be removed after booting from "Menu for own choices" continues. Sorry I cannot be more helpful about timing.


I created a bug report and checking it I wrote:-

Yes, it is possible to unplug then plug back in but timing is very critical.
I unplugged the stick when the sticks led indicator was extinguished just after leaving "Menu for own choices" and plugged back in when I saw some network lines appear onscreen... very shortly before the pmshell call. This got me through Phase1. However, I missed inserting stick quickly enough after the reboot into Phase2.

So, you will have to be "on your toes" to get the usb stick reinserted in time  :-)

Not sure if anything else in the bug report will be of use

Good Luck


Dave Yeo

  • Hero Member
  • *****
  • Posts: 4855
  • Karma: +102/-1
    • View Profile
I have to say that I have now had 2 USB sticks fail while testing ArcaOS, both in subtle ways where they looked good but did not always attach or on one wouldn't boot at times. While not cheap, they weren't expensive and were both fairly old, with the 1st one being one of the first I ever bought, back when 2GB's seemed huge.
Definitely worth trying a new stick.

Sigurd Fastenrath

  • Hero Member
  • *****
  • Posts: 577
  • Karma: +27/-0
  • OS/2 Versus Hardware - Maximum Warp!
    • View Profile
Thanks for the hints! In the end - I tested the USB Stick with the Lenovo Yoga 12 I have and had the same fail - it turned out to be a hardware Problem and I had success!  :D

The long story with pictures will come tomorrow, I just write via Firefox from the T480!